aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2022-07-17 16:44:35 +0000
committerStefan Eßer <se@FreeBSD.org>2022-07-17 16:44:35 +0000
commitfe74bc4851d9dd76ea5384885db1ee07f88c65c9 (patch)
tree1a7532eb435fb2b40bb658722b50c6e5e2597223
parent9e2b046577596b2aec3d4767383469d8966549bf (diff)
downloadports-fe74bc4851d9dd76ea5384885db1ee07f88c65c9.tar.gz
ports-fe74bc4851d9dd76ea5384885db1ee07f88c65c9.zip
audio/espeak-ng: add espeak to CONFLICTS_INSTALL
The espeak package has been replaced by espeak-ng, but since the pkg command does not understand that the latter replaces the former, it is possible that "pkg upgrade" tries to install espeak-ng on a system that already has espeak installed. Create and plan to keep the CONFLICTS_INSTALL entry for some time in order to let the pkg command know that it cannot install espeak-ng without prior deinstallation of espeak.
-rw-r--r--audio/espeak-ng/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/audio/espeak-ng/Makefile b/audio/espeak-ng/Makefile
index 5b1d8d7e35fc..cebff200e16d 100644
--- a/audio/espeak-ng/Makefile
+++ b/audio/espeak-ng/Makefile
@@ -2,7 +2,7 @@
PORTNAME= espeak-ng
PORTVERSION= 1.51.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= audio
#MASTER_SITES= https://github.com/espeak-ng/${PORTNAME}/releases/download/${PORTVERSION}/
@@ -21,7 +21,7 @@ USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-pcaudiolib
-CONFLICTS_INSTALL= speak
+CONFLICTS_INSTALL= espeak speak
OPTIONS_DEFINE= DOCS