aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-08-27 10:26:11 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-08-27 10:26:11 +0000
commitfe8ed9605454c28f8f7f576741220b7092f2dcdb (patch)
tree2dc8095551ef7289828de989bc8c94e5d1dbce0b
parenta8af098b8c1cbb04e009208a1f384b0ef629b4a8 (diff)
downloadports-fe8ed9605454c28f8f7f576741220b7092f2dcdb.tar.gz
ports-fe8ed9605454c28f8f7f576741220b7092f2dcdb.zip
lang/python310: Fix disabling uuid.h detection and stage-qa error
- Bump PORTREVISION for package change ====> Running Q/A tests (stage-qa) Error: /usr/local/lib/python3.10/lib-dynload/_uuid.cpython-310.so is linked to /usr/local/lib/libuuid.so.1 from misc/e2fsprogs-libuuid but it is not declared as a dependency Warning: you need LIB_DEPENDS+=libuuid.so:misc/e2fsprogs-libuuid ... Warning: Possible REINPLACE_CMD issues: - - REINPLACE_CMD ran, but did not modify file contents: setup.py
-rw-r--r--lang/python310/Makefile5
-rw-r--r--lang/python310/files/patch-configure23
2 files changed, 23 insertions, 5 deletions
diff --git a/lang/python310/Makefile b/lang/python310/Makefile
index f2ec1104c73f..37d9ec6fffc6 100644
--- a/lang/python310/Makefile
+++ b/lang/python310/Makefile
@@ -1,5 +1,6 @@
PORTNAME= python
DISTVERSION= ${PYTHON_DISTVERSION}
+PORTREVISION= 1
CATEGORIES= lang python
MASTER_SITES= PYTHON/ftp/python/${DISTVERSION:C/[a-z].*//}
PKGNAMESUFFIX= ${PYTHON_SUFFIX}
@@ -122,10 +123,6 @@ PLIST_SUB+= SUPPORTED_OPENSSL=""
.endif
post-patch:
-# disable the detection of includes and library from e2fsprogs-libuuid,
-# which introduces hidden dependency and breaks build
- @${REINPLACE_CMD} -e 's|uuid/uuid.h|ignore_&|' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e '/find_library_file/ s|uuid|ignore_&|' ${WRKSRC}/setup.py
# disable detection of multiarch as it breaks with clang >= 13, which adds a
# major.minor version number in -print-multiarch output, confusing Python
@${REINPLACE_CMD} -e 's|^\( *MULTIARCH=\).*--print-multiarch.*|\1|' ${WRKSRC}/configure
diff --git a/lang/python310/files/patch-configure b/lang/python310/files/patch-configure
index c78047439605..1890947cf0d6 100644
--- a/lang/python310/files/patch-configure
+++ b/lang/python310/files/patch-configure
@@ -1,4 +1,7 @@
---- configure.orig 2022-02-23 19:52:00 UTC
+Disable the detection of includes and library from e2fsprogs-libuuid, which
+introduces hidden dependency and breaks build
+
+--- configure.orig 2022-08-01 20:25:27 UTC
+++ configure
@@ -6625,7 +6625,7 @@ fi
@@ -9,3 +12,21 @@
if test -n "$ac_tool_prefix"; then
# Extract the first word of "${ac_tool_prefix}llvm-ar", so it can be a program name with args.
+@@ -10123,7 +10123,7 @@ fi
+ # Dynamic linking for HP-UX
+
+ # checks for uuid.h location
+-for ac_header in uuid/uuid.h uuid.h
++for ac_header in uuid.h
+ do :
+ as_ac_Header=`$as_echo "ac_cv_header_$ac_header" | $as_tr_sh`
+ ac_fn_c_check_header_mongrel "$LINENO" "$ac_header" "$as_ac_Header" "$ac_includes_default"
+@@ -10141,7 +10141,7 @@ done
+ $as_echo_n "checking for uuid_generate_time_safe... " >&6; }
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+-#include <uuid/uuid.h>
++#include <uuid.h>
+ int
+ main ()
+ {