aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2023-04-26 20:53:59 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2023-04-26 20:55:50 +0000
commitfefa73016dbcf3948d640da8ea9236b1a9b6b73f (patch)
tree96dae19d4073aa3aaaeb6eadf29a084f5589aeb6
parent435769a87614fbe5d4eab67111657aabcfa9f870 (diff)
downloadports-fefa73016dbcf3948d640da8ea9236b1a9b6b73f.tar.gz
ports-fefa73016dbcf3948d640da8ea9236b1a9b6b73f.zip
x11/py-pyautogui: New port: lets Python control the mouse and keyboard, and other GUI automation tasks
PyAutoGUI is a cross-platform GUI automation Python module for human beings. Used to programmatically control the mouse & keyboard.
-rw-r--r--x11/Makefile1
-rw-r--r--x11/py-pyautogui/Makefile26
-rw-r--r--x11/py-pyautogui/distinfo3
-rw-r--r--x11/py-pyautogui/pkg-descr2
4 files changed, 32 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index d948980fb968..daaa5d9c6d31 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -312,6 +312,7 @@
SUBDIR += py-i3-quickterm
SUBDIR += py-i3ipc
SUBDIR += py-mouseinfo
+ SUBDIR += py-pyautogui
SUBDIR += py-pynput
SUBDIR += py-pyscreenshot
SUBDIR += py-pyscreeze
diff --git a/x11/py-pyautogui/Makefile b/x11/py-pyautogui/Makefile
new file mode 100644
index 000000000000..bea1a35ccb8b
--- /dev/null
+++ b/x11/py-pyautogui/Makefile
@@ -0,0 +1,26 @@
+PORTNAME= pyautogui
+DISTVERSION= 0.9.53
+CATEGORIES= x11 python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= PyAutoGUI-${DISTVERSION}
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= lets Python control the mouse and keyboard, and other GUI automation tasks
+WWW= https://github.com/asweigart/pyautogui/
+
+LICENSE= BSD
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}python-xlib>0:x11-toolkits/py-python-xlib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pymsgbox>0:devel/py-pymsgbox@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytweening>0:devel/py-pytweening@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyscreeze>0:x11/py-pyscreeze@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}mouseinfo>0:x11/py-mouseinfo@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= distutils autoplist
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/x11/py-pyautogui/distinfo b/x11/py-pyautogui/distinfo
new file mode 100644
index 000000000000..ef262012272a
--- /dev/null
+++ b/x11/py-pyautogui/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1682517697
+SHA256 (PyAutoGUI-0.9.53.tar.gz) = d31de8f712218d90be7fc98091fce1a12a3e9196e0c814eb9afd73bb2ec97035
+SIZE (PyAutoGUI-0.9.53.tar.gz) = 59031
diff --git a/x11/py-pyautogui/pkg-descr b/x11/py-pyautogui/pkg-descr
new file mode 100644
index 000000000000..c9ae9ce76d1f
--- /dev/null
+++ b/x11/py-pyautogui/pkg-descr
@@ -0,0 +1,2 @@
+PyAutoGUI is a cross-platform GUI automation Python module for human beings.
+Used to programmatically control the mouse & keyboard.