aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2023-09-11 19:07:14 +0000
committerMatthias Andree <mandree@FreeBSD.org>2023-10-09 16:19:43 +0000
commitfff0cd6cf3ae5141f7f588e27b8e71839ee742be (patch)
tree622a870d1ff13418cac9074975aa5c77f9a82145
parentf1cfb904cc32238e28dc034d6738681e548b3a94 (diff)
downloadports-fff0cd6cf3ae5141f7f588e27b8e71839ee742be.tar.gz
ports-fff0cd6cf3ae5141f7f588e27b8e71839ee742be.zip
graphics/rawtherapee: drop USE_GCC...
...to unblock the GCC-13-as-default upgrade. PR: 273682 Reported by: salvadore@
-rw-r--r--graphics/rawtherapee/Makefile21
1 files changed, 4 insertions, 17 deletions
diff --git a/graphics/rawtherapee/Makefile b/graphics/rawtherapee/Makefile
index 10d89e4bf4fc..b6c4b7731919 100644
--- a/graphics/rawtherapee/Makefile
+++ b/graphics/rawtherapee/Makefile
@@ -1,6 +1,6 @@
PORTNAME= rawtherapee
PORTVERSION= 5.9
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= graphics
MASTER_SITES= https://rawtherapee.com/shared/source/ \
LOCAL/mandree/
@@ -25,27 +25,15 @@ LIB_DEPENDS= \
libsigc-2.0.so:devel/libsigc++20 \
libtiff.so:graphics/tiff
-USES= cmake desktop-file-utils compiler:gcc-c++11-lib gnome \
+USES= cmake desktop-file-utils compiler:c++11-lang gnome \
jpeg localbase:ldflags pkgconfig tar:xz
# Binutils required for LTO (base ar/nm/ld/ranlib don't work)
USE_BINUTILS= yes
-# As of 2019-09-29, this port is known to be miscompiled by clang90
-# (SIGSEGV or SIBGUS).
-# So we shall stick to a modern GCC for now,
-# XXX FIXME note that rawtherapee is somewhat sensitive
-# versus compiler details so we may need to pin GCC 9.x
-# or a version range.
-USE_GCC= yes
-
USE_GNOME= gtkmm30 librsvg2
-_LTO_FLAGS= -flto=${MAKE_JOBS_NUMBER}
-# gcc needs -flto=${MAKE_JOBS_NUMBER} for parallel link (fixed in GCC 10?)
-# and does not understand -flto=thin
-#
-# llvm/clang needs -flto=thin and will automatically parallelize the link
+_LTO_FLAGS= -flto=thin
# Fix <https://bugs.freebsd.org/251041>:
# 11.x has binutils that don't accept a --plugin option,
@@ -64,9 +52,8 @@ CMAKE_ARGS+= -DDOCDIR="${DOCSDIR}" \
-DDATADIR="${DATADIR}" \
-DCACHE_NAME_SUFFIX="" \
-Wno-dev \
- -DCMAKE_AR:FILEPATH=${_AR} \
- -DCMAKE_RANLIB:FILEPATH=${_RANLIB} \
-DCMAKE_POLICY_DEFAULT_CMP0056:STRING=NEW
+
# 3.4.x: CMAKE_EXE_LINKER_FLAGS is not passed to TRY_COMPILE by default
# any more. The CMP0056 policy must be explicitly set to NEW to ensure
# linker flags are passed. Else -lomp is not found with clang.