aboutsummaryrefslogtreecommitdiff
path: root/Mk/Uses/go.mk
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-06-23 11:50:41 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-06-23 11:50:41 +0000
commitc76d322aa6afa818af9b8c37542056532cab05e5 (patch)
treed49e37d6eb04a27ce2135e7a29630ea89ed0b00d /Mk/Uses/go.mk
parent9a3c0ab0ca729211fea79137807c6fc92fc425d2 (diff)
downloadports-c76d322aa6afa818af9b8c37542056532cab05e5.tar.gz
ports-c76d322aa6afa818af9b8c37542056532cab05e5.zip
Mk/Uses/go.mk: Allow overriding the Go port
This is intended to be used for regression testing of USES=go ports with lang/go-devel. Submitted by: dg@syrec.org Differential Revision: https://reviews.freebsd.org/D20570
Notes
Notes: svn path=/head/; revision=504942
Diffstat (limited to 'Mk/Uses/go.mk')
-rw-r--r--Mk/Uses/go.mk9
1 files changed, 8 insertions, 1 deletions
diff --git a/Mk/Uses/go.mk b/Mk/Uses/go.mk
index ac488a91c106..21ef428722dc 100644
--- a/Mk/Uses/go.mk
+++ b/Mk/Uses/go.mk
@@ -36,6 +36,12 @@
# GO_BUILDFLAGS
# Additional build arguments to be passed to the `go install` command
#
+# GO_PORT
+# The Go port to use. By default this is lang/go but can be set
+# to lang/go-devel in make.conf for testing with future Go versions.
+#
+# This variable should not be set by individual ports!
+#
# MAINTAINER: jlaffaye@FreeBSD.org
.if !defined(_INCLUDE_USES_GO_MK)
@@ -83,7 +89,8 @@ GO_ENV+= GOPATH="${WRKDIR}" \
GOBIN=""
.endif
-BUILD_DEPENDS+= ${GO_CMD}:lang/go
+GO_PORT?= lang/go
+BUILD_DEPENDS+= ${GO_CMD}:${GO_PORT}
PLIST_SUB+= GO_PKGNAME=${GO_PKGNAME}
_USES_POST+= go