aboutsummaryrefslogtreecommitdiff
path: root/archivers/rar/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2017-11-07 14:26:42 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2017-11-07 14:26:42 +0000
commit9f4fbaaf59e8c084fbeef93021551fb7882f242e (patch)
tree6f3913a3e1624434bca2f801b53c6b91747e2710 /archivers/rar/Makefile
parentb1088c3e2d167c1522aa5fc7b6a4ca561ca40e56 (diff)
downloadports-9f4fbaaf59e8c084fbeef93021551fb7882f242e.tar.gz
ports-9f4fbaaf59e8c084fbeef93021551fb7882f242e.zip
Reinstate IA32_BINARY_PORT=yes knob that was removed in r249298 to allow
installation on 64-bit systems even if 32-bit libraries are not present (binary was statically linked): nowadays, the binary is linked dynamically and thus requires /usr/lib32. This also allows to remove BROKEN_* knobs.
Notes
Notes: svn path=/head/; revision=453662
Diffstat (limited to 'archivers/rar/Makefile')
-rw-r--r--archivers/rar/Makefile17
1 files changed, 2 insertions, 15 deletions
diff --git a/archivers/rar/Makefile b/archivers/rar/Makefile
index df6e2cfa6f41..23b2796cb4db 100644
--- a/archivers/rar/Makefile
+++ b/archivers/rar/Makefile
@@ -16,9 +16,7 @@ LICENSE_NAME= RAR license
LICENSE_FILE= ${WRKSRC}/license.txt
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-BROKEN_powerpc= fails to install: File format not recognized
-BROKEN_sparc64= fails to install: File format not recognized
-
+IA32_BINARY_PORT= yes
RESTRICTED= only unmodified original package can be distributed
NO_BUILD= yes
WRKSRC= ${WRKDIR}/rar
@@ -27,17 +25,6 @@ PORTDOCS= *
OPTIONS_DEFINE= DOCS
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "amd64"
-.if !defined(HAVE_COMPAT_IA32_KERN)
-HAVE_COMPAT_IA32_KERN!= if ${SYSCTL} -n compat.ia32.maxvmem >/dev/null 2>&1; then ${ECHO_CMD} YES; fi
-.endif
-.if !defined(HAVE_COMPAT_IA32_KERN)
-IGNORE= requires a kernel with compiled-in IA32 compatibility
-.endif
-.endif
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/rar ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/rar.txt ${STAGEDIR}${PREFIX}/man/cat1/rar.1
@@ -49,4 +36,4 @@ post-install-DOCS-on:
${INSTALL_DATA} ${WRKSRC}/*.txt ${WRKSRC}/order.htm \
${STAGEDIR}${DOCSDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>