aboutsummaryrefslogtreecommitdiff
path: root/audio/ardour
diff options
context:
space:
mode:
authorEdward Tomasz Napierala <trasz@FreeBSD.org>2009-02-21 10:52:31 +0000
committerEdward Tomasz Napierala <trasz@FreeBSD.org>2009-02-21 10:52:31 +0000
commitb7a0d13a40db9bcd1239d55de4e5a2e9be1fb78f (patch)
tree3b6e5879ee6e31b98711ef6872ad1c1fc58de1d4 /audio/ardour
parent3b43930b210a9b26f12ceb476dc5ffa90652c12a (diff)
downloadports-b7a0d13a40db9bcd1239d55de4e5a2e9be1fb78f.tar.gz
ports-b7a0d13a40db9bcd1239d55de4e5a2e9be1fb78f.zip
Update to 2.7.1.
Fix for VST is pending.
Notes
Notes: svn path=/head/; revision=228766
Diffstat (limited to 'audio/ardour')
-rw-r--r--audio/ardour/Makefile2
-rw-r--r--audio/ardour/distinfo6
-rw-r--r--audio/ardour/files/patch-SConstruct38
-rw-r--r--audio/ardour/files/patch-libs-ardour-io.cc11
4 files changed, 18 insertions, 39 deletions
diff --git a/audio/ardour/Makefile b/audio/ardour/Makefile
index cbc132ba7e36..0a691b1137ba 100644
--- a/audio/ardour/Makefile
+++ b/audio/ardour/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= ardour
-PORTVERSION= 2.7
+PORTVERSION= 2.7.1
CATEGORIES= audio
MASTER_SITES= http://releases.ardour.org/
DISTFILES= ardour-${DISTVERSION}.tar.bz2
diff --git a/audio/ardour/distinfo b/audio/ardour/distinfo
index b102eca8e7ee..38b3bf78b171 100644
--- a/audio/ardour/distinfo
+++ b/audio/ardour/distinfo
@@ -1,3 +1,3 @@
-MD5 (ardour-2.7.tar.bz2) = 0617dc77c85ee6eecf1b4b3fb9d02221
-SHA256 (ardour-2.7.tar.bz2) = a6cb8e694fe872ed073b760ef7d467b6313bdc78941ca32a0c3dbb563ef28c0f
-SIZE (ardour-2.7.tar.bz2) = 3305862
+MD5 (ardour-2.7.1.tar.bz2) = 0fd4b1a600c75447d633b796bad321e1
+SHA256 (ardour-2.7.1.tar.bz2) = 102b99716ea99bbe66ad57abd1a1bf39d904068e76cb222d68f7acb78c63c864
+SIZE (ardour-2.7.1.tar.bz2) = 3313029
diff --git a/audio/ardour/files/patch-SConstruct b/audio/ardour/files/patch-SConstruct
index 077a5934240d..c2aa3685a38a 100644
--- a/audio/ardour/files/patch-SConstruct
+++ b/audio/ardour/files/patch-SConstruct
@@ -1,5 +1,5 @@
---- SConstruct.orig 2008-10-25 15:06:02.000000000 +0200
-+++ SConstruct 2008-11-09 09:44:10.000000000 +0100
+--- SConstruct.orig 2008-12-02 11:02:40.000000000 +0100
++++ SConstruct 2009-02-11 19:13:27.000000000 +0100
@@ -48,7 +48,7 @@
BoolOption('FPU_OPTIMIZATION', 'Build runtime checked assembler code', 1),
BoolOption('LIBLO', 'Compile with support for liblo library', 1),
@@ -7,9 +7,9 @@
- PathOption('PREFIX', 'Set the install "prefix"', '/usr/local'),
+ PathOption('PREFIX', 'Set the install "prefix"', '/usr/local', PathOption.PathIsDirCreate),
BoolOption('SURFACES', 'Build support for control surfaces', 1),
+ BoolOption('WIIMOTE', 'Build the wiimote control surface', 0),
BoolOption('SYSLIBS', 'USE AT YOUR OWN RISK: CANCELS ALL SUPPORT FROM ARDOUR AUTHORS: Use existing system versions of various libraries instead of internal ones', 0),
- BoolOption('UNIVERSAL', 'Compile as universal binary. Requires that external libraries are already universal.', 0),
-@@ -397,7 +397,7 @@
+@@ -398,7 +398,7 @@
# Make sure they know what they are doing
#
@@ -18,7 +18,7 @@
if os.path.isfile('.personal_use_only'):
print "Enabling VST support. Note that distributing a VST-enabled ardour\nis a violation of several different licences.\nBuild with VST=false if you intend to distribute ardour to others."
else:
-@@ -698,9 +698,9 @@
+@@ -702,9 +702,9 @@
opt_flags.extend (["-mhard-float", "-mpowerpc-gfxopt"])
opt_flags.extend (["-Os"])
@@ -28,9 +28,9 @@
- build_host_supports_sse = 0
+ build_host_supports_sse = 1
- if (re.search ("i[0-9]86", config[config_cpu]) != None):
- debug_flags.append ("-DARCH_X86")
-@@ -746,12 +746,7 @@
+ #
+ # ARCH_X86 means anything in the x86 family from i386 to x86_64
+@@ -755,12 +755,7 @@
print "\nWarning: you are building Ardour with SSE support even though your system does not support these instructions. (This may not be an error, especially if you are a package maintainer)"
# end optimization section
@@ -44,7 +44,7 @@
#
# a single way to test if we're on OS X
-@@ -789,13 +784,7 @@
+@@ -798,13 +793,7 @@
# prepend boiler plate optimization flags
#
@@ -59,7 +59,7 @@
if env['DEBUG'] == 1:
env.Append(CCFLAGS=" ".join (debug_flags))
-@@ -887,6 +876,7 @@
+@@ -896,6 +885,7 @@
libraries['usb'] = LibraryInfo ()
prep_libcheck(env, libraries['usb'])
@@ -67,7 +67,7 @@
conf = Configure (libraries['usb'])
if conf.CheckLib ('usb', 'usb_interrupt_write'):
-@@ -945,6 +935,7 @@
+@@ -968,6 +958,7 @@
if env['LIBLO']:
libraries['lo'] = LibraryInfo ()
prep_libcheck(env, libraries['lo'])
@@ -75,7 +75,7 @@
conf = Configure (libraries['lo'])
if conf.CheckLib ('lo', 'lo_server_new') == False:
-@@ -958,6 +949,7 @@
+@@ -981,6 +972,7 @@
libraries['dmalloc'] = LibraryInfo ()
prep_libcheck(env, libraries['dmalloc'])
@@ -83,7 +83,7 @@
#
# look for the threaded version
-@@ -1015,8 +1007,10 @@
+@@ -1038,8 +1030,10 @@
subst_dict['%MIDITAG%'] = "ardour"
subst_dict['%MIDITYPE%'] = "coremidi"
else:
@@ -96,17 +96,7 @@
env = conf.Finish()
-@@ -1190,8 +1184,7 @@
- surface_subdirs = [ 'libs/surfaces/control_protocol',
- 'libs/surfaces/generic_midi',
- 'libs/surfaces/tranzport',
-- 'libs/surfaces/mackie',
-- 'libs/surfaces/powermate'
-+ 'libs/surfaces/mackie'
- ]
-
- if env['SURFACES']:
-@@ -1296,8 +1289,8 @@
+@@ -1328,8 +1322,8 @@
subst_dict['%JACK_INPUT%'] = "coreaudio:Built-in Audio:in"
subst_dict['%JACK_OUTPUT%'] = "coreaudio:Built-in Audio:out"
else:
diff --git a/audio/ardour/files/patch-libs-ardour-io.cc b/audio/ardour/files/patch-libs-ardour-io.cc
deleted file mode 100644
index a824d7036e10..000000000000
--- a/audio/ardour/files/patch-libs-ardour-io.cc
+++ /dev/null
@@ -1,11 +0,0 @@
---- libs/ardour/io.cc.orig Thu Jan 4 22:40:34 2007
-+++ libs/ardour/io.cc Thu Jan 4 22:41:09 2007
-@@ -2498,7 +2498,7 @@
- } else {
- // do falloff, the config value is in dB/sec, we get updated at 100/sec currently (should be a var somewhere)
- new_peak = _visible_peak_power[n] - (Config->get_meter_falloff() * 0.01f);
-- _visible_peak_power[n] = max (new_peak, -INFINITY);
-+ _visible_peak_power[n] = max ((double)new_peak, -INFINITY);
- }
- }
- }