aboutsummaryrefslogtreecommitdiff
path: root/audio/deadbeef
diff options
context:
space:
mode:
authorVeniamin Gvozdikov <vg@FreeBSD.org>2014-08-04 15:39:40 +0000
committerVeniamin Gvozdikov <vg@FreeBSD.org>2014-08-04 15:39:40 +0000
commita19d33c75baa6e5584178fbfbc2a772fffae1fcc (patch)
tree098f11b673fe5ff3409c985239b52aa15105bc8c /audio/deadbeef
parentc1addff0c444341f8f980ffd4a34671716af4bb3 (diff)
downloadports-a19d33c75baa6e5584178fbfbc2a772fffae1fcc.tar.gz
ports-a19d33c75baa6e5584178fbfbc2a772fffae1fcc.zip
- Fix build without converter
- Added new depend for artwork - Bump version
Notes
Notes: svn path=/head/; revision=364022
Diffstat (limited to 'audio/deadbeef')
-rw-r--r--audio/deadbeef/Makefile32
1 files changed, 11 insertions, 21 deletions
diff --git a/audio/deadbeef/Makefile b/audio/deadbeef/Makefile
index e9b277e7aed6..6c9a813743f7 100644
--- a/audio/deadbeef/Makefile
+++ b/audio/deadbeef/Makefile
@@ -3,6 +3,7 @@
PORTNAME= deadbeef
PORTVERSION= 0.6.2
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}${PKGNAMESUFFIX}
PKGNAMESUFFIX= -rc5
@@ -73,7 +74,7 @@ OPTIONS_SUB= yes
PULSEAUDIO_LIB_DEPENDS= libpulse.so:${PORTSDIR}/audio/pulseaudio
PULSEAUDIO_CONFIGURE_OFF= --disable-pulse
-GUI_USE= GNOME="gtk20,glib20"
+GUI_USE= gnome=gtk20,glib20
GUI_CONFIGURE_OFF= --disable-gtkui --disable-gtk3
VFS_LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
@@ -82,6 +83,11 @@ VFS_CONFIGURE_OFF= --disable-vfs-curl
LASTFM_LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
LASTFM_CONFIGURE_OFF= --disable-lfm
+ART_LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg
+ART_USE= efl=imlib2
+ART_CONFIGURE_OFF= --disable-artwork --disable-artwork-imlib2
+
EQ_CONFIGURE_OFF= --disable-supereq
SID_CONFIGURE_OFF= --disable-sid
@@ -154,6 +160,8 @@ DSP_CONFIGURE_OFF= --disable-src
MONO2STEREO_CONFIGURE_OFF= --disable-mono2stereo
+CONVERTER_CONFIGURE_OFF= --disable-converter
+
VFS_ZIP_LIB_DEPENDS= libzip.so:${PORTSDIR}/archivers/libzip
VFS_ZIP_CONFIGURE_OFF= --disable-vfs-zip
@@ -165,31 +173,13 @@ WMA_CONFIGURE_OFF= --disable-wma
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MART}
-.if ${PORT_OPTIONS:MVFS}
-CONFIGURE_ARTS+= --disable-artwork-imlib2
-PLIST_SUB+= ART=""
-LIB_DEPENDS+= libcurl.so:${PORTSDIR}/ftp/curl \
- libjpeg.so:${PORTSDIR}/graphics/jpeg
-.else
+.if ${PORT_OPTIONS:MART} && ! ${PORT_OPTIONS:MVFS}
BROKEN= VFS plugin required for album art loader, please rerun 'make config' and either disable ART or enable VFS
.endif
-.else
-CONFIGURE_ARGS+= --disable-artwork
-PLIST_SUB+= ART="@comment "
-.endif
-.if ${PORT_OPTIONS:MCONVERTER}
-.if ${PORT_OPTIONS:MGUI}
-PLIST_SUB+= CONVERTER=""
-USE_GNOME= gtk20 glib20
-.else
+.if ${PORT_OPTIONS:MCONVERTER} && ! ${PORT_OPTIONS:MGUI}
BROKEN= CONVERTER plugin required for gui, please rerun 'make config' and either disable CONVERTER or enable GUI
.endif
-.else
-CONFIGURE_ARGS+= --disable-converter
-PLIST_SUB+= CONVERTER="@comment "
-.endif
post-patch:
# Do not link to libsupc++ which may be PIC-unsafe (breaks 64-bit arches)