aboutsummaryrefslogtreecommitdiff
path: root/audio/denemo/Makefile
diff options
context:
space:
mode:
authorFUJISHIMA Satsuki <sf@FreeBSD.org>2003-07-14 02:53:03 +0000
committerFUJISHIMA Satsuki <sf@FreeBSD.org>2003-07-14 02:53:03 +0000
commitb185046be2ec03555daaf4f26d38542c403a9955 (patch)
tree0274ce607614533de66837fc1f70d4c35770d9e1 /audio/denemo/Makefile
parent88d002074007544d532f2495aeb93729291e6275 (diff)
downloadports-b185046be2ec03555daaf4f26d38542c403a9955.tar.gz
ports-b185046be2ec03555daaf4f26d38542c403a9955.zip
get rid of libgnugetopt dependency for -CURRENT,
use USE_GETOPT_LONG instead.
Notes
Notes: svn path=/head/; revision=84842
Diffstat (limited to 'audio/denemo/Makefile')
-rw-r--r--audio/denemo/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/audio/denemo/Makefile b/audio/denemo/Makefile
index 93d0ed8a945c..1ef885658adf 100644
--- a/audio/denemo/Makefile
+++ b/audio/denemo/Makefile
@@ -7,6 +7,7 @@
PORTNAME= denemo
PORTVERSION= 0.5.9
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -14,10 +15,10 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= trevor@FreeBSD.org
COMMENT= Graphical score editor
-LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt \
- intl.4:${PORTSDIR}/devel/gettext \
+LIB_DEPENDS= intl.4:${PORTSDIR}/devel/gettext \
xml.5:${PORTSDIR}/textproc/libxml
+USE_GETOPT_LONG=yes
GNU_CONFIGURE= yes
PLIST= ${WRKDIR}/pkg-plist
SHARED= denemo.conf denemo.keymaprc english.keymaprc french.keymaprc
@@ -29,11 +30,10 @@ USE_X_PREFIX= yes
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile"
+BROKEN= "Does not compile"
.endif
post-configure:
- ${PERL} -pi -e "s:module12:module12 -lgnugetopt:g" ${WRKSRC}/Makefile
${PERL} -pi -e "s:<wait.h:<sys/wait.h:g" ${WRKSRC}/*.c
pre-install: