aboutsummaryrefslogtreecommitdiff
path: root/audio/timidity++/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-07-09 21:35:14 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-07-09 21:35:14 +0000
commitc40104f2f1f279d0856e3d9b7e73045fa1c929d8 (patch)
tree2ff6acd22bde7d531b5fbdf8835a075159df6ce0 /audio/timidity++/Makefile
parent0caf410ed8672cdc063c8867f2104c1ef15e4f24 (diff)
downloadports-c40104f2f1f279d0856e3d9b7e73045fa1c929d8.tar.gz
ports-c40104f2f1f279d0856e3d9b7e73045fa1c929d8.zip
Really fix this time
Notes
Notes: svn path=/head/; revision=322582
Diffstat (limited to 'audio/timidity++/Makefile')
-rw-r--r--audio/timidity++/Makefile22
1 files changed, 11 insertions, 11 deletions
diff --git a/audio/timidity++/Makefile b/audio/timidity++/Makefile
index a0fa506d2c3f..83442a226655 100644
--- a/audio/timidity++/Makefile
+++ b/audio/timidity++/Makefile
@@ -30,6 +30,8 @@ PLIST_SUB+= TIMID_LIBDIR=${TIMID_LIBDIR} EUCJP_LOCALE=${EUCJP_LOCALE}
EUCJP_LOCALE= ja_JP.eucJP
TIMID_LIBDIR= lib/timidity
+.include <bsd.port.options.mk>
+
.if !defined(PKGNAMESUFFIX)
WANT_GNOME= yes
EXTRACT_AFTER_ARGS= --exclude '*/libarc/*' \
@@ -43,8 +45,6 @@ LDFLAGS+= -export-dynamic
DOCFILES= README.alsaseq README.dl README.m2m README.mts README.sf
DOCLANG= C ja_JP.eucJP
-.include <bsd.port.options.mk>
-
MANLANG= "" ja
MAN1= timidity.1
MAN5= timidity.cfg.5
@@ -58,6 +58,15 @@ LIB_DEPENDS+= png15:${PORTSDIR}/graphics/png
CPPFLAGS+= -I${LOCALBASE}/include/libpng15
.endif
+.include <bsd.port.pre.mk>
+
+.if ${HAVE_GNOME:Mesound}!=""
+USE_GNOME= esound
+CONFIGURE_ARGS+=--enable-audio=oss,esd,vorbis
+.else
+CONFIGURE_ARGS+=--enable-audio=oss,vorbis
+.endif
+
pre-su-install:
@${MKDIR} ${PREFIX}/share/timidity ${PREFIX}/${TIMID_LIBDIR}
@@ -70,15 +79,6 @@ post-install::
.include "${MASTERDIR}/Makefile.interface"
.endif # !defined(PKGNAMESUFFIX)
-.include <bsd.port.pre.mk>
-
-.if ${HAVE_GNOME:Mesound}!=""
-USE_GNOME= esound
-CONFIGURE_ARGS+=--enable-audio=oss,esd,vorbis
-.else
-CONFIGURE_ARGS+=--enable-audio=oss,vorbis
-.endif
-
post-install::
.if !defined(NOPORTDOCS) && defined(DOCFILES)
.for lang in ${DOCLANG}