aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2017-01-18 13:20:31 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2017-01-18 13:20:31 +0000
commit02f27a83b44d4566fd409edc60570ac0734eb63e (patch)
tree62d2805fd9c9c4285034b54a2ccb3f498f302811 /audio
parentbddf1289efd81317364118eb60cdc28cc766c3c2 (diff)
downloadports-02f27a83b44d4566fd409edc60570ac0734eb63e.tar.gz
ports-02f27a83b44d4566fd409edc60570ac0734eb63e.zip
The output of tools like awk, date, sort, tr,... depends on the current
locale set by the user. Add LANG=C and LC_ALL=C at the beginning of bsd.port.mk and export them so all commands are executed with the C locale. LC_ALL=C overrides all other LC_* variables. LANG is used by setlocale(3) as default value for LC_* variables, so normally it isn't used when LC_ALL is set, but there's code out there that looks at LANG directly so it's safer to set it as well. The only commands not captured by this are != assignments before any inclusion of bsd.port.*mk. Introduce USE_LOCALE=<locale> that adds LANG=<locale> and LC_ALL=<locale> to CONFIGURE_ENV and MAKE_ENV so upstream build systems can be executed with a different locale (e.g. USE_LOCALE=en_US.UTF-8). PR: 215882 Exp-run by: antoine Approved by: portmgr (antoine)
Notes
Notes: svn path=/head/; revision=431796
Diffstat (limited to 'audio')
-rw-r--r--audio/denemo/Makefile1
-rw-r--r--audio/libamrnb/Makefile2
-rw-r--r--audio/libamrwb/Makefile2
3 files changed, 0 insertions, 5 deletions
diff --git a/audio/denemo/Makefile b/audio/denemo/Makefile
index 6452a7603eea..d92a091fdc42 100644
--- a/audio/denemo/Makefile
+++ b/audio/denemo/Makefile
@@ -23,7 +23,6 @@ LIB_DEPENDS= libaubio.so:audio/aubio \
libfftw3.so:math/fftw3
RUN_DEPENDS= xdg-open:devel/xdg-utils
-EXTRACT_CMD= ${SETENV} LC_ALL=en_US.UTF-8 ${TAR}
EXTRACT_BEFORE_ARGS=\
-s '!\(/Clarinet in B\).*\(\.denemo\)$$!\1b\2!p' -xf
diff --git a/audio/libamrnb/Makefile b/audio/libamrnb/Makefile
index 9a6f64605da6..2eda57fb3ef4 100644
--- a/audio/libamrnb/Makefile
+++ b/audio/libamrnb/Makefile
@@ -29,8 +29,6 @@ RESTRICTED= unclear legal status, probably need licenses from 3GPP and more
USES= gmake tar:bzip2 libtool
PORTDOCS= AUTHORS COPYING ChangeLog NEWS README TODO readme.txt
GNU_CONFIGURE= yes
-CONFIGURE_ENV+= LANG=C
-MAKE_ENV+= LANG=C
INSTALL_TARGET= install-strip
SUB_FILES= pkg-message
USE_LDCONFIG= yes
diff --git a/audio/libamrwb/Makefile b/audio/libamrwb/Makefile
index 1120b7cf141c..812ab8df129f 100644
--- a/audio/libamrwb/Makefile
+++ b/audio/libamrwb/Makefile
@@ -28,8 +28,6 @@ RESTRICTED= unclear legal status, probably need licenses from 3GPP and more
USES= gmake tar:bzip2 libtool
PORTDOCS= AUTHORS COPYING ChangeLog NEWS README TODO readme.txt
GNU_CONFIGURE= yes
-CONFIGURE_ENV+= LANG=C
-MAKE_ENV+= LANG=C
INSTALL_TARGET= install-strip
SUB_FILES= pkg-message
USE_LDCONFIG= yes