aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorMichael Scheidell <scheidell@FreeBSD.org>2012-01-24 19:15:15 +0000
committerMichael Scheidell <scheidell@FreeBSD.org>2012-01-24 19:15:15 +0000
commit0f15c9e15d552e78538536f0cd64fa3bc835f207 (patch)
treee3b3cd32cd02a203fdec9d4c0c198234c0054477 /audio
parent0de2824a140eb8275bf6ae1160a395adfe0f214a (diff)
downloadports-0f15c9e15d552e78538536f0cd64fa3bc835f207.tar.gz
ports-0f15c9e15d552e78538536f0cd64fa3bc835f207.zip
- Update to 2.0.0.29.
- Bump from beta (build 14) to release (build 29) - Resolve oddities surrounding PLIST_SUB and SUB_LIST (thanks Michael and Gabor) - Update pkg-plist to reflect updated documentation - Support creation of both sc_serv.log and sc_w3c.log on startup PR: ports/16440 Approved by: gabor (mentor)
Notes
Notes: svn path=/head/; revision=289747
Diffstat (limited to 'audio')
-rw-r--r--audio/shoutcast/Makefile21
-rw-r--r--audio/shoutcast/distinfo4
-rw-r--r--audio/shoutcast/files/pkg-message.in2
-rw-r--r--audio/shoutcast/files/shoutcast.in25
-rw-r--r--audio/shoutcast/pkg-plist4
5 files changed, 31 insertions, 25 deletions
diff --git a/audio/shoutcast/Makefile b/audio/shoutcast/Makefile
index cc1cc99884ec..5b7160a5b4c7 100644
--- a/audio/shoutcast/Makefile
+++ b/audio/shoutcast/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= shoutcast
-PORTVERSION= 2.0.b14
+PORTVERSION= 2.0.0.29
CATEGORIES= audio net
MASTER_SITES= http://download.nullsoft.com/shoutcast/tools/
-DISTNAME= sc_serv2_bsd_8_x_01_25_2011
+DISTNAME= sc_serv2_bsd_8_x_07_31_2011
MAINTAINER= jarrod@downtools.com.au
COMMENT= SHOUTcast Distributed Network Audio Server
@@ -27,15 +27,15 @@ SHOUTCASTUSER= ${PORTNAME}
SHOUTCASTGROUP= ${PORTNAME}
SHOUTCASTDIR= /var/run/${PORTNAME}
-PLIST_SUB= SHOUTCASTUSER=${SHOUTCASTUSER} \
+SHOUTCAST_SUB= SHOUTCASTUSER=${SHOUTCASTUSER} \
SHOUTCASTGROUP=${SHOUTCASTGROUP} \
SHOUTCASTDIR=${SHOUTCASTDIR}
+PLIST_SUB= ${SHOUTCAST_SUB}
+
SUB_FILES= pkg-message
-SUB_LIST= SHOUTCASTUSER=${SHOUTCASTUSER} \
- SHOUTCASTGROUP=${SHOUTCASTGROUP} \
- SHOUTCASTDIR=${SHOUTCASTDIR}
+SUB_LIST= ${SHOUTCAST_SUB}
USERS= ${SHOUTCASTUSER}
GROUPS= ${SHOUTCASTGROUP}
@@ -43,11 +43,10 @@ GROUPS= ${SHOUTCASTGROUP}
.include <bsd.port.pre.mk>
post-patch:
- @${REINPLACE_CMD} -e '/^logfile=.*\/logfile.log/d' \
- -e '/sc_serv2 directory/d' \
+ @${REINPLACE_CMD} -e '/sc_serv2 directory/d' \
-e 's#=.*/sc_serv.log#=/var/log/sc_serv.log#g' \
-e 's#=.*/sc_w3c.log#=/var/log/sc_w3c.log#g' \
- -e 's#=./control/#=${SHOUTCASTDIR}/#g' ${WRKSRC}/sc_serv_basic.conf
+ -e 's#=control/#=${SHOUTCASTDIR}/#g' ${WRKSRC}/sc_serv_basic.conf
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/sc_serv ${PREFIX}/sbin
@@ -64,7 +63,9 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/docs/dsp_sc/dsp_sc.txt ${DOCSDIR}/dsp_sc.txt
${INSTALL_DATA} ${WRKSRC}/docs/dsp_sc/dsp_sc_config.txt ${DOCSDIR}/dsp_sc_config.txt
${INSTALL_DATA} ${WRKSRC}/docs/getting_started.txt ${DOCSDIR}/getting_started.txt
- ${INSTALL_DATA} ${WRKSRC}/docs/sc2_xml_metadata.txt ${DOCSDIR}/sc2_xml_metadata.txt
+ ${INSTALL_DATA} ${WRKSRC}/docs/sc_serv2.txt ${DOCSDIR}/sc_serv2.txt
+ ${INSTALL_DATA} ${WRKSRC}/docs/sc_serv2_authhash.txt ${DOCSDIR}/sc_serv2_authhash.txt
+ ${INSTALL_DATA} ${WRKSRC}/docs/sc_serv2_xml_responses.txt ${DOCSDIR}/sc_serv2_xml_responses.txt
${INSTALL_DATA} ${WRKSRC}/docs/shoutcast_system_overview.txt ${DOCSDIR}/shoutcast_system_overview.txt
.endif
diff --git a/audio/shoutcast/distinfo b/audio/shoutcast/distinfo
index 9acd8d3e4adf..82cd3bff729b 100644
--- a/audio/shoutcast/distinfo
+++ b/audio/shoutcast/distinfo
@@ -1,2 +1,2 @@
-SHA256 (sc_serv2_bsd_8_x_01_25_2011.tar.gz) = ecf72ec571d61c0967c522b14443e126cd82033d79d1f301daa6e3abab640ba9
-SIZE (sc_serv2_bsd_8_x_01_25_2011.tar.gz) = 696256
+SHA256 (sc_serv2_bsd_8_x_07_31_2011.tar.gz) = a4815602ad4abfb5b844667a0faf907bf151bcf0c06651f0756b89f35e35753c
+SIZE (sc_serv2_bsd_8_x_07_31_2011.tar.gz) = 820208
diff --git a/audio/shoutcast/files/pkg-message.in b/audio/shoutcast/files/pkg-message.in
index 707a64d266c9..3659cf523217 100644
--- a/audio/shoutcast/files/pkg-message.in
+++ b/audio/shoutcast/files/pkg-message.in
@@ -6,7 +6,7 @@
shoutcast_enable="YES"
- Configuration templates are available in %%PREFIX%%/%%ETCDIR%% as
+ Configuration templates are available in %%ETCDIR%% as
*.sample files. A basic installation can be completed by copying
sc_serv_basic.conf.sample to sc_serv.conf.
diff --git a/audio/shoutcast/files/shoutcast.in b/audio/shoutcast/files/shoutcast.in
index 4fefd6403f46..255d6066efc5 100644
--- a/audio/shoutcast/files/shoutcast.in
+++ b/audio/shoutcast/files/shoutcast.in
@@ -9,36 +9,39 @@
# Add the following lines to /etc/rc.conf to enable SHOUTcast:
# shoutcast_enable (bool): Set to "NO" by default.
# Set it to "YES" to enable SHOUTcast.
-# shoutcast_configfile (str): Set to "%%PREFIX%%/%%ETCDIR%%/sc_serv.conf" by default.
-# shoutcast_user (str): Set to %%SHOUTCASTUSER%% by default
-# shoutcast_chdir (str): Set to %%SHOUTCASTDIR%% by default
+# shoutcast_configfile (str): Set to "%%ETCDIR%%/sc_serv.conf" by default.
+# shoutcast_user (str): Set to "%%SHOUTCASTUSER%%" by default.
+# shoutcast_chdir (str): Set to "%%SHOUTCASTDIR%%" by default.
+# shoutcast_logfile (str): Set to "/var/log/sc_serv.log" by default.
+# shoutcast_w3clog (str): Set to "/var/log/sc_w3c.log" by default.
. /etc/rc.subr
name=shoutcast
rcvar=shoutcast_enable
-load_rc_config shoutcast
+load_rc_config ${name}
: ${shoutcast_enable:="NO"}
+: ${shoutcast_configfile:="%%ETCDIR%%/sc_serv.conf"}
: ${shoutcast_user:="%%SHOUTCASTUSER%%"}
: ${shoutcast_chdir:="%%SHOUTCASTDIR%%"}
+: ${shoutcast_logfile:="/var/log/sc_serv.log"}
+: ${shoutcast_w3clog:="/var/log/sc_w3c.log"}
command="%%PREFIX%%/sbin/sc_serv"
-shoutcast_logfile="/var/log/sc_serv.log"
-required_dirs="${shoutcast_chdir}"
-required_files="${shoutcast_configfile:="%%PREFIX%%/%%ETCDIR%%/sc_serv.conf"}"
+required_files="${shoutcast_configfile}"
-command_args="${required_files} >/dev/null 2>&1 &"
+command_args="${shoutcast_configfile} >/dev/null 2>&1 &"
start_precmd="shoutcast_prestart"
shoutcast_prestart()
{
- touch ${shoutcast_logfile}
- chown %%SHOUTCASTUSER%%:wheel ${shoutcast_logfile}
- chmod 0640 ${shoutcast_logfile}
+ touch "${shoutcast_logfile}" "${shoutcast_w3clog}"
+ chown %%SHOUTCASTUSER%%:wheel "${shoutcast_logfile}" "${shoutcast_w3clog}"
+ chmod 0640 "${shoutcast_logfile}" "${shoutcast_w3clog}"
}
run_rc_command "$1"
diff --git a/audio/shoutcast/pkg-plist b/audio/shoutcast/pkg-plist
index 5f336eefcaad..d632551e5aae 100644
--- a/audio/shoutcast/pkg-plist
+++ b/audio/shoutcast/pkg-plist
@@ -12,7 +12,9 @@ sbin/sc_serv
%%PORTDOCS%%%%DOCSDIR%%/dsp_sc.txt
%%PORTDOCS%%%%DOCSDIR%%/dsp_sc_config.txt
%%PORTDOCS%%%%DOCSDIR%%/getting_started.txt
-%%PORTDOCS%%%%DOCSDIR%%/sc2_xml_metadata.txt
+%%PORTDOCS%%%%DOCSDIR%%/sc_serv2.txt
+%%PORTDOCS%%%%DOCSDIR%%/sc_serv2_authhash.txt
+%%PORTDOCS%%%%DOCSDIR%%/sc_serv2_xml_responses.txt
%%PORTDOCS%%%%DOCSDIR%%/shoutcast_system_overview.txt
@dirrmtry %%ETCDIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%