aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2017-04-10 13:25:23 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2017-04-10 13:25:23 +0000
commit9777db6fbba9c0b26edf3678d7fd8e1b44ecad7e (patch)
treec730fec1f910e50fff4a5e0cb753b2e501048bc8 /audio
parent2b3838ff6125eeb5bed931235e540167538273af (diff)
downloadports-9777db6fbba9c0b26edf3678d7fd8e1b44ecad7e.tar.gz
ports-9777db6fbba9c0b26edf3678d7fd8e1b44ecad7e.zip
Update to 2.8.0-rc0
- Fix build with devel/ncurses installed [1], which erroneously redefines _POSIX_C_SOURCE as 200112L globally via its pkg-config file and hides strndup from cmus. A workaround for this was applied to cmus in DPorts commit d2907fe but it never made it back to FreeBSD. Changes: https://github.com/cmus/cmus/releases/tag/v2.8.0-rc0 PR: 216325, 214475 [1] Reported by: Oleg Gushchenkov <gor@clogic.com.ua> [1] Approved by: mat (mentor) Differential Revision: https://reviews.freebsd.org/D10242
Notes
Notes: svn path=/head/; revision=438165
Diffstat (limited to 'audio')
-rw-r--r--audio/cmus/Makefile25
-rw-r--r--audio/cmus/distinfo10
-rw-r--r--audio/cmus/files/patch-Makefile13
-rw-r--r--audio/cmus/files/patch-configure12
-rw-r--r--audio/cmus/files/patch-ffmpeg.c47
-rw-r--r--audio/cmus/files/patch-ip_mp4.c (renamed from audio/cmus/files/patch-mp4.c)13
-rw-r--r--audio/cmus/files/patch-sndio.c24
-rw-r--r--audio/cmus/pkg-plist3
8 files changed, 46 insertions, 101 deletions
diff --git a/audio/cmus/Makefile b/audio/cmus/Makefile
index 1ed111da0d61..b10441b629ff 100644
--- a/audio/cmus/Makefile
+++ b/audio/cmus/Makefile
@@ -2,15 +2,19 @@
# $FreeBSD$
PORTNAME= cmus
-PORTVERSION= 2.7.1
+DISTVERSION= 2.8.0-rc0
DISTVERSIONPREFIX= v
-PORTREVISION= 1
CATEGORIES= audio
+DIST_SUBDIR= cmus
+
+# Fixes for playback of 24-bit files with the sndio/OSS output plugins
+PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
+PATCHFILES= 6a85680.patch:-p1 0fb39d8.patch:-p1
MAINTAINER= tobik@FreeBSD.org
COMMENT= Console-based music player with really cool features
-LICENSE= GPLv2
+LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
USE_GITHUB= yes
@@ -31,15 +35,15 @@ MAKE_ARGS= V=2
# follow shell value semantics i.e. later assignments overwrite
# previous assignments. The options here appear in the same order as
# ${WRKSRC}/configure --help. Please keep it that way.
-_CMUS_CONFIGURE_OPTS= CDDB CDIO DISCID FLAC MAD MODPLUG MIKMOD MPC \
- VORBIS TREMOR OPUS WAV WAVPACK MP4 AAC FFMPEG \
- VTX CUE ROAR PULSE ALSA JACK SAMPLERATE AO \
- ARTS OSS SNDIO SUN WAVEOUT
+_CMUS_CONFIGURE_OPTS= AAC ALSA AO ARTS CDDB CDIO COREAUDIO CUE DISCID \
+ FFMPEG FLAC JACK MAD MIKMOD MODPLUG MP4 MPC MPRIS OPUS OSS \
+ PULSE ROAR SAMPLERATE SNDIO SUN TREMOR VORBIS VTX WAVEOUT \
+ WAVPACK WAV
.for opt in ${_CMUS_CONFIGURE_OPTS}
CONFIGURE_ARGS+= CONFIG_${opt}=n
.endfor
-OPTIONS_DEFAULT= AAC FFMPEG FLAC MAD MP4 OSS SNDIO VORBIS WAV
+OPTIONS_DEFAULT= AAC FFMPEG FLAC MAD MP4 OPUS OSS SNDIO VORBIS WAV
OPTIONS_SUB= yes
OPTIONS_GROUP= OUT IN
@@ -131,9 +135,12 @@ WAV_CONFIGURE_ON= CONFIG_WAV=y
WAVPACK_CONFIGURE_ON= CONFIG_WAVPACK=y
WAVPACK_LIB_DEPENDS= libwavpack.so:audio/wavpack
+post-patch:
+# From DPorts: prevent passing -D_POSIX_C_SOURCE=200112L -D_XOPEN_SOURCE=600
+ @${REINPLACE_CMD} -e 's@\(NCURSES_CFLAGS=\).*@\1""@g' \
+ ${WRKSRC}/configure
# Doc/cmus.txt is used to generate the man pages. Fix paths to point
# to the correct directories.
-post-patch:
@${REINPLACE_CMD} \
-e 's,/usr/share/doc/cmus/examples,${EXAMPLESDIR},g' \
-e 's,/usr/share/cmus,${DATADIR},g' \
diff --git a/audio/cmus/distinfo b/audio/cmus/distinfo
index c0945ba33078..70cc78353f79 100644
--- a/audio/cmus/distinfo
+++ b/audio/cmus/distinfo
@@ -1,3 +1,7 @@
-TIMESTAMP = 1469160686
-SHA256 (cmus-cmus-v2.7.1_GH0.tar.gz) = 8179a7a843d257ddb585f4c65599844bc0e516fe85e97f6f87a7ceade4eb5165
-SIZE (cmus-cmus-v2.7.1_GH0.tar.gz) = 296818
+TIMESTAMP = 1490271541
+SHA256 (cmus/cmus-cmus-v2.8.0-rc0_GH0.tar.gz) = b594087f16053f4db49e89d72b1c6dbb12e221373e806e62b3e97c327de1dac9
+SIZE (cmus/cmus-cmus-v2.8.0-rc0_GH0.tar.gz) = 315613
+SHA256 (cmus/6a85680.patch) = 504c3c792be330d0f7bfda2101c4d7a24bd94aa38761def5e58f91d6fe081778
+SIZE (cmus/6a85680.patch) = 3400
+SHA256 (cmus/0fb39d8.patch) = 6b35f6e4e1a4e78598c3b125a764e2975298189467c82e868e19c6569901e3f7
+SIZE (cmus/0fb39d8.patch) = 785
diff --git a/audio/cmus/files/patch-Makefile b/audio/cmus/files/patch-Makefile
new file mode 100644
index 000000000000..2517f5e94cfc
--- /dev/null
+++ b/audio/cmus/files/patch-Makefile
@@ -0,0 +1,13 @@
+Don't run git during the build
+
+--- Makefile.orig 2016-11-20 12:29:46 UTC
++++ Makefile
+@@ -9,7 +9,7 @@ _ver2 = $(shell git rev-parse --verify -
+ # hand-made
+ _ver3 = v2.8.0-rc0
+
+-VERSION = $(or $(_ver0),$(_ver1),$(_ver2),$(_ver3))
++VERSION = $(_ver3)
+
+ all: main plugins man
+
diff --git a/audio/cmus/files/patch-configure b/audio/cmus/files/patch-configure
deleted file mode 100644
index 1123cc7365d3..000000000000
--- a/audio/cmus/files/patch-configure
+++ /dev/null
@@ -1,12 +0,0 @@
-Upstreamed in https://github.com/cmus/cmus/commit/37f4daaea4d2724cd2b4d66984cf72b012ef5d48
---- configure.orig 2016-08-03 15:18:16 UTC
-+++ configure
-@@ -21,7 +21,7 @@ check_cflags()
- check_sndio()
- {
- case `uname -s` in
-- OpenBSD)
-+ OpenBSD|FreeBSD)
- check_library SNDIO "" "-lsndio"
- return $?
- esac
diff --git a/audio/cmus/files/patch-ffmpeg.c b/audio/cmus/files/patch-ffmpeg.c
deleted file mode 100644
index 35876e59efd0..000000000000
--- a/audio/cmus/files/patch-ffmpeg.c
+++ /dev/null
@@ -1,47 +0,0 @@
---- ffmpeg.c.orig 2015-07-13 10:00:56 UTC
-+++ ffmpeg.c
-@@ -39,7 +39,7 @@
- #include <libavformat/avio.h>
- #include <libswresample/swresample.h>
- #include <libavutil/opt.h>
--#include <libavutil/audioconvert.h>
-+#include <libavutil/channel_layout.h>
- #ifndef AVUTIL_MATHEMATICS_H
- #include <libavutil/mathematics.h>
- #endif
-@@ -347,7 +347,7 @@ static int ffmpeg_fill_buffer(AVFormatCo
- struct ffmpeg_output *output, SwrContext *swr)
- {
- #if (LIBAVCODEC_VERSION_INT >= ((53<<16) + (25<<8) + 0))
-- AVFrame *frame = avcodec_alloc_frame();
-+ AVFrame *frame = av_frame_alloc();
- int got_frame;
- #endif
- while (1) {
-@@ -363,7 +363,7 @@ static int ffmpeg_fill_buffer(AVFormatCo
- if (av_read_frame(ic, &input->pkt) < 0) {
- /* Force EOF once we can read no longer. */
- #if (LIBAVCODEC_VERSION_INT >= ((53<<16) + (25<<8) + 0))
-- avcodec_free_frame(&frame);
-+ av_frame_free(&frame);
- #endif
- return 0;
- }
-@@ -426,7 +426,7 @@ static int ffmpeg_fill_buffer(AVFormatCo
- res = 0;
- output->buffer_pos = output->buffer;
- output->buffer_used_len = res * cc->channels * sizeof(int16_t);
-- avcodec_free_frame(&frame);
-+ av_frame_free(&frame);
- return output->buffer_used_len;
- }
- #endif
-@@ -566,7 +566,7 @@ static long ffmpeg_current_bitrate(struc
- long bitrate = -1;
- #if (LIBAVFORMAT_VERSION_INT > ((51<<16)+(43<<8)+0))
- /* ape codec returns silly numbers */
-- if (priv->codec->id == CODEC_ID_APE)
-+ if (priv->codec->id == AV_CODEC_ID_APE)
- return -1;
- #endif
- if (priv->input->curr_duration > 0) {
diff --git a/audio/cmus/files/patch-mp4.c b/audio/cmus/files/patch-ip_mp4.c
index 310c56f9243e..5a4fe05b1888 100644
--- a/audio/cmus/files/patch-mp4.c
+++ b/audio/cmus/files/patch-ip_mp4.c
@@ -1,14 +1,15 @@
This patch is needed because multimedia/mp4v2 doesn't currently have
MP4LogSetLevel. It requires mp4v2 >= 2.0.0.
---- mp4.c.orig 2015-07-13 10:00:56 UTC
-+++ mp4.c
-@@ -155,7 +155,7 @@ static int mp4_open(struct input_plugin_
+--- ip/mp4.c.orig 2016-11-20 12:29:46 UTC
++++ ip/mp4.c
+@@ -154,9 +154,6 @@ static int mp4_open(struct input_plugin_
+ if (ip_data->remote)
return -IP_ERROR_FUNCTION_NOT_SUPPORTED;
- /* kindly ask mp4v2 to not spam stderr */
+- /* kindly ask mp4v2 to not spam stderr */
- MP4LogSetLevel(MP4_LOG_NONE);
-+ //MP4LogSetLevel(MP4_LOG_NONE);
-
+-
/* init private struct */
priv = xnew(struct mp4_private, 1);
+ *priv = priv_init;
diff --git a/audio/cmus/files/patch-sndio.c b/audio/cmus/files/patch-sndio.c
deleted file mode 100644
index 2ceeb5d159e6..000000000000
--- a/audio/cmus/files/patch-sndio.c
+++ /dev/null
@@ -1,24 +0,0 @@
-Upstreamed in https://github.com/cmus/cmus/commit/37f4daaea4d2724cd2b4d66984cf72b012ef5d48
---- sndio.c.orig 2015-07-13 10:00:56 UTC
-+++ sndio.c
-@@ -20,7 +20,6 @@
-
- #include <sys/types.h>
- #include <sys/ioctl.h>
--#include <sys/audioio.h>
- #include <sys/stat.h>
- #include <errno.h>
- #include <fcntl.h>
-@@ -82,6 +81,12 @@ static int sndio_set_sf(sample_format_t
- par.le = 1;
-
- switch (sf_get_bits(sndio_sf)) {
-+ case 32:
-+ par.bits = 32;
-+ break;
-+ case 24:
-+ par.bits = 24;
-+ break;
- case 16:
- par.bits = 16;
- break;
diff --git a/audio/cmus/pkg-plist b/audio/cmus/pkg-plist
index 2a22f7ed9db1..0107bac04767 100644
--- a/audio/cmus/pkg-plist
+++ b/audio/cmus/pkg-plist
@@ -7,6 +7,9 @@
%%DATADIR%%/gray-88.theme
%%DATADIR%%/green-mono-88.theme
%%DATADIR%%/green.theme
+%%DATADIR%%/gruvbox-alt.theme
+%%DATADIR%%/gruvbox.theme
+%%DATADIR%%/jellybeans.theme
%%DATADIR%%/night.theme
%%DATADIR%%/rc
%%DATADIR%%/solarized-dark.theme