aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-01-28 18:47:35 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-01-28 18:47:35 +0000
commite8624eac323d2ddf28f44a6fc3995964fafa9d2e (patch)
tree5e27bb08ac8335f232f77a8cf2d625f81ff4537e /benchmarks
parent732b5fba99457bf707221cede27c237f9653b6cd (diff)
downloadports-e8624eac323d2ddf28f44a6fc3995964fafa9d2e.tar.gz
ports-e8624eac323d2ddf28f44a6fc3995964fafa9d2e.zip
benchmarks/glmark2: expose KMS console and Wayland support
PR: 252197 Reviewed by: danfe (maintainer)
Notes
Notes: svn path=/head/; revision=563151
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/glmark2/Makefile30
-rw-r--r--benchmarks/glmark2/distinfo4
-rw-r--r--benchmarks/glmark2/pkg-plist16
3 files changed, 43 insertions, 7 deletions
diff --git a/benchmarks/glmark2/Makefile b/benchmarks/glmark2/Makefile
index af6a057d2883..178555838a92 100644
--- a/benchmarks/glmark2/Makefile
+++ b/benchmarks/glmark2/Makefile
@@ -3,8 +3,13 @@
PORTNAME= glmark2
PORTVERSION= 2020.04
+PORTREVISION= 1
CATEGORIES= benchmarks
+PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
+PATCHFILES+= c50755b5a193.patch:-p1 # https://github.com/glmark2/glmark2/issues/125
+PATCHFILES+= ca6e78769306.patch:-p1 # https://github.com/glmark2/glmark2/issues/125
+
MAINTAINER= danfe@FreeBSD.org
COMMENT= Benchmark for OpenGL (ES) 2.0
@@ -13,16 +18,35 @@ LICENSE= GPLv3
LIB_DEPENDS= libpng.so:graphics/png
USES= compiler:c++11-lang gl jpeg localbase:ldflags pkgconfig \
- waf xorg
-USE_XORG= x11
+ waf
USE_GL= egl gl glesv2
USE_GITHUB= yes
GH_TAGNAME= 06e4728
-CONFIGURE_ARGS= --with-flavors=x11-gl,x11-glesv2 --no-opt --no-debug
+CONFIGURE_ARGS= --with-flavors=${PLATFORMS:ts,} --no-opt --no-debug
PORTDOCS= NEWS
OPTIONS_DEFINE= DOCS
+OPTIONS_MULTI= PLATFORM
+OPTIONS_MULTI_PLATFORM= DRM WAYLAND X11
+OPTIONS_DEFAULT=DRM WAYLAND X11
+OPTIONS_SUB= yes
+
+PLATFORM_DESC= Window systems
+
+DRM_DESC= KMS console support
+DRM_LIB_DEPENDS= libudev.so:devel/libudev-devd \
+ libdrm.so:graphics/libdrm
+DRM_USE= GL=gbm
+DRM_VARS= PLATFORMS+="drm-gl drm-glesv2"
+
+WAYLAND_BUILD_DEPENDS= wayland-protocols>=1.12:graphics/wayland-protocols
+WAYLAND_LIB_DEPENDS= libwayland-egl.so:graphics/wayland
+WAYLAND_VARS= PLATFORMS+="wayland-gl wayland-glesv2"
+
+X11_USES= xorg
+X11_USE= XORG=x11
+X11_VARS= PLATFORMS+="x11-gl x11-glesv2"
post-patch:
@${REINPLACE_CMD} -e '/-std=c++/s,14,11,' ${WRKSRC}/wscript
diff --git a/benchmarks/glmark2/distinfo b/benchmarks/glmark2/distinfo
index f9f234cfb579..11cef7bb12d8 100644
--- a/benchmarks/glmark2/distinfo
+++ b/benchmarks/glmark2/distinfo
@@ -1,3 +1,7 @@
TIMESTAMP = 1588522805
SHA256 (glmark2-glmark2-2020.04-06e4728_GH0.tar.gz) = d0f09a9c84560c66f174a3e1c0ab65d92f9b4b35476cd526c4aae4efc0645091
SIZE (glmark2-glmark2-2020.04-06e4728_GH0.tar.gz) = 9364467
+SHA256 (c50755b5a193.patch) = 821772f1db7c6cd3f97112aa18d46ab194235914ab607e88a389c3a093cb42e7
+SIZE (c50755b5a193.patch) = 1305
+SHA256 (ca6e78769306.patch) = ef1b6d35422d236a84196550115007c65b355e80f0ac04134a55d68144c831e9
+SIZE (ca6e78769306.patch) = 879
diff --git a/benchmarks/glmark2/pkg-plist b/benchmarks/glmark2/pkg-plist
index 9ecdca0e1592..304bba8bce9f 100644
--- a/benchmarks/glmark2/pkg-plist
+++ b/benchmarks/glmark2/pkg-plist
@@ -1,7 +1,15 @@
-bin/glmark2
-bin/glmark2-es2
-share/man/man1/glmark2.1.gz
-share/man/man1/glmark2-es2.1.gz
+%%DRM%%bin/glmark2-drm
+%%DRM%%bin/glmark2-es2-drm
+%%WAYLAND%%bin/glmark2-wayland
+%%WAYLAND%%bin/glmark2-es2-wayland
+%%X11%%bin/glmark2
+%%X11%%bin/glmark2-es2
+%%DRM%%share/man/man1/glmark2-drm.1.gz
+%%DRM%%share/man/man1/glmark2-es2-drm.1.gz
+%%WAYLAND%%share/man/man1/glmark2-wayland.1.gz
+%%WAYLAND%%share/man/man1/glmark2-es2-wayland.1.gz
+%%X11%%share/man/man1/glmark2.1.gz
+%%X11%%share/man/man1/glmark2-es2.1.gz
%%DATADIR%%/models/asteroid-high.3ds
%%DATADIR%%/models/asteroid-low.3ds
%%DATADIR%%/models/bunny.obj