aboutsummaryrefslogtreecommitdiff
path: root/biology/ucsc-userapps/Makefile
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2021-04-25 17:18:38 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2021-04-25 17:18:38 +0000
commit6b63ef7436c4e0ec7693779240f1c90fa6e57a57 (patch)
tree0125bac2d6bb5d5ef4a2a99c966fc3329942b4aa /biology/ucsc-userapps/Makefile
parente8530452e7f432b4b8e1da82e9d139418c293985 (diff)
downloadports-6b63ef7436c4e0ec7693779240f1c90fa6e57a57.tar.gz
ports-6b63ef7436c4e0ec7693779240f1c90fa6e57a57.zip
biology/ucsc-userapps: Command line tools from the UCSC Genome Browser project
These are the command-line bioinformatics utilities associated with the UCSC genome browser. Care has been taken to install only the freely available tools. However, the license information at https://genome.ucsc.edu/license/ is not entirely clear and we may add non-free utilities in the future. Contact UCSC if you are using this port for commercial purposes.
Diffstat (limited to 'biology/ucsc-userapps/Makefile')
-rw-r--r--biology/ucsc-userapps/Makefile76
1 files changed, 76 insertions, 0 deletions
diff --git a/biology/ucsc-userapps/Makefile b/biology/ucsc-userapps/Makefile
new file mode 100644
index 000000000000..7a3244c70fcb
--- /dev/null
+++ b/biology/ucsc-userapps/Makefile
@@ -0,0 +1,76 @@
+# Created by: J. Bacon <jwb@FreeBSD.org>
+
+PORTNAME= ucsc-userapps
+DISTVERSION= 413
+CATEGORIES= biology perl5 python
+MASTER_SITES= http://hgdownload.cse.ucsc.edu/admin/exe/userApps.archive/
+DISTNAME= userApps.v${PORTVERSION}.src
+
+MAINTAINER= jwb@FreeBSD.org
+COMMENT= Command line tools from the UCSC Genome Browser project
+
+LICENSE= UCSC-GB
+LICENSE_NAME= UCSC Genome Browser License
+LICENSE_TEXT= To the best of our knowledge, all of the tools installed by\
+ this port are freely available. However, a license is\
+ required for commercial download and installation of some\
+ binaries and source code in the UCSC Genome Browser\
+ distribution.\n\nContact UCSC directly if you are using these\
+ tools for commercial purposes.\n\nSee\
+ https://genome.ucsc.edu/license/ for full terms.
+LICENSE_PERMS= no-dist-mirror no-dist-sell no-pkg-mirror no-pkg-sell
+
+ONLY_FOR_ARCHS= amd64
+ONLY_FOR_ARCHS_REASON= _mm_popcnt_u64
+
+BUILD_DEPENDS= bash:shells/bash
+LIB_DEPENDS= libiconv.so:converters/libiconv \
+ libmysqlclient.so:databases/mysql57-client \
+ libpng.so:graphics/png
+RUN_DEPENDS= bash:shells/bash
+
+USES= gmake localbase:ldflags shebangfix perl5 python:3.6+ ssl tar:tgz
+
+RESTRICTED= Redistribution is limited, see license
+
+SHEBANG_FILES= kent/src/checkUmask.sh \
+ kent/src/utils/bigHeat \
+ kent/src/utils/chromToUcsc/chromToUcsc \
+ kent/src/utils/tdbRename \
+ kent/src/utils/tdbSort \
+ kent/src/utils/trackDbIndexBb/trackDbIndexBb \
+ kent/src/utils/ucscApiClient \
+ kent/src/utils/webSync
+
+WRKSRC= ${WRKDIR}/userApps
+CFLAGS+= -fcommon
+MAKEFILE= [Mm]akefile
+MAKE_ENV= BINDIR=${WRKSRC}/bin
+
+SUB_FILES= ucsc-shell
+
+# Build only non-commercial tools
+do-build:
+ @${MV} ${WRKSRC}/kent/src/inc/uuid.h ${WRKSRC}/kent/src/inc/my_uuid.h
+ @${MKDIR} ${WRKSRC}/bin
+ @(cd ${WRKSRC}/kent/src/lib && ${DO_MAKE_BUILD})
+ @(cd ${WRKSRC}/kent/src/htslib && ${DO_MAKE_BUILD})
+ @(cd ${WRKSRC}/kent/src/jkOwnLib && ${DO_MAKE_BUILD})
+ @(cd ${WRKSRC}/kent/src/hg/lib && ${DO_MAKE_BUILD})
+ @(cd ${WRKSRC}/kent/src/utils && ${DO_MAKE_BUILD})
+
+do-install:
+ @${MKDIR} ${WRKSRC}/scripts ${WRKSRC}/binaries
+ @${CP} $$(file ${WRKSRC}/bin/* | fgrep ELF | cut -d : -f 1) \
+ ${WRKSRC}/binaries
+ @${CP} $$(file ${WRKSRC}/bin/* | fgrep -v ELF | cut -d : -f 1) \
+ ${WRKSRC}/scripts
+ @${MKDIR} ${STAGEDIR}${PREFIX}/userapps/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/binaries/* \
+ ${STAGEDIR}${PREFIX}/userapps/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/scripts/* \
+ ${STAGEDIR}${PREFIX}/userapps/bin
+ ${INSTALL_SCRIPT} ${WRKDIR}/ucsc-shell \
+ ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>