aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-10-21 15:21:13 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-10-21 15:21:13 +0000
commita0bcd2cf684ff6bc2faf242e6678282f20a3ee44 (patch)
treea5029ff30555b3a7ee0621f4dd5aacb832fde1d8 /biology
parentb7fb6d6f05e67910c9ecd4b0e0e1e0a130f8f54f (diff)
downloadports-a0bcd2cf684ff6bc2faf242e6678282f20a3ee44.tar.gz
ports-a0bcd2cf684ff6bc2faf242e6678282f20a3ee44.zip
Use USES=pathfix where applicable.
PR: 213195 Submitted by: mat Exp-run by: antoine Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D8093
Notes
Notes: svn path=/head/; revision=424427
Diffstat (limited to 'biology')
-rw-r--r--biology/htslib/Makefile3
-rw-r--r--biology/htslib/files/patch-Makefile14
-rw-r--r--biology/jellyfish/Makefile8
-rw-r--r--biology/libgtextutils/Makefile7
4 files changed, 11 insertions, 21 deletions
diff --git a/biology/htslib/Makefile b/biology/htslib/Makefile
index d906a3428bd8..1a080d9f26b1 100644
--- a/biology/htslib/Makefile
+++ b/biology/htslib/Makefile
@@ -17,10 +17,11 @@ TEST_DEPENDS= bash:shells/bash
USE_GITHUB= yes
GH_ACCOUNT= samtools
-USES= autoreconf gmake perl5 shebangfix
+USES= autoreconf gmake pathfix perl5 shebangfix
USE_PERL5= test
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
+PATHFIX_MAKEFILEIN= Makefile
SHEBANG_FILES= test/compare_sam.pl test/test.pl
OPTIONS_DEFINE= CURL
diff --git a/biology/htslib/files/patch-Makefile b/biology/htslib/files/patch-Makefile
index cb35c2f0f055..3a2b195df912 100644
--- a/biology/htslib/files/patch-Makefile
+++ b/biology/htslib/files/patch-Makefile
@@ -1,4 +1,4 @@
---- Makefile.orig 2015-12-15 16:34:33 UTC
+--- Makefile.orig 2016-04-22 08:45:12 UTC
+++ Makefile
@@ -22,16 +22,7 @@
# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
@@ -17,7 +17,7 @@
# For now these don't work too well as samtools also needs to know to
# add -lbz2 and -llzma if linking against the static libhts.a library.
-@@ -58,16 +49,10 @@ includedir = $(prefix)/include
+@@ -58,17 +49,11 @@ includedir = $(prefix)/include
libdir = $(exec_prefix)/lib
libexecdir = $(exec_prefix)/libexec
datarootdir = $(prefix)/share
@@ -25,17 +25,17 @@
+mandir = $(prefix)/man
man1dir = $(mandir)/man1
man5dir = $(mandir)/man5
--pkgconfigdir= $(libdir)/pkgconfig
--
+ pkgconfigdir= $(prefix)/libdata/pkgconfig
+
-MKDIR_P = mkdir -p
-INSTALL = install -p
-INSTALL_PROGRAM = $(INSTALL)
-INSTALL_DATA = $(INSTALL) -m 644
-INSTALL_DIR = $(MKDIR_P) -m 755
-+pkgconfigdir= $(exec_prefix)/libdata/pkgconfig
-
+-
# Set by config.mk if plugins are enabled
plugindir =
+
@@ -86,7 +71,7 @@ BUILT_TEST_PROGRAMS = \
test/test-vcf-api \
test/test-vcf-sweep
@@ -45,7 +45,7 @@
HTSPREFIX =
include htslib_vars.mk
-@@ -361,7 +346,7 @@ installdirs:
+@@ -360,7 +345,7 @@ installdirs:
# and libhts.so.NN (used by client executables at runtime).
install-so: libhts.so installdirs
diff --git a/biology/jellyfish/Makefile b/biology/jellyfish/Makefile
index 92c3e8e8fb0f..835189d8c0c9 100644
--- a/biology/jellyfish/Makefile
+++ b/biology/jellyfish/Makefile
@@ -17,7 +17,7 @@ BUILD_DEPENDS= yaggo:devel/yaggo
GNU_CONFIGURE= yes
USES= autoreconf compiler:c++11-lib gmake \
- libtool pkgconfig
+ libtool pathfix pkgconfig
USE_LDCONFIG= yes
USE_GITHUB= yes
@@ -35,10 +35,4 @@ BROKEN_FreeBSD_9_i386= multiple code issues on i386 < 10.0-RELEASE
CONFIGURE_ARGS+=--without-sse
.endif
-# configure does not support --with-pkgconfigdir
-post-patch:
- @${REINPLACE_CMD} \
- -e 's|$$(libdir)/pkgconfig|${PREFIX}/libdata/pkgconfig|g' \
- ${WRKSRC}/Makefile.am
-
.include <bsd.port.post.mk>
diff --git a/biology/libgtextutils/Makefile b/biology/libgtextutils/Makefile
index 1cc106ef7e7d..04037d5c7814 100644
--- a/biology/libgtextutils/Makefile
+++ b/biology/libgtextutils/Makefile
@@ -10,7 +10,7 @@ COMMENT= Gordon's text utilities
LICENSE= AGPLv3
-USES= autoreconf libtool pkgconfig
+USES= autoreconf libtool pathfix pkgconfig
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
@@ -19,9 +19,4 @@ GH_ACCOUNT= agordon
INSTALL_TARGET= install-strip
-post-patch:
- @${REINPLACE_CMD} \
- 's|$$(libdir)/pkgconfig|${PREFIX}/libdata/pkgconfig|' \
- ${WRKSRC}/Makefile.am
-
.include <bsd.port.mk>