aboutsummaryrefslogtreecommitdiff
path: root/chinese/ttfm/Makefile
diff options
context:
space:
mode:
authorJing-Tang Keith Jang <keith@FreeBSD.org>2000-11-13 08:48:09 +0000
committerJing-Tang Keith Jang <keith@FreeBSD.org>2000-11-13 08:48:09 +0000
commit09cc04f6feb40fc61141ffa36244af2c13ae0741 (patch)
treefd3329797079023b2b9db6cde6a1218e21c58285 /chinese/ttfm/Makefile
parent10c2171c8a61f9d2100ad5d7c4f1f4593fc0dc94 (diff)
downloadports-09cc04f6feb40fc61141ffa36244af2c13ae0741.tar.gz
ports-09cc04f6feb40fc61141ffa36244af2c13ae0741.zip
New port added: ttfm
A True Type Font Manager that handles true type font installation, uninstallation, list, and default font setting. It was originally in the CLE Linux distribution, modified by Cheng Yuan-Chung from Joerg Pommnitz's ttmkfdir, to have Big5/GB TTF better detection. There are four modules as of version 0.9.0 for their respective apps: chitex: For ChiTeX, a Chinese TeX/LaTeX ttf2pk: Generate pk/tfm for CJK xfreetype: For Xfsft in XFree86 3.3.x and "freetype" module in 4.x xttfm: For X-TT in XFree86 3.3.x and "xtt" module in 4.x, available in both tcl and sh versions. Since ChiTeX hasn't been ported yet, CJK needs further tuning, only xfreetype & xttfm are available right now. Future applications which uses TTF(like ghostscript) should use TTFM to manage TTF. The importing of this port also implies existing ports like arphicttf/moettf should be re-written. /me is always able to find trouble for himself. :-)
Notes
Notes: svn path=/head/; revision=35057
Diffstat (limited to 'chinese/ttfm/Makefile')
-rw-r--r--chinese/ttfm/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/chinese/ttfm/Makefile b/chinese/ttfm/Makefile
new file mode 100644
index 000000000000..8a7cae43d03f
--- /dev/null
+++ b/chinese/ttfm/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: zh-ttfm
+# Date created: 12 Nov 2000
+# Whom: Jing-Tang Keith Jang <keith@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ttfm
+PORTVERSION= 0.9.0
+CATEGORIES= chinese print
+MASTER_SITES= ftp://freebsd.sinica.edu.tw/pub/keith/
+
+MAINTAINER= keith@FreeBSD.org
+
+USE_FREETYPE= yes
+
+FONTSDIR= ${PREFIX}/share/fonts/ttf/
+MODULESDIR= ${PREFIX}/share/ttfm/
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/ttfinfo ${PREFIX}/bin
+ @${INSTALL_SCRIPT} ${WRKSRC}/ttfm.sh ${PREFIX}/bin
+ @${MKDIR} ${PREFIX}/share/doc/ttfm
+.for doc in README USAGE
+ @${INSTALL_DATA} ${WRKSRC}/${doc} ${PREFIX}/share/doc/ttfm
+.endfor
+ @${MKDIR} ${MODULESDIR}
+.for module in xfreetype.ttfm xttfm.ttfm
+ @${INSTALL_SCRIPT} ${WRKSRC}/modules/${module} ${MODULESDIR}
+.endfor
+.for module in chitex.ttfm ttf2pk.ttfm xttfm-tcl.ttfm
+ @${INSTALL_SCRIPT} ${WRKSRC}/modules/${module} ${MODULESDIR}/${module}.nop
+.endfor
+ @${MKDIR} ${FONTSDIR}
+
+.include <bsd.port.mk>