aboutsummaryrefslogtreecommitdiff
path: root/converters
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-06-11 14:49:59 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-06-11 14:49:59 +0000
commit9f8b4bcde30c0ca3bf6cead5f48aa102536e0e92 (patch)
treec4f78cbaf45ab044db3e157be708afd711a4e841 /converters
parent0533abe3e7aae5c19e0a0ce9c1e82ed5e94f63e8 (diff)
downloadports-9f8b4bcde30c0ca3bf6cead5f48aa102536e0e92.tar.gz
ports-9f8b4bcde30c0ca3bf6cead5f48aa102536e0e92.zip
Support LIBS like LDFLAGS.
- Add LIBS="${LIBS}" to MAKE_ENV and CONFIGURE_ENV. - Add an option helper for LIBS. - Adjust all ports that already use LIBS. Also remove references to PTHREAD_CFLAGS and PTHREAD_LIBS while here. - Some ports did not support having a LIBS environment variable and required additional patches. Somewhat simplified a linker command line looks like: ${CC} ${src_LDFLAGS} ${LDFLAGS} ${src_LIBS} ${LIBS} where src_LDFLAGS and src_LIBS are controlled by upstream and LDFLAGS and LIBS can be controlled by us. If possible -L and -l flags need to be added to LIBS to make sure they appear after any -L and -l flags set by upstream. Many ports currently add -L${LOCALBASE}/lib to LDFLAGS but this may appear too early on the command line causing installed libraries to be linked in instead of freshly built ones. Additional changes: benchmarks/netio: Replace WITH_IPV6 with an IPV6 option. comms/gnokii: Replace some patches with USES=pathfix. Also remove -fPIC. graphics/gimageview: USES=libtool and install desktop file in DESKTOPDIR. graphics/visionworkbench: Remove FreeBSD 7 support. multimedia/libmovtar: New LIB_DEPENDS syntax. multimedia/opencinematools: Use standard do-build. net/siproxd: USES=libtool:keepla (port actually needs .la files for plugins) net-mgmt/nagios: Remove -fPIC. net-mgmt/nagios4: Remove -fPIC. print/cups-base: Only add -lssp_nonshared on i386 and OSVERSION < 1000036. security/p11-kit: Replace PTHREAD_LIBS in CONFIGURE_ENV with ac_cv_func_pthread_mutexattr_init=no in CONFIGURE_ARGS. This skips a test in configure that falsely detects pthread_mutexattr_init in our libc. sysutils/dar: Fix iconv detection. x11/rxvt-unicode: Remove -lstdc++ and patch configure to remove a FreeBSD hack and use $CXX as linker as on other platforms. PR: 190592 Exp-run by: antoine Approved by: portmgr (antoine)
Notes
Notes: svn path=/head/; revision=357486
Diffstat (limited to 'converters')
-rw-r--r--converters/fix-mime-charset/Makefile2
-rw-r--r--converters/pdf2djvu/Makefile2
-rw-r--r--converters/rcctools/Makefile2
3 files changed, 2 insertions, 4 deletions
diff --git a/converters/fix-mime-charset/Makefile b/converters/fix-mime-charset/Makefile
index 1f678d11cf65..2b3ad4bfd193 100644
--- a/converters/fix-mime-charset/Makefile
+++ b/converters/fix-mime-charset/Makefile
@@ -20,8 +20,8 @@ GNU_CONFIGURE= yes
USES= perl5
USE_PERL5= build
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
PLIST_FILES= bin/fix-mime-charset \
man/man1/fix-mime-charset.1.gz
diff --git a/converters/pdf2djvu/Makefile b/converters/pdf2djvu/Makefile
index c964d193f13d..14ed2a1db1b3 100644
--- a/converters/pdf2djvu/Makefile
+++ b/converters/pdf2djvu/Makefile
@@ -18,8 +18,6 @@ LIB_DEPENDS= libpoppler.so:${PORTSDIR}/graphics/poppler \
libdjvulibre.so:${PORTSDIR}/graphics/djvulibre
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LIBS=-pthread
-CPPFLAGS+= -I${LOCALBASE}/include
USES= compiler:c++11-lang gmake pkgconfig
PLIST_FILES= bin/pdf2djvu man/man1/pdf2djvu.1.gz
diff --git a/converters/rcctools/Makefile b/converters/rcctools/Makefile
index 1706fdea8a5d..8441e79c60ba 100644
--- a/converters/rcctools/Makefile
+++ b/converters/rcctools/Makefile
@@ -15,8 +15,8 @@ LIB_DEPENDS= librcc.so:${PORTSDIR}/devel/librcc
USE_BZIP2= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
PLIST_FILES= bin/rcc-recode