aboutsummaryrefslogtreecommitdiff
path: root/databases/kbibtex/Makefile
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-12-30 17:46:22 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-12-30 17:46:22 +0000
commit9dbbc5bbea9095ce92b8bc358d0521271f273279 (patch)
treec118d4b12634324b27d0cbaa654fb07496125382 /databases/kbibtex/Makefile
parente67afdc30c2ed19735af5dbe614845ab07eb6754 (diff)
downloadports-9dbbc5bbea9095ce92b8bc358d0521271f273279.tar.gz
ports-9dbbc5bbea9095ce92b8bc358d0521271f273279.zip
databases/kbibtex: make webengine optional (used for non i386/amd64 architectures)
- switch to useing WebKit if WebEngine is deselected PR: 234461 Submitted by: Piotr Kubaj <pkubaj@anongoth.pl>
Notes
Notes: svn path=/head/; revision=488726
Diffstat (limited to 'databases/kbibtex/Makefile')
-rw-r--r--databases/kbibtex/Makefile17
1 files changed, 13 insertions, 4 deletions
diff --git a/databases/kbibtex/Makefile b/databases/kbibtex/Makefile
index 23d6a76b2be9..85dd23308c63 100644
--- a/databases/kbibtex/Makefile
+++ b/databases/kbibtex/Makefile
@@ -16,16 +16,25 @@ LIB_DEPENDS= libicuuc.so:devel/icu \
libpoppler-qt5.so:graphics/poppler-qt5 \
libqoauth-qt5.so:net/qoauth-qt5
-USES= cmake desktop-file-utils gettext iconv kde:5 qt:5 \
- shared-mime-info tar:xz
+USES= cmake compiler:c++11-lang desktop-file-utils gettext gnome \
+ iconv kde:5 qt:5 shared-mime-info tar:xz
USE_GNOME= libxml2 libxslt
USE_KDE= auth bookmarks codecs completion config configwidgets \
coreaddons crash ecm i18n iconthemes itemviews jobwidgets \
kio parts service solid sonnet textwidgets wallet \
widgetsaddons xmlgui
-USE_QT= concurrent core dbus declarative gui location network printsupport \
- webchannel webengine widgets xml xmlpatterns \
+USE_QT= concurrent core dbus declarative gui location network \
+ printsupport webchannel widgets xml xmlpatterns \
buildtools_build qmake_build
USE_LDCONFIG= yes
+OPTIONS_DEFINE= WEBENGINE
+OPTIONS_DEFAULT_amd64= WEBENGINE
+OPTIONS_DEFAULT_i386= WEBENGINE
+
+WEBENGINE_DESC= Add dependency on qt5-webengine
+WEBENGINE_USE= QT=webengine
+WEBENGINE_USE_OFF= QT=webkit
+WEBENGINE_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_Qt5WebEngineWidgets
+
.include <bsd.port.mk>