aboutsummaryrefslogtreecommitdiff
path: root/databases/kbibtex
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2012-05-08 23:02:44 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2012-05-08 23:02:44 +0000
commitc02c892e11d37d7367beed075afb35985e2a5cd1 (patch)
tree36af08776fb4a2e80a93688145f7af9ce838dc7b /databases/kbibtex
parent0daac9a63ab3cc3e3924e7f76e0d0877ae3d44fc (diff)
downloadports-c02c892e11d37d7367beed075afb35985e2a5cd1.tar.gz
ports-c02c892e11d37d7367beed075afb35985e2a5cd1.zip
Update to 0.4 for KDE 4
Take maintainership
Notes
Notes: svn path=/head/; revision=296259
Diffstat (limited to 'databases/kbibtex')
-rw-r--r--databases/kbibtex/Makefile23
-rw-r--r--databases/kbibtex/distinfo4
-rw-r--r--databases/kbibtex/files/patch-src-fileexporterbibtex.cpp11
-rw-r--r--databases/kbibtex/files/patch-src-fileimporterbibtex.cpp11
-rw-r--r--databases/kbibtex/files/patch-src__gui__bibtex__bibtexfileview.h10
-rw-r--r--databases/kbibtex/files/patch-src__libkbibtexio__iconvlatex.cpp11
-rw-r--r--databases/kbibtex/pkg-descr4
-rw-r--r--databases/kbibtex/pkg-plist42
8 files changed, 58 insertions, 58 deletions
diff --git a/databases/kbibtex/Makefile b/databases/kbibtex/Makefile
index 2f8eceb63eb9..e1feb74ad70a 100644
--- a/databases/kbibtex/Makefile
+++ b/databases/kbibtex/Makefile
@@ -5,24 +5,27 @@
# $FreeBSD$
PORTNAME= kbibtex
-PORTVERSION= 0.2.3
-PORTREVISION= 3
+DISTVERSION= 0.4
CATEGORIES= databases kde
-MASTER_SITES= http://www.unix-ag.uni-kl.de/~fischer/${PORTNAME}/download/
+MASTER_SITES= http://download.gna.org/${PORTNAME}/${PORTVERSION:C,(^[[:digit:]]\.[[:digit:]]).*,\1,}/
-MAINTAINER= ports@FreeBSD.org
-COMMENT= BibTeX editor for KDE
+MAINTAINER= makc@FreeBSD.org
+COMMENT= Bibliography editor for KDE
-LIB_DEPENDS= yaz.4:${PORTSDIR}/net/yaz
+LIB_DEPENDS= poppler-qt4.3:${PORTSDIR}/graphics/poppler-qt4
USE_BZIP2= yes
-USE_KDELIBS_VER=3
-USE_GMAKE= yes
-USE_AUTOTOOLS= libtool
+USE_CMAKE= yes
+USE_GNOME= libxml2 libxslt
+USE_KDE4= kdelibs kdeprefix automoc4 sharedmime
+USE_QT_VER= 4
+QT_COMPONENTS= qmake_build moc_build uic_build rcc_build \
+ webkit
+MAKE_JOBS_SAFE= yes
MAN1= kbibtex.1
post-patch:
- @${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/${CONFIGURE_SCRIPT}
+ ${REINPLACE_CMD} -e 's,share/man,man,' ${WRKSRC}/CMakeLists.txt
.include <bsd.port.mk>
diff --git a/databases/kbibtex/distinfo b/databases/kbibtex/distinfo
index 058a28645b3c..9451f2f0b26c 100644
--- a/databases/kbibtex/distinfo
+++ b/databases/kbibtex/distinfo
@@ -1,2 +1,2 @@
-SHA256 (kbibtex-0.2.3.tar.bz2) = 2a2628564c2337d8cf94742c5231261655cf89ad59b6e3f3f1fabedc3a37d82b
-SIZE (kbibtex-0.2.3.tar.bz2) = 841523
+SHA256 (kbibtex-0.4.tar.bz2) = 9a7f969d645cebb50b653db811b6bba734eb93e44e72237e49c1a4dbc05700c3
+SIZE (kbibtex-0.4.tar.bz2) = 191138
diff --git a/databases/kbibtex/files/patch-src-fileexporterbibtex.cpp b/databases/kbibtex/files/patch-src-fileexporterbibtex.cpp
deleted file mode 100644
index 1138cfa90e21..000000000000
--- a/databases/kbibtex/files/patch-src-fileexporterbibtex.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/fileexporterbibtex.cpp.orig 2010-02-01 19:08:49.000000000 +0100
-+++ src/fileexporterbibtex.cpp 2010-02-01 19:17:03.000000000 +0100
-@@ -258,7 +258,7 @@
- for ( i = 0; i < encodeMaxTries && utf8datasize != 0; ++i )
- {
- QCString utf8 = workingText.utf8();
-- char *utf8data = utf8.data();
-+ const char *utf8data = utf8.data();
- utf8datasize = utf8.length();
- char *outputdata = m_iconvBuffer;
- size_t outputdatasize = m_iconvBufferSize;
diff --git a/databases/kbibtex/files/patch-src-fileimporterbibtex.cpp b/databases/kbibtex/files/patch-src-fileimporterbibtex.cpp
deleted file mode 100644
index df7a7125063e..000000000000
--- a/databases/kbibtex/files/patch-src-fileimporterbibtex.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/fileimporterbibtex.cpp.orig 2010-02-01 19:17:54.000000000 +0100
-+++ src/fileimporterbibtex.cpp 2010-02-01 19:18:23.000000000 +0100
-@@ -67,7 +67,7 @@
- {
- evaluateParameterComments( iconvHandle, m_lineBuffer );
-
-- char *raw = m_lineBuffer;
-+ const char *raw = m_lineBuffer;
- char *enc = convertedLine;
- size_t encLen = m_lineBufferSize, rawLen = ( size_t )len;
- size_t result = iconv( iconvHandle, &raw, &rawLen, &enc, &encLen );
diff --git a/databases/kbibtex/files/patch-src__gui__bibtex__bibtexfileview.h b/databases/kbibtex/files/patch-src__gui__bibtex__bibtexfileview.h
new file mode 100644
index 000000000000..0044a7a286af
--- /dev/null
+++ b/databases/kbibtex/files/patch-src__gui__bibtex__bibtexfileview.h
@@ -0,0 +1,10 @@
+--- ./src/gui/bibtex/bibtexfileview.h.orig 2012-05-05 10:50:42.000000000 +0000
++++ ./src/gui/bibtex/bibtexfileview.h 2012-05-06 00:53:34.029244696 +0000
+@@ -21,6 +21,7 @@
+ #define KBIBTEX_GUI_BIBTEXFILEVIEW_H
+
+ #include <QTreeView>
++#include <KMimeType>
+
+ #include <kbibtexgui_export.h>
+
diff --git a/databases/kbibtex/files/patch-src__libkbibtexio__iconvlatex.cpp b/databases/kbibtex/files/patch-src__libkbibtexio__iconvlatex.cpp
new file mode 100644
index 000000000000..1769cd6b4c3d
--- /dev/null
+++ b/databases/kbibtex/files/patch-src__libkbibtexio__iconvlatex.cpp
@@ -0,0 +1,11 @@
+--- ./src/libkbibtexio/iconvlatex.cpp.orig 2012-05-05 10:50:42.000000000 +0000
++++ ./src/libkbibtexio/iconvlatex.cpp 2012-05-06 00:53:04.285249457 +0000
+@@ -58,7 +58,7 @@
+ QByteArray IConvLaTeX::encode(const QString &input)
+ {
+ QByteArray inputByteArray = input.toUtf8();
+-#ifdef Q_WS_WIN
++#ifndef Q_OS_LINUX
+ /// iconv on Windows likes to have it as const char *
+ const char *inputBuffer = inputByteArray.data();
+ #else
diff --git a/databases/kbibtex/pkg-descr b/databases/kbibtex/pkg-descr
index 12c204068173..b9e192441600 100644
--- a/databases/kbibtex/pkg-descr
+++ b/databases/kbibtex/pkg-descr
@@ -1,3 +1,3 @@
-KBibTeX is a BibTeX editor for KDE.
+KBibTeX is a bibliography editor for KDE.
-WWW: http://www.unix-ag.uni-kl.de/~fischer/kbibtex/
+WWW: http://home.gna.org/kbibtex/
diff --git a/databases/kbibtex/pkg-plist b/databases/kbibtex/pkg-plist
index aa471ab24524..0b4550f9a802 100644
--- a/databases/kbibtex/pkg-plist
+++ b/databases/kbibtex/pkg-plist
@@ -1,31 +1,29 @@
bin/kbibtex
-lib/kde3/libkbibtexpart.a
-lib/kde3/libkbibtexpart.la
-lib/kde3/libkbibtexpart.so
-share/applications/kde/kbibtex.desktop
-share/apps/kbibtex/kbibtex_shell.rc
-share/apps/kbibtex/z3950-servers.cfg
-share/apps/kbibtexpart/kbibtex_part.rc
-share/apps/kbibtexpart/xslt/MARC21slim2MODS3.xsl
-share/apps/kbibtexpart/xslt/MARC21slimUtils.xsl
-share/apps/kbibtexpart/xslt/UNIMARC2MODS3.xsl
-share/apps/kbibtexpart/xslt/html.xsl
-share/doc/HTML/en/kbibtex/common
-share/doc/HTML/en/kbibtex/index.cache.bz2
-share/doc/HTML/en/kbibtex/index.docbook
+lib/kde4/kbibtexpart.so
+lib/libkbibtexgui.so
+lib/libkbibtexio.so
+lib/libkbibtexproc.so
+lib/libkbibtexws.so
+share/applications/kde4/kbibtex.desktop
+share/apps/kbibtex/abstractonly.xsl
+share/apps/kbibtex/arxiv2bibtex.xsl
+share/apps/kbibtex/fancy.xsl
+share/apps/kbibtex/findduplicatesui.rc
+share/apps/kbibtex/kbibtexui.rc
+share/apps/kbibtex/lyx.rc
+share/apps/kbibtex/pubmed2bibtex.xsl
+share/apps/kbibtex/standard.xsl
+share/apps/kbibtexpart/kbibtexpartui.rc
+share/config/kbibtexrc
share/icons/hicolor/128x128/apps/kbibtex.png
share/icons/hicolor/16x16/apps/kbibtex.png
share/icons/hicolor/22x22/apps/kbibtex.png
share/icons/hicolor/32x32/apps/kbibtex.png
share/icons/hicolor/48x48/apps/kbibtex.png
share/icons/hicolor/64x64/apps/kbibtex.png
-share/locale/de/LC_MESSAGES/kbibtex.mo
-share/locale/fr/LC_MESSAGES/kbibtex.mo
-share/locale/it/LC_MESSAGES/kbibtex.mo
-share/locale/pl/LC_MESSAGES/kbibtex.mo
-share/locale/ru/LC_MESSAGES/kbibtex.mo
-share/services/kbibtex_part.desktop
-@dirrm share/doc/HTML/en/kbibtex
-@dirrm share/apps/kbibtexpart/xslt
+share/kde4/services/kbibtexpart.desktop
+share/mime/application/x-endnote-refer.xml
+share/mime/application/x-research-info-systems.xml
+share/mime/packages/bibliography.xml
@dirrm share/apps/kbibtexpart
@dirrm share/apps/kbibtex