aboutsummaryrefslogtreecommitdiff
path: root/databases/linux-c7-sqlite3/Makefile
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2016-10-19 14:50:26 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2016-10-19 14:50:26 +0000
commit1675ff649cded4c85d65feb0f4c5cc87010242eb (patch)
tree3e3556f1e26a35be0250e7f749680b9fc30e9c6b /databases/linux-c7-sqlite3/Makefile
parent4fd1b570a8aec1244c7b8469c29c309a96a46804 (diff)
downloadports-1675ff649cded4c85d65feb0f4c5cc87010242eb.tar.gz
ports-1675ff649cded4c85d65feb0f4c5cc87010242eb.zip
Add Linux CentOS 7 infrastructure ports.
Mk/Uses/linux.mk changes: - Add support for architecture neutral (noarch) distfiles. - Add support for 64-bit only ports: set IGNORE on i386 and don't install 32-bit compat libraries on amd64. Submitted by: Piotr Kubaj <pkubaj@anongoth.pl> Differential Revision: https://reviews.freebsd.org/D7886
Notes
Notes: svn path=/head/; revision=424259
Diffstat (limited to 'databases/linux-c7-sqlite3/Makefile')
-rw-r--r--databases/linux-c7-sqlite3/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/databases/linux-c7-sqlite3/Makefile b/databases/linux-c7-sqlite3/Makefile
new file mode 100644
index 000000000000..3f8ead844d7c
--- /dev/null
+++ b/databases/linux-c7-sqlite3/Makefile
@@ -0,0 +1,23 @@
+# Created by: Piotr Kubaj <pkubaj@anongoth.pl>
+# $FreeBSD$
+
+PORTNAME= sqlite
+PORTVERSION= 3.7.17
+CATEGORIES= databases linux
+
+MAINTAINER= emulation@FreeBSD.org
+COMMENT= Library that implements an embeddable SQL database engine (Linux CentOS ${LINUX_DIST_VER})
+
+LICENSE= PD
+
+CONFLICTS= linux-f10-${PORTNAME}3-[0-9]* linux-c6-${PORTNAME}-[0-9]*
+
+RPMVERSION= 8.el7
+USES= linux:c7
+USE_LDCONFIG= yes
+USE_LINUX_RPM= yes
+
+PORTDOCS= README
+DESCR= ${.CURDIR}/../${PORTNAME}3/pkg-descr
+
+.include <bsd.port.mk>