aboutsummaryrefslogtreecommitdiff
path: root/databases/mongodb/Makefile
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2013-08-13 13:17:49 +0000
committerAlex Dupre <ale@FreeBSD.org>2013-08-13 13:17:49 +0000
commit60efe1a86c1c3121babcfda21b6546250a67b1a2 (patch)
treef18292a50aea05fb9f5b12413188e57c0c56cb6a /databases/mongodb/Makefile
parent56470748783a5a50afd65c6a27aeec46c9994661 (diff)
downloadports-60efe1a86c1c3121babcfda21b6546250a67b1a2.tar.gz
ports-60efe1a86c1c3121babcfda21b6546250a67b1a2.zip
Update to 2.4.5 release.
Add support for SASL client authentication Build shared library.
Notes
Notes: svn path=/head/; revision=324663
Diffstat (limited to 'databases/mongodb/Makefile')
-rw-r--r--databases/mongodb/Makefile17
1 files changed, 14 insertions, 3 deletions
diff --git a/databases/mongodb/Makefile b/databases/mongodb/Makefile
index ec1807dd184e..b771928d46fd 100644
--- a/databases/mongodb/Makefile
+++ b/databases/mongodb/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= mongodb
-PORTVERSION= 2.4.4
+PORTVERSION= 2.4.5
CATEGORIES= databases net
MASTER_SITES= http://downloads.mongodb.org/src/
DISTNAME= ${PORTNAME}-src-r${PORTVERSION}
@@ -24,19 +24,23 @@ LIB_DEPENDS= execinfo:${PORTSDIR}/devel/libexecinfo \
ONLY_FOR_ARCHS= i386 amd64
ONLY_FOR_ARCHS_REASON= "not yet ported to anything other than i386 and amd64"
-OPTIONS_DEFINE= SM SSL TEST
+OPTIONS_DEFINE= SM SSL SASL TEST
OPTIONS_DEFAULT=SSL
SM_DESC= Use SpiderMonkey instead of V8 for JavaScript
TEST_DESC= Add support for running regression test
USE_SCONS= yes
-SCONS_ARGS= --prefix=${PREFIX} --cc=${CC} --cxx=${CXX} --use-system-pcre --use-system-snappy
+SCONS_ARGS= --prefix=${PREFIX} --cc=${CC} --cxx=${CXX} \
+ --use-system-pcre --use-system-snappy \
+ --full --sharedclient
USERS= mongodb
GROUPS= mongodb
USE_RC_SUBR= mongod
+USE_LDCONFIG= yes
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MSM}
@@ -52,6 +56,11 @@ USE_OPENSSL= yes
SCONS_ARGS+= --ssl
.endif
+.if ${PORT_OPTIONS:MSASL}
+SCONS_ARGS+= --use-sasl-client
+LIB_DEPENDS+= sasl2:${PORTSDIR}/security/cyrus-sasl2
+.endif
+
.if ${PORT_OPTIONS:MTEST}
BUILD_DEPENDS= pymongo>=2.5:${PORTSDIR}/databases/pymongo
SCONS_TARGET= all
@@ -68,6 +77,8 @@ post-patch:
${WRKSRC}/SConstruct
post-install:
+ @${LN} -s ${PREFIX}/lib/libmongoclient.so \
+ ${PREFIX}/lib/libmongoclient.so.0
@if [ ! -f ${PREFIX}/etc/mongodb.conf ]; then \
${TOUCH} ${PREFIX}/etc/mongodb.conf ; \
fi