aboutsummaryrefslogtreecommitdiff
path: root/databases/mongodb/Makefile
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2014-05-12 12:59:48 +0000
committerAlex Dupre <ale@FreeBSD.org>2014-05-12 12:59:48 +0000
commitc7a80e2f5615ff1a3f6a1a08473abda784fe73a5 (patch)
tree7115315c17fcc5156ccb680e3944e8bfe4a9c62e /databases/mongodb/Makefile
parent64ca0512ccfe7532774c31148d262562c325b1ed (diff)
downloadports-c7a80e2f5615ff1a3f6a1a08473abda784fe73a5.tar.gz
ports-c7a80e2f5615ff1a3f6a1a08473abda784fe73a5.zip
Update to 2.6.1 release.
Notes
Notes: svn path=/head/; revision=353816
Diffstat (limited to 'databases/mongodb/Makefile')
-rw-r--r--databases/mongodb/Makefile29
1 files changed, 8 insertions, 21 deletions
diff --git a/databases/mongodb/Makefile b/databases/mongodb/Makefile
index 7f86f9c1a08a..09ac375ef225 100644
--- a/databases/mongodb/Makefile
+++ b/databases/mongodb/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= mongodb
-PORTVERSION= 2.4.10
+PORTVERSION= 2.6.1
CATEGORIES= databases net
MASTER_SITES= http://downloads.mongodb.org/src/
DISTNAME= ${PORTNAME}-src-r${PORTVERSION}
@@ -16,23 +16,25 @@ LICENSE_COMB= multi
LIB_DEPENDS= libexecinfo.so:${PORTSDIR}/devel/libexecinfo \
libpcre.so:${PORTSDIR}/devel/pcre \
- libsnappy.so:${PORTSDIR}/archivers/snappy
+ libsnappy.so:${PORTSDIR}/archivers/snappy \
+ libv8.so:${PORTSDIR}/lang/v8 \
# boost 1.52/1.55 from ports make mongod segfaulting with many tests
# LIB_DEPENDS+= libboost_system.so:${PORTSDIR}/devel/boost-libs
# MAKE_ARGS+= --use-system-boost
+# use bundled yaml
+# MAKE_ARGS+= --use-system-yaml
+# LIB_DEPENDS+= libyaml-cpp.so:${PORTSDIR}/devel/yaml-cpp
ONLY_FOR_ARCHS= i386 amd64
ONLY_FOR_ARCHS_REASON= "not yet ported to anything other than i386 and amd64"
-OPTIONS_DEFINE= SM SSL SASL TEST
+OPTIONS_DEFINE= SSL SASL TEST
OPTIONS_DEFAULT=SSL
-SM_DESC= Use SpiderMonkey instead of V8 for JavaScript
TEST_DESC= Add support for running regression test
USES= scons
MAKE_ARGS= --prefix=${STAGEDIR}${PREFIX} --cc=${CC} --cxx=${CXX} \
- --use-system-pcre --use-system-snappy \
- --full --sharedclient
+ --use-system-pcre --use-system-snappy --use-system-v8
USERS= mongodb
GROUPS= mongodb
@@ -43,14 +45,6 @@ PORTSCOUT= limitw:1,even
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MSM}
-MAKE_ARGS+= --usesm --use-system-sm
-LIB_DEPENDS+= libjs.so:${PORTSDIR}/lang/spidermonkey17
-.else
-MAKE_ARGS+= --usev8 --use-system-v8
-LIB_DEPENDS+= libv8.so:${PORTSDIR}/lang/v8
-.endif
-
.if ${PORT_OPTIONS:MSSL}
USE_OPENSSL= yes
MAKE_ARGS+= --ssl
@@ -71,13 +65,6 @@ TEST_TARGET+= smokeSsl
ALL_TARGET= core tools
.endif
-.if ${OSVERSION} >= 1000024
-EXTRA_PATCHES= ${PATCHDIR}/clang-patch-src_mongo_db_fts_stemmer.cpp \
- ${PATCHDIR}/clang-patch-src_mongo_platform_unordered_map.h \
- ${PATCHDIR}/clang-patch-src_mongo_platform_unordered_set.h \
- ${PATCHDIR}/clang-patch-src_third_party_s2_hash.h
-.endif
-
post-patch:
@${REINPLACE_CMD} 's/\["-O3"\]/"${CFLAGS}"/' \
${WRKSRC}/SConstruct