aboutsummaryrefslogtreecommitdiff
path: root/databases/opentsdb
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2016-01-06 08:50:23 +0000
committerMartin Wilke <miwi@FreeBSD.org>2016-01-06 08:50:23 +0000
commit48ab24dea6c1eb49d81dcaccfd70a12f2df31855 (patch)
tree1019ad2045f2fe69e731dc7cef0b9a1ff5930654 /databases/opentsdb
parentb654a36ca178c546070340ae16f17cb11657a659 (diff)
downloadports-48ab24dea6c1eb49d81dcaccfd70a12f2df31855.tar.gz
ports-48ab24dea6c1eb49d81dcaccfd70a12f2df31855.zip
- Fix wrong path searching for logback.xml
- While here remove unused sed line - Bump PORTREVISION PR: 205868 Submitted by: Davide D'Amico (based on) Approved by: Johannes Jost Meixner (maintainer)
Notes
Notes: svn path=/head/; revision=405340
Diffstat (limited to 'databases/opentsdb')
-rw-r--r--databases/opentsdb/Makefile2
-rw-r--r--databases/opentsdb/files/patch-Makefile.in7
2 files changed, 6 insertions, 3 deletions
diff --git a/databases/opentsdb/Makefile b/databases/opentsdb/Makefile
index 704683549e8a..634097ec58e2 100644
--- a/databases/opentsdb/Makefile
+++ b/databases/opentsdb/Makefile
@@ -3,6 +3,7 @@
PORTNAME= opentsdb
PORTVERSION= 2.1.3
+PORTREVISION= 1
CATEGORIES= databases java
MASTER_SITES= https://github.com/OpenTSDB/opentsdb/releases/download/v${PORTVERSION}/
@@ -45,7 +46,6 @@ SUB_LIST= OPENTSDB_USER="${OPENTSDB_USER}" \
post-patch:
${REINPLACE_CMD} -i "" -e "s|python|${PYTHON_CMD}|" ${WRKSRC}/build-aux/gen_build_data.sh
- #${REINPLACE_CMD} -i "" -e "s|%%PREFIX%%|${PREFIX}|" ${WRKSRC}/Makefile.in
${REINPLACE_CMD} -i "" -e "s|%%PREFIX%%|${PREFIX}|" ${WRKSRC}/src/utils/Config.java
${REINPLACE_CMD} -i "" -e "s|tsd.http.staticroot =|tsd.http.staticroot = ${DATADIR}/static|; s|tsd.http.cachedir =|tsd.http.cachedir = /tmp/opentsdb|; s|tsd.network.port =|tsd.network.port = 4242|;" ${WRKSRC}/src/opentsdb.conf
diff --git a/databases/opentsdb/files/patch-Makefile.in b/databases/opentsdb/files/patch-Makefile.in
index 15c4844ddd66..5b65f53154ca 100644
--- a/databases/opentsdb/files/patch-Makefile.in
+++ b/databases/opentsdb/files/patch-Makefile.in
@@ -1,8 +1,11 @@
--- Makefile.in.orig 2015-11-11 20:54:56 UTC
+++ Makefile.in
-@@ -1315,7 +1315,9 @@ printdeps:
+@@ -1313,9 +1313,11 @@ printdeps:
+ # This is kind of a hack, but I couldn't find a better way to adjust the paths
+ # in the script before it gets installed...
install-exec-hook:
- script=tsdb; pkgdatadir='$(pkgdatadir)'; configdir='$(sysconfigdir)/etc/opentsdb'; \
+- script=tsdb; pkgdatadir='$(pkgdatadir)'; configdir='$(sysconfigdir)/etc/opentsdb'; \
++ script=tsdb; pkgdatadir='$(pkgdatadir)'; configdir='$(sysconfdir)/opentsdb'; \
abs_srcdir=''; abs_builddir=''; $(edit_tsdb_script)
+ chmod u+w "$(DESTDIR)$(bindir)/tsdb"
cat tsdb.tmp >"$(DESTDIR)$(bindir)/tsdb"