aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBIx-DataSource/Makefile
diff options
context:
space:
mode:
authorDaniel Harris <dannyboy@FreeBSD.org>2001-06-11 17:53:31 +0000
committerDaniel Harris <dannyboy@FreeBSD.org>2001-06-11 17:53:31 +0000
commita446996e715c6ac3ac6dd6daf2d9ced3a473314b (patch)
tree17c84a58cdcdecbeb8d97805545319b44b19b43d /databases/p5-DBIx-DataSource/Makefile
parentca2e6f1fe1663fffe428fa6f8d3444a358aa9036 (diff)
downloadports-a446996e715c6ac3ac6dd6daf2d9ced3a473314b.tar.gz
ports-a446996e715c6ac3ac6dd6daf2d9ced3a473314b.zip
Add p5-DBIx-DataSource 0.02,
database-independent create and drop functions. PR: 27804 Submitted by: Anton Berezin <tobez@tobez.org>
Notes
Notes: svn path=/head/; revision=43858
Diffstat (limited to 'databases/p5-DBIx-DataSource/Makefile')
-rw-r--r--databases/p5-DBIx-DataSource/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/databases/p5-DBIx-DataSource/Makefile b/databases/p5-DBIx-DataSource/Makefile
new file mode 100644
index 000000000000..e57e8cf6ccf2
--- /dev/null
+++ b/databases/p5-DBIx-DataSource/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: databases/p5-DBIx-DataSource
+# Date created: 01 June 2001
+# Whom: Anton Berezin <tobez@tobez.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DBIx-DataSource
+PORTVERSION= 0.02
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DBIx
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@tobez.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= DBIx::DataSource.3 DBIx::DataSource::Driver.3 \
+ DBIx::DataSource::mysql.3 DBIx::DataSource::Pg.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>