aboutsummaryrefslogtreecommitdiff
path: root/databases/sqlite3/Makefile
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-09-24 22:46:36 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-09-24 22:46:36 +0000
commitb8bede3836f0093acd2ab3084970e49156786b09 (patch)
tree8a024e9d855607372441ab04d24e3c847db24e5c /databases/sqlite3/Makefile
parentea26f71ca2fe21adcfa3351ae1ab5c77e7176c41 (diff)
downloadports-b8bede3836f0093acd2ab3084970e49156786b09.tar.gz
ports-b8bede3836f0093acd2ab3084970e49156786b09.zip
databases/sqlite3: fix build on powerpc64le
Specify that powerpc64le is little-endian, sqlite thinks all powerpc* are big-endian.
Notes
Notes: svn path=/head/; revision=549969
Diffstat (limited to 'databases/sqlite3/Makefile')
-rw-r--r--databases/sqlite3/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/databases/sqlite3/Makefile b/databases/sqlite3/Makefile
index 0dfec10a4714..d31b927fd1bf 100644
--- a/databases/sqlite3/Makefile
+++ b/databases/sqlite3/Makefile
@@ -234,6 +234,7 @@ DQS_CPPFLAGS_OFF= -DSQLITE_DQS=0
# Platform Configuration
CPPFLAGS+= -DHAVE_ISNAN=1 -DHAVE_MALLOC_USABLE_SIZE=1 -DHAVE_GMTIME_R=1 -DHAVE_LOCALTIME_R=1 -DHAVE_USLEEP=1 -DHAVE_STRCHRNUL=1
+CFLAGS_powerpc64le= -DSQLITE_BYTEORDER=1234
post-configure:
@${ECHO_MSG} "===> CONFIGURE_ARGS=${CONFIGURE_ARGS}"