aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2017-03-15 14:45:30 +0000
committerMathieu Arnold <mat@FreeBSD.org>2017-03-15 14:45:30 +0000
commita28f0f7f7f7687e6ab6ebc4b3313f96232c00aa0 (patch)
treebaf6ab0b133f634d778359bdbf4c920166db5b76 /databases
parentc285e43283c14c5abf4dc12cfdf0793f4ca0d130 (diff)
downloadports-a28f0f7f7f7687e6ab6ebc4b3313f96232c00aa0.tar.gz
ports-a28f0f7f7f7687e6ab6ebc4b3313f96232c00aa0.zip
Remove all USE_OPENSSL occurrences.
Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=436247
Diffstat (limited to 'databases')
-rw-r--r--databases/galera/Makefile3
-rw-r--r--databases/libdrizzle-redux/Makefile3
-rw-r--r--databases/mongodb/Makefile2
-rw-r--r--databases/pgbouncer/Makefile3
-rw-r--r--databases/pgpool-II/Makefile10
-rw-r--r--databases/virtuoso/Makefile3
6 files changed, 7 insertions, 17 deletions
diff --git a/databases/galera/Makefile b/databases/galera/Makefile
index 55d36c07dc4e..26acd135d8df 100644
--- a/databases/galera/Makefile
+++ b/databases/galera/Makefile
@@ -18,12 +18,11 @@ BUILD_DEPENDS= checkmk:devel/check \
${PYTHON_PKGNAMEPREFIX}cloud_sptheme>=0:textproc/py-cloud_sptheme
LIB_DEPENDS= libboost_date_time.so:devel/boost-libs
-USES= execinfo python:build scons shebangfix
+USES= execinfo python:build scons shebangfix ssl
USE_CXXSTD= c++11
USE_GCC= yes
USE_LDCONFIG= yes
-USE_OPENSSL= yes
LDFLAGS+= -lboost_program_options -lboost_system
MAKE_ARGS+= --config=force
diff --git a/databases/libdrizzle-redux/Makefile b/databases/libdrizzle-redux/Makefile
index 6f0bace81620..edc0f73526d5 100644
--- a/databases/libdrizzle-redux/Makefile
+++ b/databases/libdrizzle-redux/Makefile
@@ -16,9 +16,8 @@ COMMENT= Client and protocol library for the Drizzle database
LICENSE= BSD2CLAUSE
GNU_CONFIGURE= yes
-USES= gmake libtool
+USES= gmake libtool ssl
USE_LDCONFIG= yes
-USE_OPENSSL= yes
CONFLICTS= libdrizzle-[0-9]*
diff --git a/databases/mongodb/Makefile b/databases/mongodb/Makefile
index c72ca66e9ee6..9b2883cf6775 100644
--- a/databases/mongodb/Makefile
+++ b/databases/mongodb/Makefile
@@ -45,7 +45,7 @@ PORTSCOUT= limitw:1,even
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MSSL}
-USE_OPENSSL= yes
+USES+= ssl
MAKE_ARGS+= --ssl
.endif
diff --git a/databases/pgbouncer/Makefile b/databases/pgbouncer/Makefile
index ca7215f2de5b..37c64fcae10c 100644
--- a/databases/pgbouncer/Makefile
+++ b/databases/pgbouncer/Makefile
@@ -24,8 +24,7 @@ GROUPS= pgbouncer
USE_RC_SUBR= pgbouncer
GNU_CONFIGURE= yes
-USES= gmake
-USE_OPENSSL= yes
+USES= gmake ssl
CONFIGURE_ARGS= --with-libevent=${LOCALBASE} --enable-evdns
CONFIGURE_ENV+= PTHREAD_LIBS="-lpthread"
diff --git a/databases/pgpool-II/Makefile b/databases/pgpool-II/Makefile
index 44b75fe4a026..275a8c2c3877 100644
--- a/databases/pgpool-II/Makefile
+++ b/databases/pgpool-II/Makefile
@@ -15,9 +15,8 @@ LICENSE= MIT
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-USES= gmake pgsql:9.2 libtool
+USES= gmake pgsql:9.2 libtool ssl
USE_LDCONFIG= yes
-USE_OPENSSL= yes
CONFIGURE_ARGS= --with-openssl
CONFLICTS= pgpool-3.* pgpool-II-22-* pgpool-II-23-* pgpool-II-23-*
@@ -28,15 +27,10 @@ PORTDOCS+= TODO
PORTDOCShtml= pgpool-en.html pgpool-ja.html pgpool.css
PORTDOCShtml+= tutorial-en.html tutorial-ja.html
-OPTIONS_DEFINE+= DOCS SSL
+OPTIONS_DEFINE+= DOCS
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MSSL}
-USE_OPENSSL= yes
-CONFIGURE_ARGS+=--with-openssl
-.endif
-
.if exists(${LOCALBASE}/include/postgresql/server/replication/walreceiver.h)
FUNCTIONS= pgpool-recovery pgpool-regclass pgpool-walrecrunning
PLIST_SUB= PGSQL9=""
diff --git a/databases/virtuoso/Makefile b/databases/virtuoso/Makefile
index faf6d21b20df..169fb5f703d7 100644
--- a/databases/virtuoso/Makefile
+++ b/databases/virtuoso/Makefile
@@ -27,9 +27,8 @@ BROKEN_sparc64= Does not compile: error: DV_INT_TAG_WORD undeclared
NOT_FOR_ARCHS= arm armv6 i386 mips powerpc
NOT_FOR_ARCHS_REASON= can only be built on 64bit platforms
-USES= execinfo gmake libtool readline uidfix
+USES= execinfo gmake libtool readline uidfix ssl
USE_AUTOTOOLS= autoheader aclocal
-USE_OPENSSL= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-readline\