aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2021-03-24 13:34:35 +0000
committerRene Ladan <rene@FreeBSD.org>2021-03-24 13:34:35 +0000
commitb217c7fc9cc4e56e26f88b17551499a17c4c6d24 (patch)
tree927d28feccb5a8860ed230fbec099ccb4255ada8 /databases
parent80fa663d16236be2c6d5165f92327ed60b6a4b42 (diff)
downloadports-b217c7fc9cc4e56e26f88b17551499a17c4c6d24.tar.gz
ports-b217c7fc9cc4e56e26f88b17551499a17c4c6d24.zip
Mark ports recursively depending on Python 2.7 for expiration on June 23.
For ports optionally dependending on Python 2.7, just mark those options as expired. Remove konquerer from the x11/kde-baseapps metaport and bump its PORTREVISION. Submitted by: rene Reviewed by: portmgr, adridg, ehaupt, lme, madpilot, pizzamig, se, sunpoet, yuri Approved by: portmgr Differential Revision: https://reviews.freebsd.org/D28665
Notes
Notes: svn path=/head/; revision=569118
Diffstat (limited to 'databases')
-rw-r--r--databases/couchdb2/Makefile3
-rw-r--r--databases/couchdb3/Makefile3
-rw-r--r--databases/kbibtex/Makefile7
-rw-r--r--databases/p5-AnyEvent-CouchDB/Makefile3
-rw-r--r--databases/pypy-gdbm/Makefile3
-rw-r--r--databases/pypy-sqlite3/Makefile3
6 files changed, 22 insertions, 0 deletions
diff --git a/databases/couchdb2/Makefile b/databases/couchdb2/Makefile
index 72a1349d978a..2871544cbe42 100644
--- a/databases/couchdb2/Makefile
+++ b/databases/couchdb2/Makefile
@@ -14,6 +14,9 @@ COMMENT= JSON document database with HTTP API and scalable multi-master sync
LICENSE= APACHE20 BSD3CLAUSE ISCL WTFPL OFL11
LICENSE_COMB= multi
+DEPRECATED= Uses EOL Python 2.7 via lang/spidermonkey185
+EXPIRATION_DATE=2021-06-23
+
BUILD_DEPENDS= rebar:devel/rebar \
erlang-runtime21>=21.3:lang/erlang-runtime21
LIB_DEPENDS= libicudata.so:devel/icu \
diff --git a/databases/couchdb3/Makefile b/databases/couchdb3/Makefile
index 85007e237ede..b773a3bce2d8 100644
--- a/databases/couchdb3/Makefile
+++ b/databases/couchdb3/Makefile
@@ -13,6 +13,9 @@ COMMENT= JSON document database with HTTP API and scalable multi-master sync
LICENSE= APACHE20 BSD3CLAUSE ISCL WTFPL OFL11
LICENSE_COMB= multi
+DEPRECATED= Uses EOL Python 2.7 via lang/spidermonkey60
+EXPIRATION_DATE=2021-06-23
+
BUILD_DEPENDS= rebar:devel/rebar \
erlang-runtime22>=22.0:lang/erlang-runtime22
LIB_DEPENDS= libicudata.so:devel/icu \
diff --git a/databases/kbibtex/Makefile b/databases/kbibtex/Makefile
index 25e915b82ff5..5863fa8ff067 100644
--- a/databases/kbibtex/Makefile
+++ b/databases/kbibtex/Makefile
@@ -36,4 +36,11 @@ WEBENGINE_USE= QT=webengine
WEBENGINE_USE_OFF= QT=webkit
WEBENGINE_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_Qt5WebEngineWidgets
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MWEBENGINE}
+DEPRECATED= Uses EOL Python 2.7 via www/qt5-webengine
+EXPIRATION_DATE=2021-06-23
+.endif
+
.include <bsd.port.mk>
diff --git a/databases/p5-AnyEvent-CouchDB/Makefile b/databases/p5-AnyEvent-CouchDB/Makefile
index 76259e10a7e1..9cead655f32b 100644
--- a/databases/p5-AnyEvent-CouchDB/Makefile
+++ b/databases/p5-AnyEvent-CouchDB/Makefile
@@ -13,6 +13,9 @@ COMMENT= Non-blocking CouchDB client based on jquery.couch.js
LICENSE= MIT
+DEPRECATED= Uses EOL Python 2.7 via databases/couchdb2
+EXPIRATION_DATE=2021-06-23
+
BUILD_DEPENDS= ${RUN_DEPENDS}
RUN_DEPENDS= couchdb2>=0.9.0:databases/couchdb2 \
p5-AnyEvent-HTTP>=2.11:www/p5-AnyEvent-HTTP \
diff --git a/databases/pypy-gdbm/Makefile b/databases/pypy-gdbm/Makefile
index 326c0a5f0e1c..1b35c6500f3e 100644
--- a/databases/pypy-gdbm/Makefile
+++ b/databases/pypy-gdbm/Makefile
@@ -10,6 +10,9 @@ COMMENT= PyPy bindings to the GNU dbm library
LICENSE= GPLv2+
+DEPRECATED= Uses EOL Python 2.7 via lang/pypy
+EXPIRATION_DATE=2021-06-23
+
LIB_DEPENDS= libgdbm.so:databases/gdbm
CFFI_NAME= ffi
diff --git a/databases/pypy-sqlite3/Makefile b/databases/pypy-sqlite3/Makefile
index 499ee0051131..f3387b873a38 100644
--- a/databases/pypy-sqlite3/Makefile
+++ b/databases/pypy-sqlite3/Makefile
@@ -7,6 +7,9 @@ CATEGORIES= databases python
MAINTAINER= python@FreeBSD.org
COMMENT= Standard PyPy binding to the SQLite3 library
+DEPRECATED= Uses EOL Python 2.7 via lang/pypy
+EXPIRATION_DATE=2021-06-23
+
LIB_DEPENDS= libsqlite3.so:databases/sqlite3
CFFI_NAME= _ffi