aboutsummaryrefslogtreecommitdiff
path: root/deskutils/gnome-shell-extension-dashtopanel/Makefile
diff options
context:
space:
mode:
authorAlexander Vereeken <Alexander88207@protonmail.com>2020-12-28 11:13:57 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-05-01 05:57:33 +0000
commita7c419f27af6cd9ca9107dd5a6bd895a3130bf1f (patch)
treec52475b19816fad246fd5c97d04b4ce5a76eaa39 /deskutils/gnome-shell-extension-dashtopanel/Makefile
parentb123c72083e5cdbe537c6ebe9b44569751131582 (diff)
downloadports-a7c419f27af6cd9ca9107dd5a6bd895a3130bf1f.tar.gz
ports-a7c419f27af6cd9ca9107dd5a6bd895a3130bf1f.zip
deskutils/gnome-shell-extension-dashtopanel: add new port
This extension moves the dash into the gnome main panel. https://github.com/home-sweet-gnome/dash-to-panel PR: 243771
Diffstat (limited to 'deskutils/gnome-shell-extension-dashtopanel/Makefile')
-rw-r--r--deskutils/gnome-shell-extension-dashtopanel/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/deskutils/gnome-shell-extension-dashtopanel/Makefile b/deskutils/gnome-shell-extension-dashtopanel/Makefile
new file mode 100644
index 000000000000..4be3161ea79c
--- /dev/null
+++ b/deskutils/gnome-shell-extension-dashtopanel/Makefile
@@ -0,0 +1,29 @@
+# Created by: Alexander Vereeken <Alexander88207@protonmail.com>
+
+PORTNAME= gnome-shell-extension-dashtopanel
+PORTVERSION= v40
+CATEGORIES= deskutils
+
+MAINTAINER= Alexander88207@protonmail.com
+COMMENT= Icon taskbar for the Gnome Shell
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= gsed:textproc/gsed \
+ git:devel/git \
+ gsettings-desktop-schemas>=0:devel/gsettings-desktop-schemas \
+ gettext>=0:devel/gettext
+
+BINARY_ALIAS= sed=gsed
+
+USES= gmake
+
+USE_GITHUB= yes
+GH_ACCOUNT= home-sweet-gnome
+GH_PROJECT= dash-to-panel
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/share/|${PREFIX}/share/|g' ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>