aboutsummaryrefslogtreecommitdiff
path: root/deskutils/orage
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2018-09-30 11:58:29 +0000
committerKoop Mast <kwm@FreeBSD.org>2018-09-30 11:58:29 +0000
commit951c1f5d1c7354f058f5919d858dbb0c174dc73e (patch)
tree6146e775343aaf339921799078894a48fef9aa15 /deskutils/orage
parentc9b47f0427d70ba42c2d53271f8b64b8e8096825 (diff)
downloadports-951c1f5d1c7354f058f5919d858dbb0c174dc73e.tar.gz
ports-951c1f5d1c7354f058f5919d858dbb0c174dc73e.zip
The FreeBSD GNOME team proudly presents GNOME 3.28 for FreeBSD.
The offical GNOME 3.28 release notes can be found at https://help.gnome.org/misc/release-notes/3.28/ Thanks to Antoine Brodin for running the exp-runs. PR: 229761
Notes
Notes: svn path=/head/; revision=480951
Diffstat (limited to 'deskutils/orage')
-rw-r--r--deskutils/orage/Makefile2
-rw-r--r--deskutils/orage/files/patch-src_ical-code.c79
2 files changed, 80 insertions, 1 deletions
diff --git a/deskutils/orage/Makefile b/deskutils/orage/Makefile
index cb6d855b12a5..8fa3656d34ba 100644
--- a/deskutils/orage/Makefile
+++ b/deskutils/orage/Makefile
@@ -3,7 +3,7 @@
PORTNAME= orage
PORTVERSION= 4.12.1
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= deskutils xfce
MASTER_SITES= XFCE/src/apps/${PORTNAME}/${PORTVERSION:R}/
DIST_SUBDIR= xfce4
diff --git a/deskutils/orage/files/patch-src_ical-code.c b/deskutils/orage/files/patch-src_ical-code.c
new file mode 100644
index 000000000000..88c043160166
--- /dev/null
+++ b/deskutils/orage/files/patch-src_ical-code.c
@@ -0,0 +1,79 @@
+Propposed patch from comment #3
+https://bugzilla.xfce.org/show_bug.cgi?id=13997
+
+From 58e4bb4d3b982876dec33d55003d591559439598 Mon Sep 17 00:00:00 2001
+From: Stefan Seyfried <seife+dev@b1-systems.com>
+Date: Sat, 3 Mar 2018 20:25:24 +0100
+Subject: [PATCH] fix build with libical version 3
+
+---
+ src/ical-code.c | 12 ++++++++++++
+ 1 file changed, 12 insertions(+)
+
+diff --git a/src/ical-code.c b/src/ical-code.c
+index d5831404..c40042c3 100644
+--- src/ical-code.c
++++ src/ical-code.c
+@@ -2579,7 +2579,9 @@ static struct icaltimetype count_first_alarm_time(xfical_period per
+ * when counting alarm time. */
+ if (rel == ICAL_RELATED_START) {
+ per.stime.is_date = 0;
++#if ICAL_MAJOR_VERSION < 3
+ per.stime.is_utc = 1;
++#endif
+ per.stime.is_daylight = 0;
+ per.stime.zone = utc_icaltimezone;
+ per.stime.hour = 0;
+@@ -2588,7 +2590,9 @@ static struct icaltimetype count_first_alarm_time(xfical_period per
+ }
+ else {
+ per.etime.is_date = 0;
++#if ICAL_MAJOR_VERSION < 3
+ per.etime.is_utc = 1;
++#endif
+ per.etime.is_daylight = 0;
+ per.etime.zone = utc_icaltimezone;
+ per.etime.hour = 0;
+@@ -2613,7 +2617,9 @@ static struct icaltimetype count_next_alarm_time(struct icaltimetype start_time
+ /* HACK: convert to UTC time so that we can use time arithmetic
+ * when counting alarm time. */
+ start_time.is_date = 0;
++#if ICAL_MAJOR_VERSION < 3
+ start_time.is_utc = 1;
++#endif
+ start_time.is_daylight = 0;
+ start_time.zone = utc_icaltimezone;
+ start_time.hour = 0;
+@@ -2768,7 +2774,9 @@ static alarm_struct *process_alarm_trigger(icalcomponent *c
+ */
+ if (icaltime_is_date(per.stime)) {
+ if (local_icaltimezone != utc_icaltimezone) {
++#if ICAL_MAJOR_VERSION < 3
+ next_alarm_time.is_utc = 0;
++#endif
+ next_alarm_time.is_daylight = 0;
+ next_alarm_time.zone = local_icaltimezone;
+ }
+@@ -2850,7 +2858,9 @@ orage_message(120, P_N "Alarm rec loop next_start:%s next_alarm:%s per.stime:%s"
+ */
+ if (icaltime_is_date(per.stime)) {
+ if (local_icaltimezone != utc_icaltimezone) {
++#if ICAL_MAJOR_VERSION < 3
+ next_alarm_time.is_utc = 0;
++#endif
+ next_alarm_time.is_daylight = 0;
+ next_alarm_time.zone = local_icaltimezone;
+ }
+@@ -2944,7 +2954,9 @@ orage_message(120, P_N "*****After loop Alarm %s %s", icaltime_as_ical_string(ne
+ */
+ if (icaltime_is_date(per.stime)) {
+ if (local_icaltimezone != utc_icaltimezone) {
++#if ICAL_MAJOR_VERSION < 3
+ next_alarm_time.is_utc = 0;
++#endif
+ next_alarm_time.is_daylight = 0;
+ next_alarm_time.zone = local_icaltimezone;
+ }
+--
+2.16.2
+