aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2011-03-03 10:15:19 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2011-03-03 10:15:19 +0000
commita46d7cb4bfc12f879124169583e5a42180526669 (patch)
tree997bc79b70439039ea07183d20ee20c2502a1b05 /deskutils
parent27b438f5edc45e0492f6ab0ede6bf52f5886b46f (diff)
downloadports-a46d7cb4bfc12f879124169583e5a42180526669.tar.gz
ports-a46d7cb4bfc12f879124169583e5a42180526669.zip
Add xfce4-tumbler
Tumbler, is thumbnail service implementing the thumbnail management D-BUS specification. WWW: http://git.xfce.org/apps/tumbler/
Notes
Notes: svn path=/head/; revision=270187
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/xfce4-tumbler/Makefile106
-rw-r--r--deskutils/xfce4-tumbler/distinfo2
-rw-r--r--deskutils/xfce4-tumbler/pkg-descr4
-rw-r--r--deskutils/xfce4-tumbler/pkg-plist122
5 files changed, 235 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index 7dfe6e9f72b8..112cae495348 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -297,6 +297,7 @@
SUBDIR += xfce4-notes-plugin
SUBDIR += xfce4-notification-daemon
SUBDIR += xfce4-notifyd
+ SUBDIR += xfce4-tumbler
SUBDIR += xfce4-volstatus-icon
SUBDIR += xfce4-xkb-plugin
SUBDIR += xmaddressbook
diff --git a/deskutils/xfce4-tumbler/Makefile b/deskutils/xfce4-tumbler/Makefile
new file mode 100644
index 000000000000..ff59418875ad
--- /dev/null
+++ b/deskutils/xfce4-tumbler/Makefile
@@ -0,0 +1,106 @@
+# New ports collection makefile for: tumbler
+# Date created: 2010-12-03
+# Whom: Olivier Duchateau <duchateau.olivier@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tumbler
+PORTVERSION= 0.1.6
+CATEGORIES= deskutils xfce
+MASTER_SITES= ${MASTER_SITE_XFCE}
+MASTER_SITE_SUBDIR= src/apps/${PORTNAME}/${PORTVERSION:R}
+PKGNAMEPREFIX= xfce4-
+DIST_SUBDIR= xfce4
+
+MAINTAINER= oliver@FreeBSD.org
+COMMENT= Thumbnail service for Xfce desktop
+
+LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png \
+ freetype.9:${PORTSDIR}/print/freetype2 \
+ dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_AUTOTOOLS= libtool
+USE_GNOME= glib20 gnomehack intltool intlhack pkgconfig
+USE_LDCONFIG= yes
+USE_XFCE= configenv
+
+CONFIGURE_ARGS= --enable-xdg-cache \
+ --disable-gtk-doc-html
+
+OPTIONS= NLS "Enable Native Language Support" on \
+ APIDOCS "Install api documentation" off \
+ PIXBUF "Enable gdk-pixbuf plugin thumbnailer" on \
+ FONTS "Enable fonts plugin thumbnailer" on \
+ JPEG "Enable JPEG and EXIF plugin thumbnailer" on \
+ FFMPEG "Enable FFMPEG plugin thumbnailer" off \
+ POPPLER "Enable PDF/PS plugin thumbnailer" on
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+CONFIGURE_ARGS+=--enable-nls
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.if defined(WITHOUT_APIDOCS)
+CONFIGURE_ARGS+=--without-html-dir
+PLIST_SUB+= APIDOCS="@comment "
+.else
+CONFIGURE_ARGS+=--with-html-dir=${PREFIX}/share/gtk-doc/html
+PLIST_SUB+= APIDOCS=""
+.endif
+
+.if !defined(WITHOUT_PIXBUF)
+USE_GNOME+= gdkpixbuf2
+CONFIGURE_ARGS+=--enable-pixbuf-thumbnailer
+PLIST_SUB+= PIXBUF=""
+.else
+CONFIGURE_ARGS+=--disable-pixbuf-thumbnailer
+PLIST_SUB+= PIXBUF="@comment "
+.endif
+
+.if !defined(WITHOUT_FONTS)
+CONFIGURE_ARGS+=--enable-font-thumbnailer
+PLIST_SUB+= FONTS=""
+.else
+CONFIGURE_ARGS+=--disable-font-thumbnailer
+PLIST_SUB+= FONTS="@comment "
+.endif
+
+.if !defined(WITHOUT_JPEG)
+LIB_DEPENDS+= jpeg.11:${PORTSDIR}/graphics/jpeg \
+ exif.12:${PORTSDIR}/graphics/exif
+CONFIGURE_ARGS+=--enable-jpeg-thumbnailer
+PLIST_SUB+= JPEG=""
+.else
+CONFIGURE_ARGS+=--disable-jpeg-thumbnailer
+PLIST_SUB+= JPEG="@comment "
+.endif
+
+.if !defined(WITHOUT_FFMPEG)
+LIB_DEPENDS+= ffmpegthumbnailer.4:${PORTSDIR}/multimedia/ffmpegthumbnailer
+CONFIGURE_ARGS+=--enable-ffmpeg-thumbnailer
+PLIST_SUB+= FFMPEG=""
+.else
+CONFIGURE_ARGS+=--disable-ffmpeg-thumbnailer
+PLIST_SUB+= FFMPEG="@comment "
+.endif
+
+.if !defined(WITHOUT_POPPLER)
+LIB_DEPENDS+= poppler-glib.5:${PORTSDIR}/graphics/poppler-gtk
+CONFIGURE_ARGS+=--enable-poppler-thumbnailer
+PLIST_SUB+= POPPLER=""
+.else
+CONFIGURE_ARGS+=--disable-poppler-thumbnailer
+PLIST_SUB+= POPPLER="@comment "
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/deskutils/xfce4-tumbler/distinfo b/deskutils/xfce4-tumbler/distinfo
new file mode 100644
index 000000000000..0b9a28fe45a7
--- /dev/null
+++ b/deskutils/xfce4-tumbler/distinfo
@@ -0,0 +1,2 @@
+SHA256 (xfce4/tumbler-0.1.6.tar.bz2) = aed9ed477026dab4b50ae12cc580edcae9f41bd567f3f9c85a453a74cd4ed4f6
+SIZE (xfce4/tumbler-0.1.6.tar.bz2) = 449394
diff --git a/deskutils/xfce4-tumbler/pkg-descr b/deskutils/xfce4-tumbler/pkg-descr
new file mode 100644
index 000000000000..7c9a3ae58a43
--- /dev/null
+++ b/deskutils/xfce4-tumbler/pkg-descr
@@ -0,0 +1,4 @@
+Tumbler, is thumbnail service implementing the thumbnail management D-BUS
+specification.
+
+WWW: http://git.xfce.org/apps/tumbler/
diff --git a/deskutils/xfce4-tumbler/pkg-plist b/deskutils/xfce4-tumbler/pkg-plist
new file mode 100644
index 000000000000..d2222973c60f
--- /dev/null
+++ b/deskutils/xfce4-tumbler/pkg-plist
@@ -0,0 +1,122 @@
+include/tumbler-1/tumbler/tumbler-abstract-thumbnailer.h
+include/tumbler-1/tumbler/tumbler-cache-plugin.h
+include/tumbler-1/tumbler/tumbler-cache.h
+include/tumbler-1/tumbler/tumbler-config.h
+include/tumbler-1/tumbler/tumbler-enum-types.h
+include/tumbler-1/tumbler/tumbler-error.h
+include/tumbler-1/tumbler/tumbler-file-info.h
+include/tumbler-1/tumbler/tumbler-glib-extensions.h
+include/tumbler-1/tumbler/tumbler-marshal.h
+include/tumbler-1/tumbler/tumbler-provider-factory.h
+include/tumbler-1/tumbler/tumbler-provider-plugin.h
+include/tumbler-1/tumbler/tumbler-thumbnail-flavor.h
+include/tumbler-1/tumbler/tumbler-thumbnail.h
+include/tumbler-1/tumbler/tumbler-thumbnailer-provider.h
+include/tumbler-1/tumbler/tumbler-thumbnailer.h
+include/tumbler-1/tumbler/tumbler-util.h
+include/tumbler-1/tumbler/tumbler.h
+lib/libtumbler-1.a
+lib/libtumbler-1.la
+lib/libtumbler-1.so
+lib/libtumbler-1.so.0
+lib/tumbler-1/plugins/cache/tumbler-cache-plugin.so
+lib/tumbler-1/plugins/cache/tumbler-xdg-cache.a
+lib/tumbler-1/plugins/cache/tumbler-xdg-cache.la
+lib/tumbler-1/plugins/cache/tumbler-xdg-cache.so
+%%FFMPEG%%lib/tumbler-1/plugins/tumbler-ffmpeg-thumbnailer.a
+%%FFMPEG%%lib/tumbler-1/plugins/tumbler-ffmpeg-thumbnailer.la
+%%FFMPEG%%lib/tumbler-1/plugins/tumbler-ffmpeg-thumbnailer.so
+%%FONTS%%lib/tumbler-1/plugins/tumbler-font-thumbnailer.a
+%%FONTS%%lib/tumbler-1/plugins/tumbler-font-thumbnailer.la
+%%FONTS%%lib/tumbler-1/plugins/tumbler-font-thumbnailer.so
+%%JPEG%%lib/tumbler-1/plugins/tumbler-jpeg-thumbnailer.a
+%%JPEG%%lib/tumbler-1/plugins/tumbler-jpeg-thumbnailer.la
+%%JPEG%%lib/tumbler-1/plugins/tumbler-jpeg-thumbnailer.so
+%%PIXBUF%%lib/tumbler-1/plugins/tumbler-pixbuf-thumbnailer.a
+%%PIXBUF%%lib/tumbler-1/plugins/tumbler-pixbuf-thumbnailer.la
+%%PIXBUF%%lib/tumbler-1/plugins/tumbler-pixbuf-thumbnailer.so
+%%POPPLER%%lib/tumbler-1/plugins/tumbler-poppler-thumbnailer.a
+%%POPPLER%%lib/tumbler-1/plugins/tumbler-poppler-thumbnailer.la
+%%POPPLER%%lib/tumbler-1/plugins/tumbler-poppler-thumbnailer.so
+lib/tumbler-1/tumblerd
+libdata/pkgconfig/tumbler-1.pc
+share/dbus-1/services/org.xfce.Tumbler.Cache1.service
+share/dbus-1/services/org.xfce.Tumbler.Manager1.service
+share/dbus-1/services/org.xfce.Tumbler.Thumbnailer1.service
+%%APIDOCS%%share/gtk-doc/html/tumbler/TumblerAbstractThumbnailer.html
+%%APIDOCS%%share/gtk-doc/html/tumbler/TumblerCache.html
+%%APIDOCS%%share/gtk-doc/html/tumbler/TumblerThumbnail.html
+%%APIDOCS%%share/gtk-doc/html/tumbler/TumblerThumbnailerProvider.html
+%%APIDOCS%%share/gtk-doc/html/tumbler/api-index-full.html
+%%APIDOCS%%share/gtk-doc/html/tumbler/extension-api.html
+%%APIDOCS%%share/gtk-doc/html/tumbler/extension-tutorial.html
+%%APIDOCS%%share/gtk-doc/html/tumbler/home.png
+%%APIDOCS%%share/gtk-doc/html/tumbler/index.html
+%%APIDOCS%%share/gtk-doc/html/tumbler/index.sgml
+%%APIDOCS%%share/gtk-doc/html/tumbler/left.png
+%%APIDOCS%%share/gtk-doc/html/tumbler/miscellaneous.html
+%%APIDOCS%%share/gtk-doc/html/tumbler/object-tree.html
+%%APIDOCS%%share/gtk-doc/html/tumbler/pt01.html
+%%APIDOCS%%share/gtk-doc/html/tumbler/right.png
+%%APIDOCS%%share/gtk-doc/html/tumbler/style.css
+%%APIDOCS%%share/gtk-doc/html/tumbler/thumbnails.html
+%%APIDOCS%%share/gtk-doc/html/tumbler/tumbler-Error-Domain-and-Types.html
+%%APIDOCS%%share/gtk-doc/html/tumbler/tumbler-Various-Enumeration-Types.html
+%%APIDOCS%%share/gtk-doc/html/tumbler/tumbler-Version-Information-and-Compatibility-Checks.html
+%%APIDOCS%%share/gtk-doc/html/tumbler/tumbler-tumbler-file-info.html
+%%APIDOCS%%share/gtk-doc/html/tumbler/tumbler-tumbler-provider-factory.html
+%%APIDOCS%%share/gtk-doc/html/tumbler/tumbler-tumbler-provider-plugin.html
+%%APIDOCS%%share/gtk-doc/html/tumbler/tumbler.devhelp
+%%APIDOCS%%share/gtk-doc/html/tumbler/tumbler.devhelp2
+%%APIDOCS%%share/gtk-doc/html/tumbler/up.png
+%%NLS%%share/locale/ast/LC_MESSAGES/tumbler.mo
+%%NLS%%share/locale/bn/LC_MESSAGES/tumbler.mo
+%%NLS%%share/locale/ca/LC_MESSAGES/tumbler.mo
+%%NLS%%share/locale/da/LC_MESSAGES/tumbler.mo
+%%NLS%%share/locale/de/LC_MESSAGES/tumbler.mo
+%%NLS%%share/locale/en_GB/LC_MESSAGES/tumbler.mo
+%%NLS%%share/locale/eu/LC_MESSAGES/tumbler.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/tumbler.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/tumbler.mo
+%%NLS%%share/locale/gl/LC_MESSAGES/tumbler.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/tumbler.mo
+%%NLS%%share/locale/id/LC_MESSAGES/tumbler.mo
+%%NLS%%share/locale/it/LC_MESSAGES/tumbler.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/tumbler.mo
+%%NLS%%share/locale/kk/LC_MESSAGES/tumbler.mo
+%%NLS%%share/locale/lv/LC_MESSAGES/tumbler.mo
+%%NLS%%share/locale/pa/LC_MESSAGES/tumbler.mo
+%%NLS%%share/locale/pt/LC_MESSAGES/tumbler.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/tumbler.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/tumbler.mo
+%%NLS%%share/locale/si/LC_MESSAGES/tumbler.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/tumbler.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/tumbler.mo
+%%NLS%%share/locale/ug/LC_MESSAGES/tumbler.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/tumbler.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/tumbler.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/tumbler.mo
+%%NLS%%share/locale/ar/LC_MESSAGES/tumbler.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/tumbler.mo
+%%NLS%%share/locale/el/LC_MESSAGES/tumbler.mo
+%%NLS%%share/locale/he/LC_MESSAGES/tumbler.mo
+%%NLS%%share/locale/nb/LC_MESSAGES/tumbler.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/tumbler.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/tumbler.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/tumbler.mo
+%%NLS%%@dirrmtry share/locale/ug/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/ug
+%%NLS%%@dirrmtry share/locale/si/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/si
+%%NLS%%@dirrmtry share/locale/kk/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/kk
+%%NLS%%@dirrmtry share/locale/ast/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/ast
+%%APIDOCS%%@dirrm share/gtk-doc/html/tumbler
+%%APIDOCS%%@dirrmtry share/gtk-doc/html
+%%APIDOCS%%@dirrmtry share/gtk-doc
+@dirrm lib/tumbler-1/plugins/cache
+@dirrm lib/tumbler-1/plugins
+@dirrm lib/tumbler-1
+@dirrm include/tumbler-1/tumbler
+@dirrm include/tumbler-1