aboutsummaryrefslogtreecommitdiff
path: root/devel/allegro/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-03-30 03:04:33 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-03-30 03:04:33 +0000
commitf89a6b459429792c4da8df43a2448f7a1313ea0f (patch)
tree51e5a0614c19b70096a9ce5bb833ee73b3c736e3 /devel/allegro/Makefile
parent9fdbea032b7fb62be43204e588d8001509e9def9 (diff)
downloadports-f89a6b459429792c4da8df43a2448f7a1313ea0f.tar.gz
ports-f89a6b459429792c4da8df43a2448f7a1313ea0f.zip
devel/allegro: updating to 4.1.4 (devel version).
This PR updates allegro to the last 4.1.4, fixes allegro-config, and adds samples. PR: ports/45344 Submitted by: Thierry Thomas <thierry@pompo.net>
Notes
Notes: svn path=/head/; revision=77725
Diffstat (limited to 'devel/allegro/Makefile')
-rw-r--r--devel/allegro/Makefile16
1 files changed, 13 insertions, 3 deletions
diff --git a/devel/allegro/Makefile b/devel/allegro/Makefile
index 4f5fc605c55d..4e2d632078f9 100644
--- a/devel/allegro/Makefile
+++ b/devel/allegro/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= allegro
-PORTVERSION= 4.0.2
-PORTREVISION= 2
+PORTVERSION= 4.1.4
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= alleg
@@ -27,8 +26,9 @@ CONFIGURE_ARGS= --enable-vga=no
MAKEFILE= makefile
INSTALLS_SHLIB= yes
-SHLIB_VER= 4
+SHLIB_VER= 41
PLIST_SUB= SHLIB_VER="${SHLIB_VER}"
+DEMO= demo.c demo.dat demo.h music.txt ../readme.txt
.include <bsd.port.pre.mk>
@@ -49,6 +49,10 @@ INSTALL_TARGET= full-install install-man install-info
PLIST_SUB+= FULL=""
.endif
+.if !defined(NOPORTDOCS)
+PLIST_SUB+= EXAMPLESDIR="share/examples/${PORTNAME}"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e \
's|${PORTVERSION}|${SHLIB_VER}|g' ${WRKSRC}/makefile.ver
@@ -59,6 +63,12 @@ post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/docs/html/*.html ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/docs/html/*.css ${DOCSDIR}
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/demo/demo ${EXAMPLESDIR}
+.for FILE in ${DEMO}
+ ${INSTALL_DATA} ${WRKSRC}/demo/${FILE} ${EXAMPLESDIR}
+.endfor
.endif
.include "Makefile.man"