aboutsummaryrefslogtreecommitdiff
path: root/devel/avr-libc
diff options
context:
space:
mode:
authorJoerg Wunsch <joerg@FreeBSD.org>2005-04-11 08:58:31 +0000
committerJoerg Wunsch <joerg@FreeBSD.org>2005-04-11 08:58:31 +0000
commit02cccbb75f7b4a82fe7901a6dc0ad3f51eb10d79 (patch)
tree0b651a75e6af4439627f3cabfcbed6e28bf11440 /devel/avr-libc
parentf93aa4f2311e5b164e7704a47ce36fb8d1ed661d (diff)
downloadports-02cccbb75f7b4a82fe7901a6dc0ad3f51eb10d79.tar.gz
ports-02cccbb75f7b4a82fe7901a6dc0ad3f51eb10d79.zip
After Kris pointed out to me that I'm completely on the wrong track
wrt. the names of the installed doxygen temp files, do it right now, and delete anything from the target directory doxygen did install there which doesn't match our expectation (as take from PLIST_DOC). This appears to be the only sane way until doxygen reverts itself back to normal behaviour, and doesn't install any temporary files.
Notes
Notes: svn path=/head/; revision=133009
Diffstat (limited to 'devel/avr-libc')
-rw-r--r--devel/avr-libc/Makefile24
1 files changed, 21 insertions, 3 deletions
diff --git a/devel/avr-libc/Makefile b/devel/avr-libc/Makefile
index 6f2ce441f9bd..152b784c2223 100644
--- a/devel/avr-libc/Makefile
+++ b/devel/avr-libc/Makefile
@@ -7,7 +7,7 @@
PORTNAME= avr-libc
PORTVERSION= 1.2.3
-PORTREVISION= 3
+PORTREVISION= 4
PORTEPOCH= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
@@ -52,6 +52,12 @@ DEMOFILES= Makefile demo.c
DEMOFILES+= demo.bin demo.hex demo.pdf demo.srec
.endif
+.if defined(MAINTAINER_DEBUG)
+ECHO_EXTRA_RM= ${ECHO_CMD} "Removing " $${to_be_rm_ed} "..."
+.else
+ECHO_EXTRA_RM= ${ECHO_CMD} "Removing extraneous man page files..."
+.endif
+
do-build:
(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ./domake MAKE=${GMAKE})
@@ -83,8 +89,20 @@ do-install:
${PREFIX}/share/doc/avr-libc/examples/twitest; \
done
.if !defined(NOPORTDOCS)
- ${RM} -f ${PREFIX}/share/doc/avr-libc/man/man3/_tmp*
- ${RM} -f ${PREFIX}/share/doc/avr-libc/man/man3/_work*
+ @( \
+ tmpname=$${TMPDIR:-/tmp}/avr-libc-inst.$$$$ ; \
+ cd ${PREFIX}/share/doc/avr-libc/man/man3 ; \
+ ${GREP} '^share/doc/.*man3/' ${PLIST_DOC} | \
+ ${SED} -e 's,.*/,,' | \
+ ${SORT} > $${tmpname}.1 ; \
+ ${LS} -1 | \
+ ${SED} -e 's,.*/,,' | \
+ ${SORT} > $${tmpname}.2 ; \
+ to_be_rm_ed=$$(${COMM} -13 $${tmpname}.1 $${tmpname}.2) ; \
+ ${RM} -f $${tmpname}.1 $${tmpname}.2 ; \
+ ${ECHO_EXTRA_RM} ; \
+ ${RM} -f $${to_be_rm_ed} \
+ )
.endif
.include <bsd.port.mk>