aboutsummaryrefslogtreecommitdiff
path: root/devel/dconf
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2015-08-05 19:13:24 +0000
committerKoop Mast <kwm@FreeBSD.org>2015-08-05 19:13:24 +0000
commitd129587b5d568b0ff5300386f1e1b706c349f38e (patch)
treee398c7b6ea5203fd3953999e6dd9d6c83c9ec931 /devel/dconf
parentc13de12f75988e599e389d9c77ed92db8d927185 (diff)
downloadports-d129587b5d568b0ff5300386f1e1b706c349f38e.tar.gz
ports-d129587b5d568b0ff5300386f1e1b706c349f38e.zip
The FreeBSD GNOME team proudly presents GNOME 3.16 for FreeBSD.
The offical GNOME 3.16 release notes can be found at https://help.gnome.org/misc/release-notes/3.16/ Upgrade instructions for port users: Delete the old tracker package with: # pkg delete -f tracker And user port upgrade tool of choice to upgrade. Thanks to Antoine Brodin for running the exp-runs. This release was made possible by the following people: Gustau Perez Ting-Wei_Lan PR: 201980
Notes
Notes: svn path=/head/; revision=393607
Diffstat (limited to 'devel/dconf')
-rw-r--r--devel/dconf/Makefile28
-rw-r--r--devel/dconf/distinfo4
-rw-r--r--devel/dconf/files/patch-editor_Makefile.in20
-rw-r--r--devel/dconf/pkg-plist82
4 files changed, 18 insertions, 116 deletions
diff --git a/devel/dconf/Makefile b/devel/dconf/Makefile
index 0a324205240d..a56960b1eb41 100644
--- a/devel/dconf/Makefile
+++ b/devel/dconf/Makefile
@@ -1,10 +1,8 @@
# Created by: Koop Mast <kwm@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/trunk/devel/dconf/Makefile 20031 2014-11-02 21:47:55Z kwm $
-PORTNAME?= dconf
-PORTVERSION= 0.22.0
-PORTREVISION?= 1
+PORTNAME= dconf
+PORTVERSION= 0.24.0
CATEGORIES= devel gnome
MASTER_SITES= GNOME
DISTNAME= dconf-${PORTVERSION}
@@ -18,23 +16,12 @@ BUILD_DEPENDS= vala>=0.18.1:${PORTSDIR}/lang/vala \
LIB_DEPENDS= libdbus-1.so:${PORTSDIR}/devel/dbus
USES= gettext gmake pathfix pkgconfig tar:xz
-USE_GNOME= glib20 intltool
+USE_GNOME= glib20
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-DCONF_SLAVE?= no
-
-.if ${DCONF_SLAVE} == editor
-USE_GNOME+= gtk30
-INSTALLS_ICONS= yes
-GLIB_SCHEMAS= ca.desrt.dconf-editor.gschema.xml
-LIB_DEPENDS+= libdconf.so:${PORTSDIR}/devel/dconf
-.else
-CONFIGURE_ARGS+=--disable-editor
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|/etc/|${PREFIX}/etc/|g' \
${WRKSRC}/engine/dconf-engine.c \
@@ -42,21 +29,14 @@ post-patch:
${WRKSRC}/engine/dconf-engine-source-system.c \
${WRKSRC}/bin/dconf-update.c \
${WRKSRC}/tests/engine.c
- @${REINPLACE_CMD} -e 's|/usr/local/|${LOCALBASE}/|g' \
- ${WRKSRC}/editor/dconf-model.c
- @${REINPLACE_CMD} -e 's|/usr/share|${LOCALBASE}/share|g' \
- ${WRKSRC}/editor/dconf-model.vala
@${REINPLACE_CMD} -e 's|-Wno-unused-but-set-variable||g' \
${WRKSRC}/bin/Makefile.in \
- ${WRKSRC}/client/Makefile.in \
- ${WRKSRC}/editor/Makefile.in
+ ${WRKSRC}/client/Makefile.in
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
${WRKSRC}/docs/Makefile.in
-.if ${DCONF_SLAVE} == no
post-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/etc/dconf/db
@${MKDIR} ${STAGEDIR}${PREFIX}/etc/dconf/profile
-.endif
.include <bsd.port.mk>
diff --git a/devel/dconf/distinfo b/devel/dconf/distinfo
index 40bd5627a34e..1174509a313a 100644
--- a/devel/dconf/distinfo
+++ b/devel/dconf/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gnome3/dconf-0.22.0.tar.xz) = 0a277cb0c3f09e77d9413c5a9b3577fc2b5d6e941b59b44940392e024a224b8e
-SIZE (gnome3/dconf-0.22.0.tar.xz) = 393260
+SHA256 (gnome3/dconf-0.24.0.tar.xz) = 4373e0ced1f4d7d68d518038796c073696280e22957babb29feb0267c630fec2
+SIZE (gnome3/dconf-0.24.0.tar.xz) = 218512
diff --git a/devel/dconf/files/patch-editor_Makefile.in b/devel/dconf/files/patch-editor_Makefile.in
deleted file mode 100644
index f9935dd33e93..000000000000
--- a/devel/dconf/files/patch-editor_Makefile.in
+++ /dev/null
@@ -1,20 +0,0 @@
---- editor/Makefile.orig.in 2013-03-26 19:20:12.623348896 +0000
-+++ editor/Makefile.in 2013-03-26 19:21:40.077341977 +0000
-@@ -72,7 +72,7 @@
- dconf_editor-dconf-view.$(OBJEXT)
- dconf_editor_OBJECTS = $(am_dconf_editor_OBJECTS)
- am__DEPENDENCIES_1 =
--dconf_editor_DEPENDENCIES = ../client/libdconf.so.1 \
-+dconf_editor_DEPENDENCIES = -ldconf \
- $(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1) \
- $(am__DEPENDENCIES_1)
- dconf_editor_LINK = $(CCLD) $(dconf_editor_CFLAGS) $(CFLAGS) \
-@@ -297,7 +297,7 @@
- INCLUDES = -I$(top_srcdir) -I$(top_srcdir)/client
- dconf_editor_VALAFLAGS = --vapidir ../client --pkg gtk+-3.0 --pkg gmodule-2.0 --pkg libxml-2.0 --pkg dconf
- dconf_editor_LDADD = \
-- ../client/libdconf.so.1 \
-+ -ldconf \
- $(gtk_LIBS) \
- $(gee_LIBS) \
- $(gmodule_LIBS) \
diff --git a/devel/dconf/pkg-plist b/devel/dconf/pkg-plist
index aa35523310f7..532d45651c05 100644
--- a/devel/dconf/pkg-plist
+++ b/devel/dconf/pkg-plist
@@ -1,38 +1,35 @@
bin/dconf
+include/dconf-dbus-1/dconf-dbus-1.h
include/dconf/client/dconf-client.h
include/dconf/common/dconf-changeset.h
include/dconf/common/dconf-error.h
-include/dconf-dbus-1/dconf-dbus-1.h
include/dconf/common/dconf-paths.h
include/dconf/dconf.h
lib/gio/modules/libdconfsettings.so
-lib/libdconf.so
-lib/libdconf.so.1
-lib/libdconf.so.1.0.0
lib/libdconf-dbus-1.so
lib/libdconf-dbus-1.so.0
lib/libdconf-dbus-1.so.0.0.0
-libdata/pkgconfig/dconf.pc
+lib/libdconf.so
+lib/libdconf.so.1
+lib/libdconf.so.1.0.0
libdata/pkgconfig/dconf-dbus-1.pc
+libdata/pkgconfig/dconf.pc
libexec/dconf-service
-man/man1/dconf-editor.1.gz
man/man1/dconf-service.1.gz
man/man1/dconf.1.gz
man/man7/dconf.7.gz
share/bash-completion/completions/dconf
share/dbus-1/services/ca.desrt.dconf.service
+share/gtk-doc/html/dconf/DConfClient.html
+share/gtk-doc/html/dconf/annotation-glossary.html
+share/gtk-doc/html/dconf/api-index-full.html
+share/gtk-doc/html/dconf/ch01.html
share/gtk-doc/html/dconf/dconf-DConfChangeset.html
share/gtk-doc/html/dconf/dconf-DConfError.html
share/gtk-doc/html/dconf/dconf-dconf-Paths.html
-share/gtk-doc/html/dconf/dconf-editor.html
share/gtk-doc/html/dconf/dconf-overview.html
share/gtk-doc/html/dconf/dconf-service.html
share/gtk-doc/html/dconf/dconf-tool.html
-share/gtk-doc/html/dconf/programs.html
-share/gtk-doc/html/dconf/DConfClient.html
-share/gtk-doc/html/dconf/annotation-glossary.html
-share/gtk-doc/html/dconf/api-index-full.html
-share/gtk-doc/html/dconf/ch01.html
share/gtk-doc/html/dconf/dconf.devhelp2
share/gtk-doc/html/dconf/home.png
share/gtk-doc/html/dconf/index.html
@@ -40,70 +37,15 @@ share/gtk-doc/html/dconf/index.sgml
share/gtk-doc/html/dconf/left-insensitive.png
share/gtk-doc/html/dconf/left.png
share/gtk-doc/html/dconf/object-tree.html
+share/gtk-doc/html/dconf/programs.html
share/gtk-doc/html/dconf/right-insensitive.png
share/gtk-doc/html/dconf/right.png
share/gtk-doc/html/dconf/style.css
share/gtk-doc/html/dconf/up-insensitive.png
share/gtk-doc/html/dconf/up.png
-share/locale/an/LC_MESSAGES/dconf.mo
-share/locale/ar/LC_MESSAGES/dconf.mo
-share/locale/as/LC_MESSAGES/dconf.mo
-share/locale/be/LC_MESSAGES/dconf.mo
-share/locale/bg/LC_MESSAGES/dconf.mo
-share/locale/bn_IN/LC_MESSAGES/dconf.mo
-share/locale/ca/LC_MESSAGES/dconf.mo
-share/locale/ca@valencia/LC_MESSAGES/dconf.mo
-share/locale/cs/LC_MESSAGES/dconf.mo
-share/locale/da/LC_MESSAGES/dconf.mo
-share/locale/de/LC_MESSAGES/dconf.mo
-share/locale/el/LC_MESSAGES/dconf.mo
-share/locale/en_GB/LC_MESSAGES/dconf.mo
-share/locale/eo/LC_MESSAGES/dconf.mo
-share/locale/es/LC_MESSAGES/dconf.mo
-share/locale/et/LC_MESSAGES/dconf.mo
-share/locale/eu/LC_MESSAGES/dconf.mo
-share/locale/fa/LC_MESSAGES/dconf.mo
-share/locale/fi/LC_MESSAGES/dconf.mo
-share/locale/fr/LC_MESSAGES/dconf.mo
-share/locale/fur/LC_MESSAGES/dconf.mo
-share/locale/gl/LC_MESSAGES/dconf.mo
-share/locale/he/LC_MESSAGES/dconf.mo
-share/locale/hi/LC_MESSAGES/dconf.mo
-share/locale/hu/LC_MESSAGES/dconf.mo
-share/locale/id/LC_MESSAGES/dconf.mo
-share/locale/it/LC_MESSAGES/dconf.mo
-share/locale/ja/LC_MESSAGES/dconf.mo
-share/locale/ko/LC_MESSAGES/dconf.mo
-share/locale/lt/LC_MESSAGES/dconf.mo
-share/locale/lv/LC_MESSAGES/dconf.mo
-share/locale/ml/LC_MESSAGES/dconf.mo
-share/locale/mr/LC_MESSAGES/dconf.mo
-share/locale/nb/LC_MESSAGES/dconf.mo
-share/locale/nl/LC_MESSAGES/dconf.mo
-share/locale/pa/LC_MESSAGES/dconf.mo
-share/locale/pl/LC_MESSAGES/dconf.mo
-share/locale/pt/LC_MESSAGES/dconf.mo
-share/locale/pt_BR/LC_MESSAGES/dconf.mo
-share/locale/ru/LC_MESSAGES/dconf.mo
-share/locale/sk/LC_MESSAGES/dconf.mo
-share/locale/sl/LC_MESSAGES/dconf.mo
-share/locale/sr/LC_MESSAGES/dconf.mo
-share/locale/sr@latin/LC_MESSAGES/dconf.mo
-share/locale/sv/LC_MESSAGES/dconf.mo
-share/locale/ta/LC_MESSAGES/dconf.mo
-share/locale/te/LC_MESSAGES/dconf.mo
-share/locale/tg/LC_MESSAGES/dconf.mo
-share/locale/th/LC_MESSAGES/dconf.mo
-share/locale/tr/LC_MESSAGES/dconf.mo
-share/locale/ug/LC_MESSAGES/dconf.mo
-share/locale/uk/LC_MESSAGES/dconf.mo
-share/locale/vi/LC_MESSAGES/dconf.mo
-share/locale/zh_CN/LC_MESSAGES/dconf.mo
-share/locale/zh_HK/LC_MESSAGES/dconf.mo
-share/locale/zh_TW/LC_MESSAGES/dconf.mo
share/vala/vapi/dconf.deps
share/vala/vapi/dconf.vapi
-@dir etc/dconf/db
-@dir etc/dconf/profile
+@dir %%ETCDIR%%/db
+@dir %%ETCDIR%%/profile
@exec %D/bin/gio-querymodules %D/lib/gio/modules 2>/dev/null || /usr/bin/true
@unexec %D/bin/gio-querymodules %D/lib/gio/modules 2>/dev/null || /usr/bin/true