aboutsummaryrefslogtreecommitdiff
path: root/devel/double-conversion/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-02-16 23:30:01 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-02-16 23:30:01 +0000
commit4c77ad9ee9f8bea471345a97f013aa7178bbbc99 (patch)
tree32ecf36fe35896e3df8059511f2f6316fd57ef24 /devel/double-conversion/Makefile
parentcb7116509931b4bd235b8e843b43afcb861e25ef (diff)
downloadports-4c77ad9ee9f8bea471345a97f013aa7178bbbc99.tar.gz
ports-4c77ad9ee9f8bea471345a97f013aa7178bbbc99.zip
Move: devel/libdouble-conversion -> devel/double-conversion
While in devel/double-conversion, order USExx clauses, and replace CMAKE_POSITION_INDEPENDENT_CODE with BUILD_SHARED_LIBS since shared libs should be a default Update and bump databases/clickhouse Approved by: portmgr blanket
Notes
Notes: svn path=/head/; revision=493133
Diffstat (limited to 'devel/double-conversion/Makefile')
-rw-r--r--devel/double-conversion/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/devel/double-conversion/Makefile b/devel/double-conversion/Makefile
new file mode 100644
index 000000000000..d29d2a89c8ec
--- /dev/null
+++ b/devel/double-conversion/Makefile
@@ -0,0 +1,24 @@
+# Created by: Waitman Gobble <waitman@waitman.net>
+# $FreeBSD$
+
+PORTNAME= double-conversion
+PORTVERSION= 3.0.0
+DISTVERSIONPREFIX= v
+CATEGORIES= devel
+
+MAINTAINER= waitman@waitman.net
+COMMENT= Binary-decimal and decimal-binary routines for IEEE doubles
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+#BROKEN_aarch64= Fails to build: Target architecture was not detected as supported by Double-Conversion
+
+USES= cmake
+USE_GITHUB= yes
+GH_ACCOUNT= google
+USE_LDCONFIG= yes
+
+CMAKE_ON= BUILD_SHARED_LIBS
+
+.include <bsd.port.mk>