aboutsummaryrefslogtreecommitdiff
path: root/devel/gdb
diff options
context:
space:
mode:
authorLuca Pizzamiglio <pizzamig@FreeBSD.org>2021-07-03 09:54:51 +0000
committerLuca Pizzamiglio <pizzamig@FreeBSD.org>2021-07-03 09:54:51 +0000
commit65af5b9da1535eba81a41c88e386aa1729ceb60c (patch)
tree1c97ca23689449c475a8d6e5a515482d009d2284 /devel/gdb
parentdf915285f58675744659c3df6652a0d2c9c4712c (diff)
downloadports-65af5b9da1535eba81a41c88e386aa1729ceb60c.tar.gz
ports-65af5b9da1535eba81a41c88e386aa1729ceb60c.zip
devel/gdb: Add a hack to fix the kill storm bug
While here, fix the debug install avoid stripping gdb Bump portrevision PR: 256838 Reported by: arrowd@FreeBSD.org Co-Author: arrowd@FreeBSD.org
Diffstat (limited to 'devel/gdb')
-rw-r--r--devel/gdb/Makefile3
-rw-r--r--devel/gdb/files/patch-gdb_inflow.c14
2 files changed, 16 insertions, 1 deletions
diff --git a/devel/gdb/Makefile b/devel/gdb/Makefile
index 308c44bd9740..b2afab9118ad 100644
--- a/devel/gdb/Makefile
+++ b/devel/gdb/Makefile
@@ -2,7 +2,7 @@
PORTNAME= gdb
DISTVERSION= 10.2
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= GNU
@@ -68,6 +68,7 @@ OPTIONS_SUB= yes
BUNDLED_READLINE_CONFIGURE_OFF= --with-system-readline
DEBUG_CFLAGS= -g
+DEBUG_VARS= STRIP=
GUILE_CONFIGURE_WITH= guile
GUILE_LIB_DEPENDS= libguile-2.2.so:lang/guile2
NLS_USES= gettext-runtime
diff --git a/devel/gdb/files/patch-gdb_inflow.c b/devel/gdb/files/patch-gdb_inflow.c
new file mode 100644
index 000000000000..ffac898e0d85
--- /dev/null
+++ b/devel/gdb/files/patch-gdb_inflow.c
@@ -0,0 +1,14 @@
+--- gdb/inflow.c.orig 2021-07-03 10:52:57.144161000 +0200
++++ gdb/inflow.c 2021-07-03 10:55:06.776399000 +0200
+@@ -881,7 +881,10 @@
+ pass_signal (int signo)
+ {
+ #ifndef _WIN32
+- kill (inferior_ptid.pid (), SIGINT);
++ if (inferior_ptid.pid () )
++ kill (inferior_ptid.pid (), SIGINT);
++ else
++ kill (current_inferior ()->pid, SIGINT);
+ #endif
+ }
+