aboutsummaryrefslogtreecommitdiff
path: root/devel/ice/files/patch-cpp-test-Ice-objects-Makefile
diff options
context:
space:
mode:
authorMichael Gmelin <grembo@FreeBSD.org>2016-04-06 13:08:51 +0000
committerMichael Gmelin <grembo@FreeBSD.org>2016-04-06 13:08:51 +0000
commitafb254820dbed31b644d253dab86e8ed01275cda (patch)
tree8e8739eddfb8556fe036062a31e52a84cd8e83a6 /devel/ice/files/patch-cpp-test-Ice-objects-Makefile
parentf7d6d5a3b2a7c750da6cfcdfd5de6333c348faca (diff)
downloadports-afb254820dbed31b644d253dab86e8ed01275cda.tar.gz
ports-afb254820dbed31b644d253dab86e8ed01275cda.zip
Update ice ports to 3.6.2
Approved by: mentors(implicit)
Notes
Notes: svn path=/head/; revision=412616
Diffstat (limited to 'devel/ice/files/patch-cpp-test-Ice-objects-Makefile')
-rw-r--r--devel/ice/files/patch-cpp-test-Ice-objects-Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/devel/ice/files/patch-cpp-test-Ice-objects-Makefile b/devel/ice/files/patch-cpp-test-Ice-objects-Makefile
new file mode 100644
index 000000000000..de44a26171c3
--- /dev/null
+++ b/devel/ice/files/patch-cpp-test-Ice-objects-Makefile
@@ -0,0 +1,28 @@
+--- cpp.orig/test/Ice/objects/Makefile.orig 2016-04-05 23:00:02.156584966 +0200
++++ cpp/test/Ice/objects/Makefile 2016-04-05 23:44:31.611624964 +0200
+@@ -12,9 +12,9 @@
+ CLIENT = $(call mktestname,client)
+ SERVER = $(call mktestname,server)
+ COLLOCATED = $(call mktestname,collocated)
+-TESTLIBNAME = libTestDerived.a
++TESTLIBNAME = libTestDerived.so
+
+-TARGETS = $(CLIENT) $(SERVER) $(COLLOCATED)
++TARGETS = $(CLIENT) $(SERVER) $(COLLOCATED) $(TESTLIBNAME)
+
+ SLICE_OBJS = Test.o \
+ Derived.o \
+@@ -47,11 +47,11 @@
+
+ $(TESTLIBNAME): $(SLICE_OBJS)
+ rm -f $@
+- $(call mklib,$@,$(SLICE_OBJS))
++ $(call mkshlib,$@,$(TESTLIBNAME),$(SLICE_OBJS),$(LIBS))
+
+ $(CLIENT): $(COBJS) $(TESTLIBNAME)
+ rm -f $@
+- $(call mktest,$@,$(COBJS) -lTestDerived $(LIBS))
++ $(call mktest,$@,-lTestDerived $(COBJS) $(LIBS))
+
+ $(SERVER): $(SOBJS)
+ rm -f $@