aboutsummaryrefslogtreecommitdiff
path: root/devel/ice
diff options
context:
space:
mode:
authorMichael Gmelin <grembo@FreeBSD.org>2016-03-08 00:29:24 +0000
committerMichael Gmelin <grembo@FreeBSD.org>2016-03-08 00:29:24 +0000
commit3c452c90f1b8601130b8ab6c5a018c2aad0ce187 (patch)
tree4bf6a896539e386e63ba3301f8078f73ed573e19 /devel/ice
parentdcafa23582f5da92e54b20d0c696e009af9bf109 (diff)
downloadports-3c452c90f1b8601130b8ab6c5a018c2aad0ce187.tar.gz
ports-3c452c90f1b8601130b8ab6c5a018c2aad0ce187.zip
Fix packaging with python 3.5.
This utilizes the new py3kplist feature. While being there, fix unit tests so they work with python3 regardless of the build environment's locale. PR: 207771 Submitted by: rm Approved by: maintainers (implicit)
Notes
Notes: svn path=/head/; revision=410590
Diffstat (limited to 'devel/ice')
-rw-r--r--devel/ice/Makefile10
-rw-r--r--devel/ice/files/patch-cpp-test-Ice-properties-run.py8
-rw-r--r--devel/ice/files/patch-python-test-Ice-properties-run.py8
3 files changed, 12 insertions, 14 deletions
diff --git a/devel/ice/Makefile b/devel/ice/Makefile
index 72c267178e1a..cc9bb93c2643 100644
--- a/devel/ice/Makefile
+++ b/devel/ice/Makefile
@@ -69,16 +69,6 @@ MAKE_ENV+= LD_LIBRARY_PATH=${WRKSRC}/cpp/lib:$$LD_LIBRARY_PATH
.include <bsd.port.pre.mk>
-.if defined(PYTHON_REL) && ${PYTHON_REL} >= 3200
-PLIST_SUB+= PYTHON32=""
-PLIST_SUB+= PYTHONPRE32="@comment "
-.else
-PLIST_SUB+= PYTHON32="@comment "
-PLIST_SUB+= PYTHONPRE32=""
-.endif
-
-PLIST_SUB+= PYTHON_SUFFIX=${PYTHON_SUFFIX}
-
.if ${PREFIX} != ${LOCALBASE}
PYSITEDIR= ${PREFIX}${PYTHON_SITELIBDIR:S|^${LOCALBASE}||}
.else
diff --git a/devel/ice/files/patch-cpp-test-Ice-properties-run.py b/devel/ice/files/patch-cpp-test-Ice-properties-run.py
index b99503f630b5..944c89292688 100644
--- a/devel/ice/files/patch-cpp-test-Ice-properties-run.py
+++ b/devel/ice/files/patch-cpp-test-Ice-properties-run.py
@@ -1,6 +1,6 @@
--- cpp/test/Ice/properties/run.py.orig 2015-12-27 03:21:09.629772970 +0100
+++ cpp/test/Ice/properties/run.py 2015-12-27 03:21:20.836761970 +0100
-@@ -28,7 +28,7 @@
+@@ -28,10 +28,10 @@
#
if sys.version_info[0] == 2:
configPath = "./config/\xe4\xb8\xad\xe5\x9b\xbd_client.config"
@@ -8,4 +8,8 @@
+ decodedPath = configPath
else:
configPath = "./config/\u4e2d\u56fd_client.config"
- decodedPath = configPath # No need to decode with Python3, strings are already Unicode
+- decodedPath = configPath # No need to decode with Python3, strings are already Unicode
++ decodedPath = configPath.encode("utf-8", "ignore") # No need to decode with Python3, strings are already Unicode
+
+ TestUtil.createConfig(decodedPath,
+ ["# Automatically generated by Ice test driver.",
diff --git a/devel/ice/files/patch-python-test-Ice-properties-run.py b/devel/ice/files/patch-python-test-Ice-properties-run.py
index da98dc879c6f..0bce6ffe5340 100644
--- a/devel/ice/files/patch-python-test-Ice-properties-run.py
+++ b/devel/ice/files/patch-python-test-Ice-properties-run.py
@@ -1,6 +1,6 @@
--- python/test/Ice/properties/run.py.orig 2015-12-27 02:42:11.742927971 +0100
+++ python/test/Ice/properties/run.py 2015-12-27 03:06:41.640921970 +0100
-@@ -26,7 +26,7 @@
+@@ -26,10 +26,10 @@
#
if sys.version_info[0] == 2:
configPath = "./config/\xe4\xb8\xad\xe5\x9b\xbd_client.config"
@@ -8,4 +8,8 @@
+ decodedPath = configPath
else:
configPath = "./config/\u4e2d\u56fd_client.config"
- decodedPath = configPath # No need to decode with Python3, strings are already Unicode
+- decodedPath = configPath # No need to decode with Python3, strings are already Unicode
++ decodedPath = configPath.encode("utf-8", 'ignore') # No need to decode with Python3, strings are already Unicode
+
+ TestUtil.createConfig(decodedPath,
+ ["# Automatically generated by Ice test driver.",