aboutsummaryrefslogtreecommitdiff
path: root/devel/icu/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-06-11 14:31:01 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-06-11 14:31:01 +0000
commit04b1ae74b3b488f58a4e148509c556c57fc73be1 (patch)
tree861903a3bb03f9d851297cd241e3d88eef570150 /devel/icu/Makefile
parent14d88f8c701c7e949e57afd87470a1768f9b67c7 (diff)
downloadports-04b1ae74b3b488f58a4e148509c556c57fc73be1.tar.gz
ports-04b1ae74b3b488f58a4e148509c556c57fc73be1.zip
Update to icu 53.1, recommand to the user to rebuild all their applications depending on icu
Notes
Notes: svn path=/head/; revision=357483
Diffstat (limited to 'devel/icu/Makefile')
-rw-r--r--devel/icu/Makefile16
1 files changed, 14 insertions, 2 deletions
diff --git a/devel/icu/Makefile b/devel/icu/Makefile
index e6ebd29f3573..fc92e9a512d3 100644
--- a/devel/icu/Makefile
+++ b/devel/icu/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= icu
-PORTVERSION= 52.1
+PORTVERSION= 53.1
CATEGORIES= devel
MASTER_SITES= http://download.icu-project.org/files/icu4c/${PORTVERSION}/ \
SF/${PORTNAME}/ICU4C/${PORTVERSION}/
@@ -33,9 +33,12 @@ CONFIGURE_ARGS+= --with-data-packaging=library \
--enable-shared \
--enable-static
+.if defined(X_BUILD_FOR)
+CONFIGURE_ARGS+= --with-cross-build
+.endif
+
USES= gmake pathfix
-INSTALL_TARGET= install install-manx
ICUMAJOR= ${PORTVERSION:C/\..*//}
PLIST_SUB+= ICUMAJOR=${ICUMAJOR} ICUVER=${PORTVERSION}
@@ -60,6 +63,15 @@ iotest cintltst intltest:
LD_LIBRARY_PATH=${WRKSRC}/lib:${WRKSRC}/tools/ctestfw \
./${.TARGET}
+post-stage:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/g* \
+ ${STAGEDIR}${PREFIX}/bin/*conv \
+ ${STAGEDIR}${PREFIX}/bin/icuinfo \
+ ${STAGEDIR}${PREFIX}/bin/derb \
+ ${STAGEDIR}${PREFIX}/bin/pkgdata
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/*
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libicuda*.so.*
+
test regression-test: iotest cintltst intltest
.include <bsd.port.mk>