aboutsummaryrefslogtreecommitdiff
path: root/devel/icu/Makefile
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2019-03-27 21:09:59 +0000
committerJan Beich <jbeich@FreeBSD.org>2019-03-27 21:09:59 +0000
commitea151d1c2eba86024177b9450f83501b4eda3dc2 (patch)
tree52af7aae42f937b4ab8670236a9aead709e9ea42 /devel/icu/Makefile
parentffcf38ec322644548acdbee8f3c4705724a61c17 (diff)
downloadports-ea151d1c2eba86024177b9450f83501b4eda3dc2.tar.gz
ports-ea151d1c2eba86024177b9450f83501b4eda3dc2.zip
devel/icu: handle RC distfiles
PR: 236325
Notes
Notes: svn path=/head/; revision=496980
Diffstat (limited to 'devel/icu/Makefile')
-rw-r--r--devel/icu/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/devel/icu/Makefile b/devel/icu/Makefile
index cdf30c784ff2..dab3b3cdce01 100644
--- a/devel/icu/Makefile
+++ b/devel/icu/Makefile
@@ -6,7 +6,7 @@ DISTVERSION= 63_1
PORTREVISION?= 1 # keep for icu-lx
PORTEPOCH?= 1
CATEGORIES?= devel
-MASTER_SITES= https://github.com/unicode-org/${PORTNAME}/releases/download/release-${DISTVERSION:S/_/-/g}/ \
+MASTER_SITES= https://github.com/unicode-org/${PORTNAME}/releases/download/release-${DISTVERSION:S/rc/-&/:S/_/-/g}/ \
SF/${PORTNAME}/${PORTNAME:tu}4C/${PORTVERSION}
DISTNAME= icu4c-${DISTVERSION}-src
@@ -32,7 +32,7 @@ USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/icu/source
ICUMAJOR= ${PORTVERSION:C/\..*//}
-PLIST_SUB+= ICUMAJOR=${ICUMAJOR} ICUVER=${PORTVERSION}
+PLIST_SUB+= ICUMAJOR=${ICUMAJOR} ICUVER=${PORTVERSION:C/r.?/1/}
.ifndef PKGNAMESUFFIX
post-install:
@@ -44,7 +44,7 @@ post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/*
# Filename varies by endianness: icudt<major>b.dat vs. icudt<major>l.dat
@(cd ${STAGEDIR}${PREFIX} && ${ECHO_CMD} \
- ${DATADIR_REL}/${PORTVERSION}/icudt*.dat >>${TMPPLIST})
+ ${DATADIR_REL}/${PORTVERSION:C/r.?/1/}/icudt*.dat >>${TMPPLIST})
.endif # PKGNAMESUFFIX
.include <bsd.port.mk>