aboutsummaryrefslogtreecommitdiff
path: root/devel/kf5-kidletime/Makefile
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2016-11-14 16:12:56 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2016-11-14 16:12:56 +0000
commit30a183cdd9faf4c65a08818c285c8d9351e43ad3 (patch)
treedbe08499461c3eea79dce8b1eca87e2699ef0d1c /devel/kf5-kidletime/Makefile
parent1ff45cdd0ae918b61cf33786436856d37aa2dcfb (diff)
downloadports-30a183cdd9faf4c65a08818c285c8d9351e43ad3.tar.gz
ports-30a183cdd9faf4c65a08818c285c8d9351e43ad3.zip
Importing KDE Frameworks into the ports tree (required for newer KDE Desktop and Applications)
KDE Frameworks is a collection of libraries and software frameworks by KDE that serve as technological foundation for KDE Plasma 5 and KDE Applications distributed under the GNU Lesser General Public License (LGPL) [1]. The work is based on what we have in the KDE testing repo [2]. This is the next big step in updating the KDE Desktop and its Applications to anything less dusty. With this change, `USES=kde:5` is now a valid option. Ports that need to depend on KDE Framework can now set: USES=kde:5 USE_KDE=<framework1> <framework2> ... <frameworkX> For example: www/qupzilla-qt5 can depend on sysutils/kf5-kwallet via: KWALLET_USE= KDE=wallet I would like to thank Raphael and Adriaan for reviewing the ports in the testing repo :) [1] https://en.wikipedia.org/wiki/KDE_Frameworks [2] http://src.mouf.net/area51/log/branches/plasma5 Reviewed by: rakuco, mat, groot_kde.org Approved by: rakuco (maintainer) Differential Revision: https://reviews.freebsd.org/D8329
Notes
Notes: svn path=/head/; revision=426118
Diffstat (limited to 'devel/kf5-kidletime/Makefile')
-rw-r--r--devel/kf5-kidletime/Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/devel/kf5-kidletime/Makefile b/devel/kf5-kidletime/Makefile
new file mode 100644
index 000000000000..f2601454d530
--- /dev/null
+++ b/devel/kf5-kidletime/Makefile
@@ -0,0 +1,16 @@
+# Created by: Tobias Berner <tcberner@gmail.com>
+# $FreeBSD$
+
+PORTNAME= kidletime
+PORTVERSION= ${KDE_FRAMEWORKS_VERSION}
+CATEGORIES= devel kde kde-frameworks
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= KF5 library for monitoring user activity
+
+USES= cmake:outsource compiler:c++11-lib kde:5 pkgconfig tar:xz
+USE_KDE= ecm
+USE_QT5= buildtools_build core dbus gui qmake_build widgets x11extras
+USE_XORG= ice sm x11 xext xcb xscrnsaver
+
+.include <bsd.port.mk>