aboutsummaryrefslogtreecommitdiff
path: root/devel/libbrotli
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2016-02-12 12:23:28 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2016-02-12 12:23:28 +0000
commit220eb54b712e0206801e4dbf076199d7a86846d1 (patch)
treeba660d72dcac4ae2fe6b70ea56061253b464f736 /devel/libbrotli
parentcfb6571e2f779233d1cb0a76bab44a9e5ece8d08 (diff)
downloadports-220eb54b712e0206801e4dbf076199d7a86846d1.tar.gz
ports-220eb54b712e0206801e4dbf076199d7a86846d1.zip
Add libbrotli - libraries for the brotli decode and encode sources.
Notes
Notes: svn path=/head/; revision=408718
Diffstat (limited to 'devel/libbrotli')
-rw-r--r--devel/libbrotli/Makefile31
-rw-r--r--devel/libbrotli/distinfo4
-rw-r--r--devel/libbrotli/files/patch-Makefile.am31
-rw-r--r--devel/libbrotli/files/patch-autogen.sh11
-rw-r--r--devel/libbrotli/pkg-descr5
-rw-r--r--devel/libbrotli/pkg-plist49
6 files changed, 131 insertions, 0 deletions
diff --git a/devel/libbrotli/Makefile b/devel/libbrotli/Makefile
new file mode 100644
index 000000000000..9d7067a281b2
--- /dev/null
+++ b/devel/libbrotli/Makefile
@@ -0,0 +1,31 @@
+# Created by: Sergey A. Osokin <osa@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= libbrotli
+PORTVERSION= ${BROTLI_VERSION}
+CATEGORIES= devel archivers
+
+MAINTAINER= osa@FreeBSD.org
+COMMENT= Library for generic-purpose lossless compression algorithm
+
+LICENSE= MIT
+
+LIBBROTLI_VERSION= 53d53e8
+BROTLI_VERSION= 0.3.0
+
+USE_GITHUB= yes
+GH_ACCOUNT= bagder google:brotli
+GH_PROJECT= brotli:brotli
+GH_TAGNAME= ${LIBBROTLI_VERSION} v${BROTLI_VERSION}:brotli
+
+#USES= pkgconfig autoreconf libtool compiler:c++0x gmake
+USES= pkgconfig autoreconf libtool compiler:c++0x
+GNU_CONFIGURE= yes
+MAKE_JOBS_UNSAFE= yes
+USE_LDCONFIG= yes
+
+pre-configure:
+ ${RMDIR} ${WRKSRC}/brotli && ${MV} ${WRKDIR}/brotli-${BROTLI_VERSION} ${WRKSRC}/brotli
+ cd ${WRKSRC} && ./autogen.sh
+
+.include <bsd.port.mk>
diff --git a/devel/libbrotli/distinfo b/devel/libbrotli/distinfo
new file mode 100644
index 000000000000..9b4da9240203
--- /dev/null
+++ b/devel/libbrotli/distinfo
@@ -0,0 +1,4 @@
+SHA256 (bagder-libbrotli-0.3.0-53d53e8_GH0.tar.gz) = fc5b50981ffd7f66dbf9ac398d99bad89e08237d90c7966ff20f4fbe883fb895
+SIZE (bagder-libbrotli-0.3.0-53d53e8_GH0.tar.gz) = 3103
+SHA256 (google-brotli-v0.3.0_GH0.tar.gz) = 5d49eb1a6dd19304dd683c293abf66c8a419728f4c6d0f390fa7deb2a39eaae2
+SIZE (google-brotli-v0.3.0_GH0.tar.gz) = 8035159
diff --git a/devel/libbrotli/files/patch-Makefile.am b/devel/libbrotli/files/patch-Makefile.am
new file mode 100644
index 000000000000..d70d7ed9b23b
--- /dev/null
+++ b/devel/libbrotli/files/patch-Makefile.am
@@ -0,0 +1,31 @@
+--- Makefile.am.orig 2016-01-20 21:31:42 UTC
++++ Makefile.am
+@@ -14,8 +14,7 @@ ENCODE = brotli/enc/backward_references.
+ brotli/enc/encode.cc brotli/enc/static_dict.cc \
+ brotli/enc/encode_parallel.cc brotli/enc/streams.cc \
+ brotli/enc/entropy_encode.cc brotli/enc/dictionary.cc \
+- brotli/enc/utf8_util.cc brotli/enc/compress_fragment.cc \
+- brotli/enc/compress_fragment_two_pass.cc
++ brotli/enc/utf8_util.cc
+
+ DECODEHEADERS = brotli/dec/decode.h brotli/dec/state.h \
+ brotli/dec/streams.h brotli/dec/types.h brotli/dec/bit_reader.h \
+@@ -32,15 +31,15 @@ ENCODEHEADERS = brotli/enc/encode.h brot
+ brotli/enc/literal_cost.h brotli/enc/cluster.h brotli/enc/bit_cost.h \
+ brotli/enc/entropy_encode.h brotli/enc/brotli_bit_stream.h \
+ brotli/enc/write_bits.h brotli/enc/static_dict_lut.h \
+- brotli/enc/encode_parallel.h brotli/enc/types.h brotli/enc/utf8_util.h \
+- brotli/enc/compress_fragment.h brotli/enc/compress_fragment_two_pass.h
++ brotli/enc/encode_parallel.h brotli/enc/types.h brotli/enc/utf8_util.h
++
+
+ EXTRA_DIST = AUTHORS README
+
+ # install headers in $(includedir) with subdirs
+ nobase_include_HEADERS = $(DECODEHEADERS) $(ENCODEHEADERS)
+
+-pkgconfigdir = $(libdir)/pkgconfig
++pkgconfigdir = $(libdir)/../libdata/pkgconfig
+ pkgconfig_DATA = libbrotlienc.pc libbrotlidec.pc
+ pkgincludedir= $(includedir)/brotli
+ pkginclude_HEADERS =
diff --git a/devel/libbrotli/files/patch-autogen.sh b/devel/libbrotli/files/patch-autogen.sh
new file mode 100644
index 000000000000..ad965f74a26b
--- /dev/null
+++ b/devel/libbrotli/files/patch-autogen.sh
@@ -0,0 +1,11 @@
+--- autogen.sh.orig 2016-01-20 21:31:42 UTC
++++ autogen.sh
+@@ -12,8 +12,6 @@ if test $? -ne 0; then
+ exit 1
+ fi
+
+-$GIT submodule init
+-$GIT submodule update
+
+ # create m4 before autoreconf
+ mkdir m4 2>/dev/null
diff --git a/devel/libbrotli/pkg-descr b/devel/libbrotli/pkg-descr
new file mode 100644
index 000000000000..720024d7f849
--- /dev/null
+++ b/devel/libbrotli/pkg-descr
@@ -0,0 +1,5 @@
+Wrapper scripts and code around the brotli code base.
+Builds libraries out of the brotli decode and encode sources.
+
+WWW: https://github.com/google/brotli
+WWW: https://github.com/bagder/libbrotli
diff --git a/devel/libbrotli/pkg-plist b/devel/libbrotli/pkg-plist
new file mode 100644
index 000000000000..e3a33c6d1dfe
--- /dev/null
+++ b/devel/libbrotli/pkg-plist
@@ -0,0 +1,49 @@
+include/brotli/dec/bit_reader.h
+include/brotli/dec/context.h
+include/brotli/dec/decode.h
+include/brotli/dec/dictionary.h
+include/brotli/dec/huffman.h
+include/brotli/dec/port.h
+include/brotli/dec/prefix.h
+include/brotli/dec/state.h
+include/brotli/dec/streams.h
+include/brotli/dec/transform.h
+include/brotli/dec/types.h
+include/brotli/enc/backward_references.h
+include/brotli/enc/bit_cost.h
+include/brotli/enc/block_splitter.h
+include/brotli/enc/brotli_bit_stream.h
+include/brotli/enc/cluster.h
+include/brotli/enc/command.h
+include/brotli/enc/context.h
+include/brotli/enc/dictionary.h
+include/brotli/enc/dictionary_hash.h
+include/brotli/enc/encode.h
+include/brotli/enc/encode_parallel.h
+include/brotli/enc/entropy_encode.h
+include/brotli/enc/fast_log.h
+include/brotli/enc/find_match_length.h
+include/brotli/enc/hash.h
+include/brotli/enc/histogram.h
+include/brotli/enc/literal_cost.h
+include/brotli/enc/metablock.h
+include/brotli/enc/port.h
+include/brotli/enc/prefix.h
+include/brotli/enc/ringbuffer.h
+include/brotli/enc/static_dict.h
+include/brotli/enc/static_dict_lut.h
+include/brotli/enc/streams.h
+include/brotli/enc/transform.h
+include/brotli/enc/types.h
+include/brotli/enc/utf8_util.h
+include/brotli/enc/write_bits.h
+lib/libbrotlidec.a
+lib/libbrotlidec.so
+lib/libbrotlidec.so.1
+lib/libbrotlidec.so.1.0.0
+lib/libbrotlienc.a
+lib/libbrotlienc.so
+lib/libbrotlienc.so.1
+lib/libbrotlienc.so.1.0.0
+libdata/pkgconfig/libbrotlidec.pc
+libdata/pkgconfig/libbrotlienc.pc