aboutsummaryrefslogtreecommitdiff
path: root/devel/libcheck/files
diff options
context:
space:
mode:
authorSean Chittenden <seanc@FreeBSD.org>2006-07-05 18:30:08 +0000
committerSean Chittenden <seanc@FreeBSD.org>2006-07-05 18:30:08 +0000
commit90862d3405a3ddcab2c788945e8af59f36bb0f30 (patch)
treef033a8f9c9770e834b5b06eb27a2b2b7623c2074 /devel/libcheck/files
parent6b4b9db459d4912155e498247c6e92a45ac6d275 (diff)
downloadports-90862d3405a3ddcab2c788945e8af59f36bb0f30.tar.gz
ports-90862d3405a3ddcab2c788945e8af59f36bb0f30.zip
Update libcheck (C unit testing library) to 0.9.3. Port changes
include: *) Update check.m4 to search for libraries and headers in /usr/local/* and $prefix/*. Ports/programs that use libcheck now work with the configure arg `--with-check` without needing to specify the location as an argument. Someone with more autofoo may want to review this. Patch submitted upstream. *) Removed incorporated patches. *) Installing docs and examples in their proper location. *) Removed a description of the benefits of unit testing in pkg-descr. *) No longer installing COPYING. Approved by: mikeh (maintainer)
Notes
Notes: svn path=/head/; revision=166995
Diffstat (limited to 'devel/libcheck/files')
-rw-r--r--devel/libcheck/files/patch-Makefile.in20
-rw-r--r--devel/libcheck/files/patch-aa11
-rw-r--r--devel/libcheck/files/patch-ab11
-rw-r--r--devel/libcheck/files/patch-check.m426
-rw-r--r--devel/libcheck/files/patch-doc+money+Makefile.in11
5 files changed, 57 insertions, 22 deletions
diff --git a/devel/libcheck/files/patch-Makefile.in b/devel/libcheck/files/patch-Makefile.in
new file mode 100644
index 000000000000..9641cb730f00
--- /dev/null
+++ b/devel/libcheck/files/patch-Makefile.in
@@ -0,0 +1,20 @@
+--- Makefile.in.orig Sun Jul 2 20:15:13 2006
++++ Makefile.in Sun Jul 2 20:15:30 2006
+@@ -77,7 +77,7 @@
+ @PLAIN_DOCDIR_FALSE@DOCROOTDIR = $(prefix)/share/doc/${PACKAGE}-${VERSION}
+ docdir = $(DOCROOTDIR)
+
+-doc_DATA = ChangeLog ChangeLogOld NEWS README COPYING
++doc_DATA = ChangeLog ChangeLogOld NEWS README
+
+ SUBDIRS = src tests doc rpm debian
+
+@@ -94,7 +94,7 @@
+ CONFIG_CLEAN_FILES =
+ DATA = $(doc_DATA) $(m4data_DATA)
+
+-DIST_COMMON = README ./stamp-h.in AUTHORS COPYING ChangeLog INSTALL \
++DIST_COMMON = README ./stamp-h.in AUTHORS ChangeLog INSTALL \
+ Makefile.am Makefile.in NEWS acinclude.m4 aclocal.m4 config.guess \
+ config.h.in config.sub configure configure.in install-sh missing \
+ mkinstalldirs
diff --git a/devel/libcheck/files/patch-aa b/devel/libcheck/files/patch-aa
deleted file mode 100644
index 2e4bdfbdd487..000000000000
--- a/devel/libcheck/files/patch-aa
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/check.h.in.orig Sun Nov 14 23:01:22 2004
-+++ src/check.h.in Sun Nov 14 23:01:36 2004
-@@ -168,7 +168,7 @@
- /* Fail the test case if expr is true */
- #define fail_if(expr, ...)\
- _fail_unless(!(expr), __FILE__, __LINE__,\
-- "Failure '"#expr"' occured", ## __VA_ARGS__, NULL)
-+ "Failure '"#expr"' occured" , ## __VA_ARGS__, NULL)
-
- /* Always fail */
- #define fail(...) _fail_unless(0, __FILE__, __LINE__, "Failed" , ## __VA_ARGS__, NULL)
diff --git a/devel/libcheck/files/patch-ab b/devel/libcheck/files/patch-ab
deleted file mode 100644
index 15e790bbba9f..000000000000
--- a/devel/libcheck/files/patch-ab
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/check_pack.c.orig Sun Nov 14 22:55:22 2004
-+++ src/check_pack.c Sun Nov 14 22:55:39 2004
-@@ -24,7 +24,7 @@
- #include <string.h>
- #include <stdio.h>
- #include <unistd.h>
--#include <stdint.h>
-+/* #include <stdint.h> */
-
- #include "check.h"
- #include "check_error.h"
diff --git a/devel/libcheck/files/patch-check.m4 b/devel/libcheck/files/patch-check.m4
new file mode 100644
index 000000000000..2c4f122ea7a7
--- /dev/null
+++ b/devel/libcheck/files/patch-check.m4
@@ -0,0 +1,26 @@
+--- check.m4.orig Tue Mar 1 01:25:26 2005
++++ check.m4 Sun Jul 2 21:13:20 2006
+@@ -19,8 +19,21 @@
+ CHECK_CFLAGS="-I$with_check/include"
+ CHECK_LIBS="-L$with_check/lib -lcheck"
+ else
+- CHECK_CFLAGS=""
+- CHECK_LIBS="-lcheck"
++ for check_includedir in /usr/local/include /usr/local/include/check /usr/include $prefix/include
++ do
++ if test -e $check_includedir/check.h ; then
++ CHECK_CFLAGS="-I${check_includedir}"
++ break
++ fi
++ done
++
++ for check_libdir in /usr/local/lib /usr/local/lib/check /usr/lib $prefix/lib
++ do
++ if test -e $check_libdir/libcheck.a ; then
++ CHECK_LIBS="-L${check_libdir} -lcheck"
++ break
++ fi
++ done
+ fi
+
+ ac_save_CFLAGS="$CFLAGS"
diff --git a/devel/libcheck/files/patch-doc+money+Makefile.in b/devel/libcheck/files/patch-doc+money+Makefile.in
new file mode 100644
index 000000000000..98744ad075bf
--- /dev/null
+++ b/devel/libcheck/files/patch-doc+money+Makefile.in
@@ -0,0 +1,11 @@
+--- doc/money/Makefile.in.orig Sun Jul 2 20:23:16 2006
++++ doc/money/Makefile.in Sun Jul 2 20:24:13 2006
+@@ -75,7 +75,7 @@
+ have_docbook2html = @have_docbook2html@
+ @PLAIN_DOCDIR_TRUE@DOCROOTDIR = $(prefix)/share/doc/$(PACKAGE)
+ @PLAIN_DOCDIR_FALSE@DOCROOTDIR = $(prefix)/share/doc/${PACKAGE}-${VERSION}
+-exampledocdir = $(DOCROOTDIR)/examples
++exampledocdir = $(prefix)/share/examples/${PACKAGE}-${VERSION}
+
+ example_docs = money.h money.c check_money.c configure.in.money Makefile.am.money
+