aboutsummaryrefslogtreecommitdiff
path: root/devel/libdisorder/Makefile
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2010-12-13 02:22:51 +0000
committerKevin Lo <kevlo@FreeBSD.org>2010-12-13 02:22:51 +0000
commit71469c7e6f2cb7319090aa2e743c2c3598d3df1d (patch)
treef827543d5f7939429b6361d5a336356b3c0141d5 /devel/libdisorder/Makefile
parent26a546dcf82549a8268e7e3d28f492f6a9d85a32 (diff)
downloadports-71469c7e6f2cb7319090aa2e743c2c3598d3df1d.tar.gz
ports-71469c7e6f2cb7319090aa2e743c2c3598d3df1d.zip
We have added support for log2() into base, so make the EXTRA_PATCHES
on OSVERSION.
Notes
Notes: svn path=/head/; revision=266169
Diffstat (limited to 'devel/libdisorder/Makefile')
-rw-r--r--devel/libdisorder/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/devel/libdisorder/Makefile b/devel/libdisorder/Makefile
index 9ddf428129fa..6d003a537ece 100644
--- a/devel/libdisorder/Makefile
+++ b/devel/libdisorder/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libdisorder
PORTVERSION= 0.0.2
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://libdisorder.freshdefense.net/releases/
@@ -15,6 +16,12 @@ COMMENT= A simple C library for entropy measurement
USE_LDCONFIG= yes
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 900027
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-disorder.c
+.endif
+
do-build:
cd ${WRKSRC}/src && ${SETENV} ${MAKE_ENV} ${MAKE}
@@ -28,4 +35,4 @@ do-install:
post-install:
${LN} -sf ${PREFIX}/lib/libdisorder.so.1 ${PREFIX}/lib/libdisorder.so
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>