aboutsummaryrefslogtreecommitdiff
path: root/devel/meson/Makefile
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2021-04-06 07:23:13 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2021-04-20 06:57:34 +0000
commita91d65363fe8aa72bdf427bb639b0fe258ee7c01 (patch)
treebff05a5e79d56100a683a17dd262f3cdbf38cf36 /devel/meson/Makefile
parent18f78deb5310e3dc0c3283cc5893339da900640c (diff)
downloadports-a91d65363fe8aa72bdf427bb639b0fe258ee7c01.tar.gz
ports-a91d65363fe8aa72bdf427bb639b0fe258ee7c01.zip
Mk/Uses/ninja.mk: Add support for devel/samurai (D29353)
Samurai is a Ninja-compatible build tool with fewer dependencies than Ninja. Hook it to the framework via a new NINJA_DEFAULT. This also adds %p to NINJA_STATUS to make Ninja or Samurai print the percentage of completed jobs to make it easier to eyeball how much of the build is done. PR: 254678 Exp-run by: antoine
Diffstat (limited to 'devel/meson/Makefile')
-rw-r--r--devel/meson/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/devel/meson/Makefile b/devel/meson/Makefile
index f80ece912514..8a25e36d64ba 100644
--- a/devel/meson/Makefile
+++ b/devel/meson/Makefile
@@ -11,10 +11,9 @@ COMMENT= High performance build system
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/COPYING
-RUN_DEPENDS= ninja:devel/ninja
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest-xdist>0:devel/py-pytest-xdist@${PY_FLAVOR}
-USES= python:3.6+ shebangfix
+USES= ninja:run python:3.6+ shebangfix
USE_PYTHON= autoplist distutils noflavors
SHEBANG_FILES= mesonbuild/rewriter.py \
mesonbuild/scripts/cmake_run_ctgt.py