aboutsummaryrefslogtreecommitdiff
path: root/devel/objecthash/Makefile
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-09-10 15:47:22 +0000
committerJohn Marino <marino@FreeBSD.org>2016-09-10 15:47:22 +0000
commit580ad56a55730ab5684f825e19e5fed302100ee6 (patch)
tree497ec495e54ec17c34759aca630d453cc625691b /devel/objecthash/Makefile
parent37abc91c92fd8d134baed7702b1e5b499f51eefd (diff)
downloadports-580ad56a55730ab5684f825e19e5fed302100ee6.tar.gz
ports-580ad56a55730ab5684f825e19e5fed302100ee6.zip
devel/objecthash: document SSL requirement
Notes
Notes: svn path=/head/; revision=421705
Diffstat (limited to 'devel/objecthash/Makefile')
-rw-r--r--devel/objecthash/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/devel/objecthash/Makefile b/devel/objecthash/Makefile
index 29238724d1eb..73321be4ffef 100644
--- a/devel/objecthash/Makefile
+++ b/devel/objecthash/Makefile
@@ -12,13 +12,12 @@ COMMENT= Cross-language way to cryptographically hash JSON objects
LICENSE= APACHE20
BROKEN_powerpc64= Does not build
+BROKEN_FreeBSD_9= does not build on FreeBSD < 10.x
LIB_DEPENDS= libicudata.so:devel/icu \
libjson-c.so:devel/json-c
-BROKEN_FreeBSD_9= does not build on FreeBSD < 10.x
-
-USES= pkgconfig
+USES= pkgconfig ssl
USE_GITHUB= yes
USE_LDCONFIG= yes
GH_ACCOUNT= benlaurie
@@ -30,7 +29,7 @@ ALL_TARGET= libobjecthash.so
PLIST_FILES= include/objecthash.h lib/libobjecthash.so
do-install:
- ${INSTALL_LIB} ${WRKSRC}/libobjecthash.so ${STAGEDIR}${PREFIX}/lib
- ${INSTALL_DATA} ${WRKSRC}/objecthash.h ${STAGEDIR}${PREFIX}/include
+ ${INSTALL_LIB} ${WRKSRC}/libobjecthash.so ${STAGEDIR}${PREFIX}/lib
+ ${INSTALL_DATA} ${WRKSRC}/objecthash.h ${STAGEDIR}${PREFIX}/include
.include <bsd.port.mk>