aboutsummaryrefslogtreecommitdiff
path: root/devel/ocaml-pomap
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-08-20 06:47:52 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-08-20 06:47:52 +0000
commitc4dd701f02fc278886abd668b28b8801b482fa53 (patch)
treedbabad8ad701df1603aaf5eadebb2d659e6a70b9 /devel/ocaml-pomap
parent19827fa00723d84bbd1b9e3fb99c6c9fcd6909a9 (diff)
downloadports-c4dd701f02fc278886abd668b28b8801b482fa53.tar.gz
ports-c4dd701f02fc278886abd668b28b8801b482fa53.zip
The Pomap-library implements an ADT that maintains maps of partially ordered
elements. Whereas a total order allows you to say whether some element is lower, equal or greater than another one, partial orders also allow for a "don-t know" case. Author: Markus Mottl <markus.mottl@gmail.com> WWW: http://www.ocaml.info/home/ocaml_sources.html PR: ports/102116 Submitted by: Stanislav Sedov <ssedov at mbsd.msk.ru>
Notes
Notes: svn path=/head/; revision=171002
Diffstat (limited to 'devel/ocaml-pomap')
-rw-r--r--devel/ocaml-pomap/Makefile67
-rw-r--r--devel/ocaml-pomap/distinfo3
-rw-r--r--devel/ocaml-pomap/pkg-descr7
3 files changed, 77 insertions, 0 deletions
diff --git a/devel/ocaml-pomap/Makefile b/devel/ocaml-pomap/Makefile
new file mode 100644
index 000000000000..96feb9d01144
--- /dev/null
+++ b/devel/ocaml-pomap/Makefile
@@ -0,0 +1,67 @@
+# New ports collection makefile for: pomap
+# Date created: 2006-08-15
+# Whom: Stanislav Sedov <ssedov@mbsd.msk.ru>
+#
+# $MBSDlabs$
+# $FreeBSD$
+#
+
+PORTNAME= pomap
+PORTVERSION= 2.9.7
+CATEGORIES= devel
+MASTER_SITES= http://www.ocaml.info/ocaml_sources/
+PKGNAMEPREFIX= ocaml-
+
+MAINTAINER= ssedov@mbsd.msk.ru
+COMMENT= OCaml library to maintain a list of partially ordered elements
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_OCAML= yes
+USE_OCAML_FINDLIB=yes
+USE_OCAML_WASH= yes
+
+DOCS= README
+DOCSDIR= ${TARGETDIR}/share/doc/ocaml/${PORTNAME}
+EXAMPLESDIR= ${TARGETDIR}/share/examples/ocaml/${PORTNAME}
+
+# XXX: exists untill it will be committed to bsd.port.mk
+COPYTREE_SHARE= ${SH} -c '(${FIND} -d $$0 $$2 | ${CPIO} -dumpl $$1 >/dev/null \
+ 2>&1) && \
+ ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} $$1 && \
+ ${FIND} $$1/ -type d -exec ${CHMOD} 755 {} \; && \
+ ${FIND} $$1/ -type f -exec ${CHMOD} ${SHAREMODE} {} \;' --
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/lang/ocaml/bsd.ocaml.mk"
+
+post-extract:
+# For nonstandard prefixes
+.if !exists(${OCAMLFIND_DESTDIR})
+ ${MKDIR} ${OCAMLFIND_DESTDIR}
+.endif
+
+post-install:
+ @${FIND} ${OCAMLFIND_DESTDIR}/${PORTNAME} -type f | \
+ ${SED} "s,^${TARGETDIR}/,," >> ${TMPPLIST}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${DOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
+ @${MKDIR} ${EXAMPLESDIR}
+ @(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} \* ${EXAMPLESDIR}/)
+ @${FIND} ${EXAMPLESDIR}/ ! -type d | \
+ ${SED} 's,^${TARGETDIR}/,,' >> ${TMPPLIST}
+ @${FIND} ${EXAMPLESDIR}/ -type d | ${SORT} -r | \
+ ${SED} 's,^${TARGETDIR}/,@dirrm ,' >> ${TMPPLIST}
+ @${FIND} ${DOCSDIR}/ ! -type d | \
+ ${SED} 's,^${TARGETDIR}/,,' >> ${TMPPLIST}
+ @${FIND} ${DOCSDIR}/ -type d | ${SORT} -r | \
+ ${SED} 's,^${TARGETDIR}/,@dirrm ,' >> ${TMPPLIST}
+# XXX: temporary workaround for non-standard PREFIX
+ @${ECHO_CMD} "@unexec rmdir %D/share/doc/ocaml 2>/dev/null || true" \
+ >> ${TMPPLIST}
+ @${ECHO_CMD} "@unexec rmdir %D/share/examples/ocaml 2>/dev/null||true" \
+ >> ${TMPPLIST}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/ocaml-pomap/distinfo b/devel/ocaml-pomap/distinfo
new file mode 100644
index 000000000000..c317c7c68a26
--- /dev/null
+++ b/devel/ocaml-pomap/distinfo
@@ -0,0 +1,3 @@
+MD5 (pomap-2.9.7.tar.bz2) = b765bf2a3b09a89a34957f8566165f8f
+SHA256 (pomap-2.9.7.tar.bz2) = e62c8cf7136428013e4e8a91f62597e0b423c07e4ae7c999ac5910ec45c7c471
+SIZE (pomap-2.9.7.tar.bz2) = 36455
diff --git a/devel/ocaml-pomap/pkg-descr b/devel/ocaml-pomap/pkg-descr
new file mode 100644
index 000000000000..95f112371837
--- /dev/null
+++ b/devel/ocaml-pomap/pkg-descr
@@ -0,0 +1,7 @@
+The Pomap-library implements an ADT that maintains maps of partially ordered
+elements. Whereas a total order allows you to say whether some element is
+lower, equal or greater than another one, partial orders also allow for a
+"don-t know" case.
+
+Author: Markus Mottl <markus.mottl@gmail.com>
+WWW: http://www.ocaml.info/home/ocaml_sources.html