aboutsummaryrefslogtreecommitdiff
path: root/devel/onetbb
diff options
context:
space:
mode:
authorGanael LAPLANCHE <martymac@FreeBSD.org>2021-10-10 15:11:27 +0000
committerGanael LAPLANCHE <martymac@FreeBSD.org>2021-10-10 15:11:27 +0000
commit036bda781b0b170e823e3cacc14f25e2bd9c2b3a (patch)
tree90617ab1ae5b1a26d09f870819f8d449cc782235 /devel/onetbb
parentbe6f269b0dc0dd4c58d200d2389bcd6892367e6b (diff)
downloadports-036bda781b0b170e823e3cacc14f25e2bd9c2b3a.tar.gz
ports-036bda781b0b170e823e3cacc14f25e2bd9c2b3a.zip
devel/onetbb: Update to 2021.4.0
Diffstat (limited to 'devel/onetbb')
-rw-r--r--devel/onetbb/Makefile13
-rw-r--r--devel/onetbb/distinfo6
-rw-r--r--devel/onetbb/files/patch-src_tbbmalloc_frontend.cpp30
-rw-r--r--devel/onetbb/files/patch-test-common-utils_concurrency_limit.h31
-rw-r--r--devel/onetbb/files/patch-test-tbbmalloc-test_malloc_compliance.cpp13
-rw-r--r--devel/onetbb/pkg-plist19
6 files changed, 43 insertions, 69 deletions
diff --git a/devel/onetbb/Makefile b/devel/onetbb/Makefile
index 578bec315771..c24dba9c5909 100644
--- a/devel/onetbb/Makefile
+++ b/devel/onetbb/Makefile
@@ -1,7 +1,7 @@
# Created by: Arun Sharma <arun@sharma-home.net>
PORTNAME= onetbb
-PORTVERSION= 2021.3.0
+PORTVERSION= 2021.4.0
DISTVERSIONPREFIX= v
CATEGORIES= devel
@@ -16,8 +16,8 @@ USES= cmake compiler:c++11-lang tar:tgz
CMAKE_ARGS+= -DTBB_STRICT:BOOL=FALSE \
-DCMAKE_INSTALL_DOCDIR:PATH="${DOCSDIR}" \
- -DCMAKE_HWLOC_2_4_LIBRARY_PATH:PATH="${LOCALBASE}/lib/libhwloc.so" \
- -DCMAKE_HWLOC_2_4_INCLUDE_PATH:PATH="${LOCALBASE}/include"
+ -DCMAKE_HWLOC_2_LIBRARY_PATH:PATH="${LOCALBASE}/lib/libhwloc.so" \
+ -DCMAKE_HWLOC_2_INCLUDE_PATH:PATH="${LOCALBASE}/include"
CONFLICTS= tbb-[0-9]*
@@ -31,8 +31,15 @@ PORTDOCS= README.md
OPTIONS_DEFINE= DOCS
+# Pkgconfig: tbb.pc (on 64bit arch) vs tbb32.pc
+PLIST_SUB= PCSUFX="${PCSUFX}"
+
.include <bsd.port.pre.mk>
+.if ${ARCH} == i386 || ${ARCH} == powerpc
+PCSUFX= 32
+.endif
+
.if ${ARCH} == powerpc || ${ARCH} == riscv64
EXTRA_PATCHES= ${FILESDIR}/extra-patch-src_tbb_tools__api_ittnotify__config.h
.endif
diff --git a/devel/onetbb/distinfo b/devel/onetbb/distinfo
index b362736545bd..ce939a2ff2f6 100644
--- a/devel/onetbb/distinfo
+++ b/devel/onetbb/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1626043027
-SHA256 (oneapi-src-oneTBB-v2021.3.0_GH0.tar.gz) = 8f616561603695bbb83871875d2c6051ea28f8187dbe59299961369904d1d49e
-SIZE (oneapi-src-oneTBB-v2021.3.0_GH0.tar.gz) = 1651329
+TIMESTAMP = 1633466066
+SHA256 (oneapi-src-oneTBB-v2021.4.0_GH0.tar.gz) = 021796c7845e155e616f5ecda16daa606ebb4c6f90b996e5c08aebab7a8d3de3
+SIZE (oneapi-src-oneTBB-v2021.4.0_GH0.tar.gz) = 2452533
diff --git a/devel/onetbb/files/patch-src_tbbmalloc_frontend.cpp b/devel/onetbb/files/patch-src_tbbmalloc_frontend.cpp
deleted file mode 100644
index 314267054456..000000000000
--- a/devel/onetbb/files/patch-src_tbbmalloc_frontend.cpp
+++ /dev/null
@@ -1,30 +0,0 @@
-Backport fa944e19600500863507ed8e9b1f5a30037d9df6
-
---- src/tbbmalloc/frontend.cpp.orig 2021-06-30 08:19:55 UTC
-+++ src/tbbmalloc/frontend.cpp
-@@ -802,21 +802,15 @@ static inline unsigned int highestBitPos(unsigned int
- return pos;
- }
-
--
--#if __TBB_x86_32 || __aarch32__
- unsigned int getSmallObjectIndex(unsigned int size)
- {
-- return (size-1)>>3;
--}
--#elif __TBB_x86_64 || __aarch64__
--unsigned int getSmallObjectIndex(unsigned int size)
--{
-- // For 64-bit malloc, 16 byte alignment is needed except for bin 0.
- unsigned int result = (size-1)>>3;
-- if (result) result |= 1; // 0,1,3,5,7; bins 2,4,6 are not aligned to 16 bytes
-+ if (sizeof(void*)==8) {
-+ // For 64-bit malloc, 16 byte alignment is needed except for bin 0.
-+ if (result) result |= 1; // 0,1,3,5,7; bins 2,4,6 are not aligned to 16 bytes
-+ }
- return result;
- }
--#endif // __TBB_x86_32 || __aarch32__
-
- /*
- * Depending on indexRequest, for a given size return either the index into the bin
diff --git a/devel/onetbb/files/patch-test-common-utils_concurrency_limit.h b/devel/onetbb/files/patch-test-common-utils_concurrency_limit.h
index 78edd61fe7d8..945060970e53 100644
--- a/devel/onetbb/files/patch-test-common-utils_concurrency_limit.h
+++ b/devel/onetbb/files/patch-test-common-utils_concurrency_limit.h
@@ -1,16 +1,21 @@
-Backport edc39b844a483b69c39c64a136c4d62342884892 and 5c5d500d4fd502baed5176a19306e70c72d9c4e4
+Fix build on FreeBSD
---- test/common/utils_concurrency_limit.h.orig 2021-06-30 08:19:55 UTC
+__unix__ is defined on FreeBSD and makes #elif __FreeBSD__ section skipped
+
+--- test/common/utils_concurrency_limit.h.orig 2021-10-04 09:50:18 UTC
+++ test/common/utils_concurrency_limit.h
-@@ -166,9 +166,10 @@ int limit_number_of_threads( int max_threads ) {
-
- #endif // __TBB_TEST_SKIP_AFFINITY
-
--#define OS_AFFINITY_SYSCALL_PRESENT ((__linux__ && !__ANDROID__) || (__FreeBSD_version >= 701000))
-+#define OS_AFFINITY_SYSCALL_PRESENT (__linux__ && !__ANDROID__)
+@@ -37,12 +37,11 @@
+ #endif
+ #include <string.h>
+ #include <sched.h>
+-#elif __FreeBSD__
+-#include <unistd.h>
++#if __FreeBSD__
+ #include <errno.h>
+-#include <string.h>
+ #include <sys/param.h>
+ #include <sys/cpuset.h>
++#endif
+ #endif
+ #include <thread>
- #if OS_AFFINITY_SYSCALL_PRESENT
-+
- void get_thread_affinity_mask(std::size_t& ncpus, std::vector<int>& free_indexes) {
- cpu_set_t* mask = nullptr;
- ncpus = sizeof(cpu_set_t) * CHAR_BIT;
diff --git a/devel/onetbb/files/patch-test-tbbmalloc-test_malloc_compliance.cpp b/devel/onetbb/files/patch-test-tbbmalloc-test_malloc_compliance.cpp
deleted file mode 100644
index 0773770d4ab3..000000000000
--- a/devel/onetbb/files/patch-test-tbbmalloc-test_malloc_compliance.cpp
+++ /dev/null
@@ -1,13 +0,0 @@
-Backport b2b2a9d65b30b869962de8140a44f5b29a3072fd
-
---- test/tbbmalloc/test_malloc_compliance.cpp.orig 2021-06-30 08:19:55 UTC
-+++ test/tbbmalloc/test_malloc_compliance.cpp
-@@ -91,7 +91,7 @@ void limitMem( size_t limit )
- }
- if (rlim.rlim_max==(rlim_t)RLIM_INFINITY)
- rlim.rlim_cur = (limit > 0) ? limit*MByte : rlim.rlim_max;
-- else rlim.rlim_cur = (limit > 0 && limit<rlim.rlim_max) ? limit*MByte : rlim.rlim_max;
-+ else rlim.rlim_cur = (limit > 0 && static_cast<rlim_t>(limit)<rlim.rlim_max) ? limit*MByte : rlim.rlim_max;
- ret = setrlimit(RLIMIT_AS,&rlim);
- if (0 != ret) {
- REPORT("Can't set limits: errno %d\n", errno);
diff --git a/devel/onetbb/pkg-plist b/devel/onetbb/pkg-plist
index 5caccb0fcac2..045e649bc53e 100644
--- a/devel/onetbb/pkg-plist
+++ b/devel/onetbb/pkg-plist
@@ -4,6 +4,7 @@ include/oneapi/tbb/blocked_range2d.h
include/oneapi/tbb/blocked_range3d.h
include/oneapi/tbb/blocked_rangeNd.h
include/oneapi/tbb/cache_aligned_allocator.h
+include/oneapi/tbb/collaborative_call_once.h
include/oneapi/tbb/combinable.h
include/oneapi/tbb/concurrent_hash_map.h
include/oneapi/tbb/concurrent_lru_cache.h
@@ -24,6 +25,7 @@ include/oneapi/tbb/detail/_concurrent_unordered_base.h
include/oneapi/tbb/detail/_config.h
include/oneapi/tbb/detail/_containers_helpers.h
include/oneapi/tbb/detail/_exception.h
+include/oneapi/tbb/detail/_export.h
include/oneapi/tbb/detail/_flow_graph_body_impl.h
include/oneapi/tbb/detail/_flow_graph_cache_impl.h
include/oneapi/tbb/detail/_flow_graph_impl.h
@@ -37,6 +39,7 @@ include/oneapi/tbb/detail/_flow_graph_tagged_buffer_impl.h
include/oneapi/tbb/detail/_flow_graph_trace_impl.h
include/oneapi/tbb/detail/_flow_graph_types_impl.h
include/oneapi/tbb/detail/_hash_compare.h
+include/oneapi/tbb/detail/_intrusive_list_node.h
include/oneapi/tbb/detail/_machine.h
include/oneapi/tbb/detail/_mutex_common.h
include/oneapi/tbb/detail/_namespace_injection.h
@@ -51,6 +54,7 @@ include/oneapi/tbb/detail/_segment_table.h
include/oneapi/tbb/detail/_small_object_pool.h
include/oneapi/tbb/detail/_string_resource.h
include/oneapi/tbb/detail/_task.h
+include/oneapi/tbb/detail/_task_handle.h
include/oneapi/tbb/detail/_template_helpers.h
include/oneapi/tbb/detail/_utils.h
include/oneapi/tbb/detail/_waitable_atomic.h
@@ -91,6 +95,7 @@ include/tbb/blocked_range2d.h
include/tbb/blocked_range3d.h
include/tbb/blocked_rangeNd.h
include/tbb/cache_aligned_allocator.h
+include/tbb/collaborative_call_once.h
include/tbb/combinable.h
include/tbb/concurrent_hash_map.h
include/tbb/concurrent_lru_cache.h
@@ -138,14 +143,14 @@ lib/cmake/TBB/TBBTargets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/TBB/TBBTargets.cmake
lib/libtbb.so
lib/libtbb.so.12
-lib/libtbb.so.12.3
-lib/libtbbbind_2_4.so
-lib/libtbbbind_2_4.so.3
-lib/libtbbbind_2_4.so.3.3
+lib/libtbb.so.12.4
+lib/libtbbbind_2_0.so
+lib/libtbbbind_2_0.so.3
+lib/libtbbbind_2_0.so.3.4
lib/libtbbmalloc.so
lib/libtbbmalloc.so.2
-lib/libtbbmalloc.so.2.3
+lib/libtbbmalloc.so.2.4
lib/libtbbmalloc_proxy.so
lib/libtbbmalloc_proxy.so.2
-lib/libtbbmalloc_proxy.so.2.3
-libdata/pkgconfig/tbb.pc
+lib/libtbbmalloc_proxy.so.2.4
+libdata/pkgconfig/tbb%%PCSUFX%%.pc