aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Algorithm-C3
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2006-03-26 20:58:10 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2006-03-26 20:58:10 +0000
commit3c3b636224309cc50ae3620c3a6ad101cfd0b65f (patch)
treee8bfe7a14b9460f915720e99ca4a76aabac2c77d /devel/p5-Algorithm-C3
parent648d55d812934c92221031fd7ecc525051d98417 (diff)
downloadports-3c3b636224309cc50ae3620c3a6ad101cfd0b65f.tar.gz
ports-3c3b636224309cc50ae3620c3a6ad101cfd0b65f.zip
This module implements the C3 algorithm.
WWW: http://search.cpan.org/dist/Algorithm-C3/ PR: ports/93819 Submitted by: Lars Balker Rasmussen <lars@balker.dk>
Notes
Notes: svn path=/head/; revision=158198
Diffstat (limited to 'devel/p5-Algorithm-C3')
-rw-r--r--devel/p5-Algorithm-C3/Makefile31
-rw-r--r--devel/p5-Algorithm-C3/distinfo3
-rw-r--r--devel/p5-Algorithm-C3/pkg-descr9
-rw-r--r--devel/p5-Algorithm-C3/pkg-plist2
4 files changed, 45 insertions, 0 deletions
diff --git a/devel/p5-Algorithm-C3/Makefile b/devel/p5-Algorithm-C3/Makefile
new file mode 100644
index 000000000000..290ec67d3e40
--- /dev/null
+++ b/devel/p5-Algorithm-C3/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: Algorithm-C3
+# Date created: 25 Feb 2006
+# Whom: Lars Balker Rasmussen <lars@balker.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Algorithm-C3
+PORTVERSION= 0.01
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Algorithm
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars@balker.dk
+COMMENT= A module for merging hierarchies using the C3 algorithm
+
+BUILD_DEPENDS= p5-Test-Simple>=0.47:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= Algorithm::C3.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires perl 5.8.x or later, install lang/perl5.8
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Algorithm-C3/distinfo b/devel/p5-Algorithm-C3/distinfo
new file mode 100644
index 000000000000..d7ba3087d9f2
--- /dev/null
+++ b/devel/p5-Algorithm-C3/distinfo
@@ -0,0 +1,3 @@
+MD5 (Algorithm-C3-0.01.tar.gz) = 1627146f60e34dcffcb2386adefa466a
+SHA256 (Algorithm-C3-0.01.tar.gz) = 256c040e50d1a6f4acf5df4ff324f1211bd5408e36cf1122b2c1780191a20e92
+SIZE (Algorithm-C3-0.01.tar.gz) = 6095
diff --git a/devel/p5-Algorithm-C3/pkg-descr b/devel/p5-Algorithm-C3/pkg-descr
new file mode 100644
index 000000000000..ee795dfcc33a
--- /dev/null
+++ b/devel/p5-Algorithm-C3/pkg-descr
@@ -0,0 +1,9 @@
+This module implements the C3 algorithm. I have broken this out
+into it's own module because I found myself copying and pasting
+it way too often for various needs. Most of the uses I have for
+C3 revolve around class building and metamodels, but it could
+also be used for things like dependency resolution as well since
+it tends to do such a nice job of preserving local precendence
+orderings.
+
+WWW: http://search.cpan.org/dist/Algorithm-C3/
diff --git a/devel/p5-Algorithm-C3/pkg-plist b/devel/p5-Algorithm-C3/pkg-plist
new file mode 100644
index 000000000000..19c3dbea10e3
--- /dev/null
+++ b/devel/p5-Algorithm-C3/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/Algorithm/C3.pm
+@dirrmtry %%SITE_PERL%%/Algorithm