aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Iterator-Util/Makefile
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2007-09-08 01:12:10 +0000
committerMark Linimon <linimon@FreeBSD.org>2007-09-08 01:12:10 +0000
commit9839011ec3910790376ce9ace5e2a1c5bcb2781f (patch)
tree41c61966bf1404bd3cfce06493a35d6a1a4acfc6 /devel/p5-Iterator-Util/Makefile
parent41a56135d1e8a68844e4c575702cdbad451d7322 (diff)
downloadports-9839011ec3910790376ce9ace5e2a1c5bcb2781f.tar.gz
ports-9839011ec3910790376ce9ace5e2a1c5bcb2781f.zip
Welcome bsd.perl.mk. Add support for constructs such as USE_PERL5=5.8.0+.
Drop support for antique perl. Work done by: gabor Sponsored by: Google Summer of Code 2007 Hat: portmgr
Notes
Notes: svn path=/head/; revision=199069
Diffstat (limited to 'devel/p5-Iterator-Util/Makefile')
-rw-r--r--devel/p5-Iterator-Util/Makefile10
1 files changed, 2 insertions, 8 deletions
diff --git a/devel/p5-Iterator-Util/Makefile b/devel/p5-Iterator-Util/Makefile
index 7941ff36d4d7..75d28a1133eb 100644
--- a/devel/p5-Iterator-Util/Makefile
+++ b/devel/p5-Iterator-Util/Makefile
@@ -20,12 +20,6 @@ RUN_DEPENDS+= ${BUILD_DEPENDS}
MAN3= Iterator::Util.3
-PERL_CONFIGURE= yes
+PERL_CONFIGURE= 5.8.0+
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500800
-IGNORE= requires at least Perl5.8 due to dependencies
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>